Bug 759983 - RFE: Features for Skynet integration
RFE: Features for Skynet integration
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michael Hideo
Ding-Yi Chen
:
Depends On: 757621 758587 831887
Blocks: 755802
  Show dependency treegraph
 
Reported: 2011-12-04 23:56 EST by Matthew Casperson
Modified: 2014-08-04 18:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 20:55:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2011-12-04 23:56:52 EST
I need to get a few features implemented for the integration with Skynet:

1. Deterministic URLs to the editor for a specific document
2. The ability to get translation statistics (like x% completed) for a document via the REST interface..
3. The ability to list the available translation resources for a document. At the moment the ITranslationResources.getTranslations() function assumes the caller is asking for a specific language, which forces me run through every locale when downloading the translations (50 odd locales * 500 documents makes for a very lengthy downloading process).
4. The ability to create a project, project revision, specify languages and assigned a user to a language via the REST API . This is so I can create the Skynet project via code rather than having to set it up manually via the web page each time.
Comment 1 Sean Flanigan 2012-06-13 20:15:10 EDT
For point 1, you can now use a URL like this:

https://translate.example.com/webtrans/Application.html?project=skynet-topics&iteration=1&localeId=fr&doc=7368-139660#view:doc;doc:7368-139660

The parameter '&doc=7368-139660' is optional, but the client will load quite slowly without it, because it will populate the docs list with every Skynet topic.  That parameter will ensure a filtered view, which only shows that topic.


For the other points, could I get you to submit separate RFEs with more detailed requirements, with me on the CC list?

Point 3 is a little unclear, but I think it might already be covered by ITranslationResources.getResources in v1.4 or SourceDocResource.getResource() in v1.6.   (It's the same REST resource, we just changed the Java mappings.)

Point 4: unofficially, you can already create a project/version through REST - IProjectResource.put and IProjectIterationResource.put.  You can't specify a project's languages this way yet though.  

I'm not sure what you mean about assigning users to languages, or why Skynet needs to do it.  Please expand on all of these requirements when you create the separate RFE.
Comment 2 Lee Newson 2012-06-13 22:43:56 EDT
Although you had already informed me about point 1, thanks again for the clarification and a bit of extra information.

I've made an RFE for point 2 (Bug #831894) and 3 (Bug #831887) which should clear it up.

As for point 4 in regards to the users, I haven't a clue what Matt meant on this one so I'll leave that for him to answer.
Comment 3 Sean Flanigan 2012-06-13 23:42:37 EDT
Also regarding point 4, does this imply that Skynet will be pushing to multiple projects in Zanata?  Otherwise, you won't need to create projects very often...
Comment 4 Isaac Rooskov 2013-02-18 20:55:58 EST
Given point 3 is being tracked in its own bug and Number 4 seems to have been fixed, closing this issue. 

Please reopen if there is a problem.
Comment 5 Misty Stanley-Jones 2013-07-25 02:05:03 EDT
Isaac, how has Number 4 been fixed?

Note You need to log in before you can comment on or make changes to this bug.