Bug 76032 - Redhat-Config-Packages crashes when run
Redhat-Config-Packages crashes when run
Status: CLOSED DUPLICATE of bug 70972
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 18:19 EDT by Harry Ising
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 18:19:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Ising 2002-10-15 18:19:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When going to run the Redhat packager, the screen will display for a moment and
then disappear. Running Readhat 8.0 on Athalon 1.7 with 512mb of RAM. Using KDE
as X window front end

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Click on the RedHat
2.Go to System Settings
3.Go to packages
	

Actual Results:  Will display package screen for a moment, then screen will
disappear

Expected Results:  Should be able to see web pasge of installed packages

Additional info:

Here is the error message running redhat-config-package from the command line

Traceback (most recent call last):
File "/usr/share/redhat-config-packages/MainWindow.py", line 163, in ?
comps = im.readCompsViaMethod(hdlist, progress.update)
File "/usr/share/redhat-config-packages/method.py", line 488, in readCompsViaMethod
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 387, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 471, in readCompsFile
    self.setupStateDicts(packages)
  File "/usr/share/redhat-config-packages/comps.py", line 420, in setupStateDicts
    for prov in h[rpm.RPMTAG_PROVIDES]:
TypeError: iteration over non-sequence
Comment 1 Jeremy Katz 2002-10-31 17:50:25 EST
Fixed in CVS and in the packages at
http://people.redhat.com/~katzj/redhat-config-packages/

*** This bug has been marked as a duplicate of 70972 ***

Note You need to log in before you can comment on or make changes to this bug.