Bug 76035 - Installer crashes when multiple SCSI CD-ROM drives exist.
Installer crashes when multiple SCSI CD-ROM drives exist.
Status: CLOSED DUPLICATE of bug 74719
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 18:41 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 18:42:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-15 18:41:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
Installing from CDs on a vanilla x86 machine with three SCSI CD-ROM drives all
attached to the same channel of an LSI 21040.  Machine boots fine and goes into
X for the install process fine; however, just after the RedHat splash screen
anaconda crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Start the install process from CD on a machine with multiple SCSI CD-ROM drives.
2.  Watch installer go down in flames.
	

Actual Results:  Machine bombed just after the RedHat splash screen.

Expected Results:  RedHat should have been installed successfully.

Additional info:

After doing some research, apparently this bug is already known of on the
newsgroups; it just hasn't been submitted to bugzilla.  Workarounds include 1)
disconnecting "extra" SCSI CD-ROM drives during install, reconnecting them when
install is complete, or 2) starting the install with the 'noprobe' option (which
isn't an option for me because I'm installing from CD.

The full error message is as follows:

Traceback (most recent call back):
File "/usr/bin/anaconda", line 639 in ?
  itutil.makedrivedevicenodes()
File "/usr/lib/bin/itutil.py" line420,in makedrivedevicenodes
  isys.makedevinode (drive,"dev%s"%(drive))
File /usr/lib/isys.py"line265 in makedevInode -isysmakedev/inode (name,fn)
systemerror:(2,'no such file or directory")

Commentary in this post in linux.redhat.install suggest that this crash is due
to the installer not being able to deduce the CD-ROM format when more than one
SCSI CD-ROM is installed:

http://groups.google.com/groups?dq=&hl=en&lr=&ie=UTF-8&selm=aohjs3%242gbq%241%40innferno.news.tiscali.de
Comment 1 Jeremy Katz 2002-10-15 19:01:16 EDT
The update disk available at
http://people.redhat.com/~katzj/80update.img includes a fix for this problem

*** This bug has been marked as a duplicate of 74719 ***

Note You need to log in before you can comment on or make changes to this bug.