Bug 74719 - Anaconda dies in iutil.makeDriveDeviceNodes()
Anaconda dies in iutil.makeDriveDeviceNodes()
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 76035 76293 76306 76881 77181 82711 83711 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 01:10 EDT by Jürgen Botz
Modified: 2007-04-18 12:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 21:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jürgen Botz 2002-10-01 01:10:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020915

Description of problem:
During install, right after X starts up the first time, this happens... (copied
from screen by hand)...

1...2...3...4...5.... X server started successfully
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 639, in ?
    iutil.makeDriveDeviceNodes()
  File "/usr/lib/anacdonda/iutil.py", line 420, in makeDriveDeviceNodes
    isys.makeDevInode(drive, "/dev/%s" % (drive,))
  File "/usr/lib/anaconda/isys.py", line 255 in makeDevInode
    _isys.mkdevinode (name, fn)
SystemError: (2, 'No such file or directory')
install exited abnormally
...


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try installing on my particular machine
2.
3.
	

Actual Results:  anaconda dies

Expected Results:  nice new redhat 8.0 install

Additional info:

My system is a bit unusual... I have a lot of devices.  RAID 5 on 3Ware card is
normal boot device (seen as SCSI by BIOS), 2 CD ROMS and a tape drive on Adaptec
SCSI, and an IDE disk.
Comment 1 Mathieu Chouquet-Stringer 2002-10-01 07:46:38 EDT
I have the same exact error... I found it first in bug #70350 but I don't have
any LS-120 drive (everything is scsi on my machine but I've got two scsi cards,
one (Adaptec), detected first, which is used by my scanner and the other (Tekram
u2w) connected to my hard-drives and cdrom drives).

When it happened, I switch to virtual console 3 and saw this:
* Started mini-wm
* anaconda floppy device fd0

fd0?? I'm not installing from a floppy but from a cd so I rebooted again from
the cd and I can confirm there's a floppy access (ie light) just before anaconda
crashes.

Moreover, I tried other ways of starting the install:
- first time I tried this: linux askmethod (booting from cd and install via
nfs), failed
- then I tried: linux text askmethod, failed
- nothing, failed
- I also tried booting on floppy (using bootnet.img) but same result (and I also
got the floppy access)

If I can be of any help, let me know.
Comment 2 Paul Rupe 2002-10-01 20:00:10 EDT
Exact same problem here (log at <http://www.geocities.com/paul19223/rh8.txt>).  I have an Adaptec AHA-2940UW with two hard drives and three CD drives attached.  It all works in RH7.3, but the 8.0 installer dies in exactly the same place.  I've tried graphical and text modes with the same result.  All CDs passed MD5SUM and linux mediacheck.

More details:
  Athlon 1.4 GHz
  Epox 8K7A
  256MB PC2100 RAM
  Leadtek GeForce 4 Ti4400
  SBLive!
  Linksys 10/100 Ethernet card
  Adaptec AHA-2940UW
  SCSI ID 0: Quantum Viking II 4.5GB
  SCSI ID 1: Quantum Atlas 10k 18GB
  SCSI ID 2: Pioneer DVD-303R
  SCSI ID 3: Yamaha CRW-4260
  SCSI ID 4: Creative CD-ROM
  No IDE devices of any kind
Comment 3 Jeremy Katz 2002-10-02 18:21:40 EDT
If you download the update image available at
http://people.redhat.com/~katzj/isys-update.img and boot with 'linux updates',
providing the update disk written to a floppy when prompted, what is the last
line of output that you get?
Comment 4 Paul Rupe 2002-10-02 18:44:23 EDT
The last line was
  trying to make scd2 as /dev/scd2
scd2 should be my third CD-ROM drive, which identifies itself as
  Host: scsi0 Channel: 00 Id: 04 Lun: 00
    Vendor: NEC      Model: CD-ROM DRIVE:500 Rev: 2.8 
    Type:   CD-ROM                           ANSI SCSI revision: 02
The drive also works fine in my current RH7.3 installation.
Comment 5 Mathieu Chouquet-Stringer 2002-10-02 19:18:23 EDT
Same thing here:
trying to make scd2 as /dev/scd2
Comment 6 Need Real Name 2002-10-04 12:47:08 EDT
I got the same problem on an 440LX board with Adaptec 2940UW and
this configuration:

scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.6
        <Adaptec 2940 Ultra SCSI adapter>
        aic7880: Ultra Wide Channel A, SCSI Id=7, 16/253 SCBs

  Vendor: PLEXTOR   Model: CD-ROM PX-40TS    Rev: 1.05
  Type:   CD-ROM                             ANSI SCSI revision: 02
(scsi0:A:3): 20.000MB/s transfers (20.000MHz, offset 15)
  Vendor: PLEXTOR   Model: CD-R   PX-R412C   Rev: 1.07
  Type:   CD-ROM                             ANSI SCSI revision: 02
(scsi0:A:4): 10.000MB/s transfers (10.000MHz, offset 8)
  Vendor: PIONEER   Model: DVD-ROM DVD-303   Rev: 1.10
  Type:   CD-ROM                             ANSI SCSI revision: 02
(scsi0:A:6): 20.000MB/s transfers (20.000MHz, offset 8)

Installing from PX CDROM. Also tried to disable floppy during install,
as installer crashes right after accessing floppy. No change.
Comment 7 Mathieu Chouquet-Stringer 2002-10-04 12:52:36 EDT
Note that it seems we've all got 3 cd drives (I've got one DVD, one regular CD
drive and one CD writer):
  Vendor: PIONEER   Model: DVD-ROM DVD-305   Rev: 1.05
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: PIONEER   Model: CD-ROM DR-U16S    Rev: 1.01
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: YAMAHA    Model: CRW3200S          Rev: 1.0d
  Type:   CD-ROM                             ANSI SCSI revision: 02
Comment 8 das_deniz 2002-10-04 17:39:50 EDT
i have a question - you all are obviously not typing all these error/status msgs
in by hand - how are you dumping this information (especially the anaconda death
msg)?

i also have a LX motherboard with the adaptec 2940UW built in.

i have two scsi devices in the chain (one happens to have multiple luns)

i'll forward the results of the isys-update shortly.
Comment 9 Jürgen Botz 2002-10-04 17:45:56 EDT
> i have a question - you all are obviously not typing all 
> these error/status msgs in by hand

Why is that "obvious"?  I did in fact type it in by hand.  In fact, I
copied it down on paper first, then typed it in again.  Being careful 
to get everything accurate down to the last blank space.  Total time
about 20 minutes.  Would have been a bit quicker using a laptop rather
than 2 stops via paper.

:j


Comment 10 Mathieu Chouquet-Stringer 2002-10-04 17:56:33 EDT
Same thing for me but I've got a laptop so I didn't have to use a sheet of
paper. Does RedHat support installation through serial (I don't remember and my
cds are at home)? If so, a serial dump would be quite handy too.
Comment 11 das_deniz 2002-10-04 18:09:14 EDT
well thanks for the faithful reproduction! - as for my boot with the updates -
there's no more on the other virtual terminals than there was without the
isys.img - and i saw a bunch of the trying to make scd0 and scd1 and the last
scd2 messages before the anaconda barf.

now i'm going to try the install after removing my 'extra' cd-rom drive.

here's my hard drive and SCSI bus info (cut and paste from dmesg :-)
(note the AIC 7880 scsi bios is v1.32 - if it matters)

hda: WDC WD300BB-00AUA1, ATA DISK drive
hdc: Maxtor 90845D4, ATA DISK drive
hdd: IC35L120AVVA07-0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
blk: queue c03d4284, I/O limit 4095Mb (mask 0xffffffff)
hda: 58633344 sectors (30020 MB) w/2048KiB Cache, CHS=3649/255/63, UDMA(33)
blk: queue c03d45e8, I/O limit 4095Mb (mask 0xffffffff)
hdc: 16514064 sectors (8455 MB) w/512KiB Cache, CHS=16383/16/63, UDMA(33)
blk: queue c03d4734, I/O limit 4095Mb (mask 0xffffffff)
hdd: 241254720 sectors (123522 MB) w/1863KiB Cache, CHS=239340/16/63, UDMA(33)
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 >
 hdc: [PTBL] [1027/255/63] hdc1 hdc2 hdc3 hdc4 < hdc5 hdc6 hdc7 >
 hdd: hdd1
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
pci_hotplug: PCI Hot Plug PCI Core version: 0.4
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 131072 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 243k freed
VFS: Mounted root (ext2 filesystem).
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.6
        <Adaptec 2940 Ultra SCSI adapter>
        aic7880: Ultra Wide Channel A, SCSI Id=7, 16/253 SCBs

  Vendor: YAMAHA    Model: CRW8424S          Rev: 1.0j
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: NAKAMICH  Model: MJ-5.16S          Rev: 1.02
  Type:   CD-ROM                             ANSI SCSI revision: 02
(scsi0:A:1): 10.000MB/s transfers (10.000MHz, offset 15)
  Vendor: NAKAMICH  Model: MJ-5.16S          Rev: 1.02
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: NAKAMICH  Model: MJ-5.16S          Rev: 1.02
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: NAKAMICH  Model: MJ-5.16S          Rev: 1.02
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: NAKAMICH  Model: MJ-5.16S          Rev: 1.02
  Type:   CD-ROM                             ANSI SCSI revision: 02

Comment 12 Mathieu Chouquet-Stringer 2002-10-04 21:12:52 EDT
Good idea! I wanted to do that the smart way (ie by disabling 2 cd drives in the
scsi card nvram) but the driver sym53cxxx or ncr53cxxx don't support this
feature with Tekram's nvram (only Symbios, now LSI's nvram). Damn, I will have
to disconnect them physically...
Comment 13 Mathieu Chouquet-Stringer 2002-10-04 21:17:40 EDT
Damn, it made a difference: with only one cd drive connected it works. I'm
installing right now and let you know if it works with 2.
Comment 14 das_deniz 2002-10-04 21:45:49 EDT
yep - you guys might have guess from the delay that it works - i'm typing from
8.0 now... by the way if you see this error during install:

----------------| ERROR |----------------

The second stage of the install which
you have selected does not match the
boot disk which you are using. This
shouldn't happen, and I'm rebooting
your system now.

                 ---------
                 |  OK   |
                 ---------

It's likely you've not terminated your scsi chain correctly
(this, ahem, happened to me....)

good fortunes bug fixing around this one red hat and thanks for 8.0
Comment 15 Jeremy Katz 2002-10-05 10:23:37 EDT
Appears to definitely be the multiple SCSI cdrom drives.  I'll cobble a machine
together the beginning of next week to investigate and come up with a fix.
Comment 16 Sam Carmello 2002-10-06 02:50:38 EDT
Hi,

I also am have the same problem with a l440gx motherboard.  I have
three SCSI disks on the first internal SCSI interface and a Nakamichi MJ 5.16
Mini Changer CD-ROM drive on the second channel.  This system 
install fine on 7.3.  I believe I have fixed all the SCSI termination problems
when getting 7.2 operational.  Mabe I missed one??

I have tried to install it in text and graphics mode.  Does not work.

My error message is the same as jurgen@botz.org at the top of this bug
report except for the line number on the last "file: ..." line.  My line number
is 
265.


My Configuration lines are:
Video Card : Cirrus Logic GD5480
Monitor: unable to probe
mouse : generic 3 Button Mouse (ps/2)

By the way I am using a Belkin OnmiView 8 port KVM Switch and a Nec 1700M
LCD monitor.

The system has 2 450 MHZ processors with 1.5 GB of RAM.


The mini-changer has the same SCSI line as das_deniz@yahoo.com except
my revision numbers are 1.11 instead of 1.02 and my changer is on the second
SCSI bus all by its self.
 
Hope this help the cause.  I would love to get 8.0 installed.  I have some
problems with system crashes and lockup under both 7.2 and 7.3.  This is
very !!!@@@@@!!!!.  Ugggggg...

thanks
Comment 17 Jeremy Katz 2002-10-10 17:54:32 EDT
Can you try with the update disk available at
http://people.redhat.com/~katzj/80update.img and see if it fixes the problem?
Comment 18 Need Real Name 2002-10-11 12:35:21 EDT
Fixed the problem for me. Thank you very much! I know why I love
RedHat!
Comment 19 Sam Carmello 2002-10-11 15:27:54 EDT
Hi,

   Forgive my lack of understanding.  How do I use this image file to generate a
new CD or boot
floppy, if this is what is done with it.  The image file has an _isys.so file
and an image.py file.

Sam
Comment 20 Jeremy Katz 2002-10-11 17:43:33 EDT
Instructions on using an update disk can be found at
http://rhlinux.redhat.com/anaconda/updatedisks.html.

This fix has been committed to CVS
Comment 21 Jeremy Katz 2002-10-15 19:01:10 EDT
*** Bug 76035 has been marked as a duplicate of this bug. ***
Comment 22 Sam Carmello 2002-10-15 21:53:47 EDT
Thanks for the instructions.  The fix worked the first time.
		Thanks Sam
Comment 23 Jeremy Katz 2002-10-19 15:50:27 EDT
*** Bug 76293 has been marked as a duplicate of this bug. ***
Comment 24 Jeremy Katz 2002-10-19 15:51:42 EDT
*** Bug 76306 has been marked as a duplicate of this bug. ***
Comment 25 Jeremy Katz 2002-10-31 15:11:33 EST
*** Bug 76881 has been marked as a duplicate of this bug. ***
Comment 26 Jeremy Katz 2002-11-05 00:25:04 EST
*** Bug 77181 has been marked as a duplicate of this bug. ***
Comment 27 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 28 Jeremy Katz 2003-01-28 20:56:27 EST
*** Bug 82711 has been marked as a duplicate of this bug. ***
Comment 29 Jeremy Katz 2003-02-09 21:22:50 EST
*** Bug 83711 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.