Bug 760431 - Moving to a new page does not refresh the translation textboxes (ghost translations)
Moving to a new page does not refresh the translation textboxes (ghost transl...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.4.3-SNAPSHOT
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
: 757575 (view as bug list)
Depends On:
Blocks: 757575 zanata-1.4.5
  Show dependency treegraph
 
Reported: 2011-12-06 02:27 EST by Runa Bhattacharjee
Modified: 2013-03-03 21:22 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.4.5-SNAPSHOT (20120123-1407)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-26 21:34:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Runa Bhattacharjee 2011-12-06 02:27:00 EST
Description of problem:

After translating the last entry of a page, when a translator moves to a new page the first string of the next page is initially not-clickable. Eventually when it becomes editable, it shows the translations from the first entry of the earlier page next to the first entry of the second page. An edit in this box affects the first entry of the first page.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. sign in at translate.zanata.org and open a project with multiple pages
2. complete the translations on page 1 and move to page 2
3. click the first entry on page 2
4. if the box does not become editable, click on the second string
5. move back to the first entry on page 2 again
6. check if any translations show up on that box
7. edit the translation
8. go back to the 1st entry on page 1 and check if the edits from step 7 have been applied here.
  
Actual results:

The translation for string 1 from page 1 are displayed. If it is not displayed, then go back to step 2, edit the last string on page 1 again and move to page 2. Repeat step 3.

Expected results:

The first entry of page 2 should display an empty text box or any existing translations for the string at that position correctly.

Additional info:

Does not happen all the time.
Comment 4 Alex Eng 2012-01-09 19:51:54 EST
Implemented loading page while table is loading data from server to avoid clicking on editor when table is fully loaded.

See https://github.com/zanata/zanata/commit/7f2d94acb15a8ee7029d698b309a42bcb20d3602 for 1.4 and 

https://github.com/zanata/zanata/commit/406a4a43e2defcb2f403d36e8a1c2291ff11dc34 for 1.5
Comment 5 Alex Eng 2012-01-09 19:58:47 EST
Correction 

Implemented loading page while table is loading data from server to avoid
clicking on editor when table is NOT fully loaded.
Comment 7 Sean Flanigan 2012-01-11 01:56:09 EST
Testing on 1.5, the "Loading" page seems to be appearing after I save each row, which is a bit annoying.  Can we restrict "Loading" to page loads?  It doesn't make sense to lock out the entire page when only one row is being loaded.

Also, something is messing up the behaviour when I click in another row - instead of saving the current row and opening the editor on the new row, it performs the implicit save, I get "Loading", and the table comes back, *but* the editor is not open.  (This doesn't happen with Ctrl-S or Alt-K, only with the mouse.)  This problem may be the same thing as https://bugzilla.redhat.com/show_bug.cgi?id=773175#c1
Comment 8 Ding-Yi Chen 2012-01-11 22:04:04 EST
The symptom also appeared in Zanata version 1.4.5-SNAPSHOT (20120111-1411).
Comment 10 Alex Eng 2012-01-18 21:56:21 EST
Patch fixes: 
1.5 - https://github.com/zanata/zanata/commit/4c60ef81531d41bdb2cc5a0539f8e10c0efc3bea
1.4 - In progress
Comment 12 Sean Flanigan 2012-01-19 22:06:51 EST
I've been finding (on 1.5) that using the Copy Source button can lead to ghost translations:

When I click Copy Source, the English string gets copied to the target, but *sometimes* the editor does not open.  When this happens, the table continues to show the old value.  If I click the editor cell, it opens, and shows the copied English string.  But if I cancel the edit, the table goes back to showing the old value.
Comment 14 Sean Flanigan 2012-01-22 22:53:25 EST
More changes in 
https://github.com/zanata/zanata/commit/a9e2f8f52e9e2e95cd60ac04b360ce4e8638459e (1.4)

and https://github.com/zanata/zanata/commit/d5872cc6a4e49be94cced4d60a1849917f8b2567 (master)

Please test with and without the search filter active.  The algorithm used to update table rows is different, and more complex, when the filter is active.
Comment 15 Ding-Yi Chen 2012-01-23 01:23:16 EST
VERIFIED with Zanata version 1.4.5-SNAPSHOT (20120123-1407)
Comment 16 Sean Flanigan 2012-01-23 19:21:57 EST
*** Bug 757575 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.