Bug 76044 - Mouse movement does not effect screen saver
Mouse movement does not effect screen saver
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
8.0
athlon Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
: 110042 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 22:17 EDT by Brad
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 17:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PSN - xscreensaver config x86 (9.14 KB, text/plain)
2003-11-14 12:06 EST, Paul Nasrat
no flags Details
PSN - XFree86 log (44.99 KB, text/plain)
2003-11-14 12:09 EST, Paul Nasrat
no flags Details
PSN - XF86Config (3.78 KB, text/plain)
2003-11-14 12:11 EST, Paul Nasrat
no flags Details

  None (edit)
Description Brad 2002-10-15 22:17:28 EDT
Description of Problem:
When the screen saver starts to engage and the screen fades to black, you move
the mouse to stop it but it just keeps going until it fases out totally and then
 detects the mouse movement and the screen saver goes off. If you hit a keyboard
key instead (while it is fading to black), it stops the screen saver immediately.


Version-Release number of selected component (if applicable):


How Reproducible:
Let the screen saver start to engage and then move the mouse.

Actual Results:
Screen saver engages.


Expected Results:
Screen saver stops immediately.


Additional Information:
The mouse is a Microsoft X05-87477 Optical USB Mouse.
Comment 1 Mike A. Harris 2002-10-18 23:38:43 EDT
Reassigning to xscreensaver.  I don't really see how this has anything
to do with XFree86.  (I also can't reproduce it)
Comment 2 David Tenser 2003-11-14 07:54:39 EST
I can confirm that this bug still exists in Fedora Core 1.
Comment 3 Bill Nottingham 2003-11-14 11:26:49 EST
*** Bug 110042 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2003-11-14 11:56:33 EST
Can you provide greater specific details about which particular
screensaver you are using, with what settings, what timing, wether
DPMS is on or not, and any other relevent details?  Can both of you
please attach your X server log and config file also?  Just in case
there is something patternic to be seen in them.

The problem does not seem to be a "screensaver is broken for everyone
in all circumstances" problem, so we need to know what the specific
circumstances are that this problem occurs in, in order to be able
to reproduce it locally.

Comment 5 Paul Nasrat 2003-11-14 12:06:29 EST
Created attachment 95976 [details]
PSN - xscreensaver config x86

Visual confirmation based on wall clock timing although it's quite subtle. 
Tested on both Fedora x86 and Fedora ppc.

Platform fedora core 1
XFree86-4.3.0-42
xscreensaver-4.14-2
Comment 6 Paul Nasrat 2003-11-14 12:09:49 EST
Created attachment 95977 [details]
PSN - XFree86 log

Steps I used to reproduce:

1) Hit lock screen
2) Move moush (touchpad - synaptics and touchpad adb) - observe time
3) Unlock
4) Hit lock screen
5) Hit key
6) Unlock
7) Hit lock screen
8) Wait until fade complete
Comment 7 Paul Nasrat 2003-11-14 12:11:24 EST
Created attachment 95978 [details]
PSN - XF86Config

Only major difference to a standard config is synaptics driver, however have
tested on alternate (ibook2 adb touchpad) configuration.
Comment 8 David Masterson 2005-01-05 18:20:10 EST
I think this happens for me in FC2.  In particular, I have a Logitech
Trackman Wheel and, when I'm just using the wheel to scroll through a
document, the screensaver doesn't seem to recognize the movement and,
so, activates while I'm scrolling around (after timeout period).
Comment 9 Ray Strode [halfline] 2005-05-11 17:32:42 EDT
Hi,

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.