Bug 76057 - non-AA fonts render poorly
non-AA fonts render poorly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 07:09 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-16 07:51:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot: Mozilla, MSIE5.5 under WINE, and Konqeror - all with non-aliased fonts. Fonts in Konqueror looks very bad - as they do in the rest of KDE3 (187.24 KB, image/png)
2002-10-16 07:50 EDT, R.K.Aa.
no flags Details

  None (edit)
Description Need Real Name 2002-10-16 07:09:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
Disabling anti-aliasing in KDE or Gnome leads to very poorly rendered fonts.
Non-AA fonts in RedHat 7.x rendered very cleanly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. disable anti-alias fonts using either KDE font selector or Gnome font selector.
2. logout / login
3. view ugly fonts 	

Actual Results:  After switching to non-AA fonts , nearly all fonts (with the
odd exception of lucida console) rendered very poorly. Arial, Sans, Serif, etc
all rendered poorly.

Expected Results:  Fonts as crisp as those in RH7.3

Additional info:

I tinkered a little trying different fonts , font families and using xfs or
using XFree's built in rendering but nothing appeared to have any impact.

Fonts displayed using xfontsel (e.g arial , helvetica) rendered very cleanly.
xfontsel listed some fonts not available to KDE/GNOME, notably Helvetica.

I can provide some screen shots if my explanation is poor. Problem occured on
multiple machines (tyan/nvidia , compaq/ati , compaq/matrox , dell/laptop) and
multiple screen resolutions.
Comment 1 R.K.Aa. 2002-10-16 07:12:26 EDT
Font rendering under RH8 is a disaster here too.
Similar: bug 75431
Comment 2 R.K.Aa. 2002-10-16 07:50:58 EDT
Created attachment 80625 [details]
screenshot: Mozilla, MSIE5.5 under WINE, and Konqeror - all with non-aliased fonts. Fonts in Konqueror looks very bad - as they do in the rest of KDE3
Comment 3 Mike A. Harris 2002-10-16 20:58:22 EDT
The freetype package in Red Hat Linux 8.0 has the truetype bytecode
interpreter disabled, which is the default for a freetype build from
upstream sources.  This is due to:  http://www.freetype.org/patents.html

In order for you to get fonts looking like they did previously in Red
Hat Linux 7.3, you'll need to rebuild freetype yourself with the
bytecode interpreter enabled.

Both GNOME and KDE in Red Hat Linux 8.0 use the Xft2 library for rendering
client side fonts.  They do not use the legacy XFree86 font support which
is provided by the xfs font server (or X server itself if you manually
configure X to serve fonts).  The only applications which use server
side fonts currently are Mozilla, Evolution, xchat, and a few other
applications, including some older apps that come with XFree86 itself.

xlsfonts shows you what fonts are available via the font server, and
NOT what is available to GNOME/KDE via Xft.

The solution to these types of problems is one or more of:

- install nicer fonts from off the web, from Microsoft, or somewhere else
- rebuild freetype with the bytecode interpreter
- use AA fonts

Anti aliasing, and font hinting are the two primary methods of making
truetype fonts look nice.  We've disabled the font hinting because of
the legal situation with Apple's patents.  You've disabled anti-aliasing
for whatever reasons.  The result is as expected - crap fonts.  Absolutely
nothing we can do about this.  Leave AA fonts enabled if you want nice
fonts, and/or re-enable the freetype bytecode interpreter.
Comment 4 R.K.Aa. 2002-10-16 21:09:05 EDT
I think you misunderstand me.. both the AA and non-AA fonts under Xft2 look like
crap to me. The solution was simply to run qtconfig and disable antialiased font
rendering in it for QT. And for GTK, to add "export GDK_USE_XFT=0" to .bashrc

After a restart all my TT fonts looked like I prefer them; crisp clear and smooth.
I've enjoyed TT fonts on RH for the past 4 years and am very pleased with the
quality - now also in RH8 :)

(I had to copy the tt fonts to ~/.fonts and run fc-cache though. xfs no longer
makes Gnome or KDE see my previous TT fonts, allthough xlsfonts lists them.
Well - i'm happy again. And for others who read this: There is no need to
recompile freetype if all you want is to NOT anti-alias fonts.
Comment 5 Need Real Name 2002-10-21 06:45:00 EDT
I recompiled with the bytecode enabled and non-AA fonts now look fine.

Edited ftoption.h and recompiled freetype-* , Xft-* and fontconfig-*, rebuilt
all and re-installed all. May not be necessary to rebuild all of those.


Note You need to log in before you can comment on or make changes to this bug.