Bug 760605 - Alt-<letter> produces <letter>
Summary: Alt-<letter> produces <letter>
Keywords:
Status: CLOSED DUPLICATE of bug 626792
Alias: None
Product: Fedora
Classification: Fedora
Component: Terminal
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-06 15:54 UTC by Denys Vlasenko
Modified: 2011-12-06 16:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 16:47:36 UTC


Attachments (Terms of Use)

Description Denys Vlasenko 2011-12-06 15:54:55 UTC
I use Midnight Commander. I noticed that Alt-s and similar functions don't work - instead, ordinary letter s is sent to the tty.

I went to Edit->Preferences->Shortcuts and deleted all Fn definitions (since mc uses F1-10 and I don't want Terminal to intercept them). I also ticked "[X] disable all menu access keys" and "[X] Disable menu shortcut keys" checkboxes, for the same reason. I did it before I noticed that Alt-<letter> doesn't work, meaning: I don't know whether Alt-<letter> used to work correctly before I did that.

I verified that it's not a mc problem: I installed good old xterm and there Alt-<letter> works as expected:

$ hexdump -C
   <--------------------- I'm pressing Alt-s, then Ctrl-D several times
^[s00000000  1b 73                       |.s|
$

whereas in bare Terminal (no mc) it does not:

$ hexdump -C
   <--------------------- I'm pressing Alt-s, then Ctrl-D several times
s00000000  73                            |s|
$

I also tested it in Linux VT and Alt-s works there.

Comment 1 Denys Vlasenko 2011-12-06 15:55:37 UTC
Affected version is:

Terminal-0.4.8-1.fc16.i686

Comment 2 Kevin Fenzi 2011-12-06 16:47:36 UTC

*** This bug has been marked as a duplicate of bug 626792 ***


Note You need to log in before you can comment on or make changes to this bug.