Bug 76062 - Xvideo v4l bridge does not scale out properly
Summary: Xvideo v4l bridge does not scale out properly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 82776 82779 82791
TreeView+ depends on / blocked
 
Reported: 2002-10-16 13:03 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 18:07:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-16 13:03:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
Xvideo v4l bridge does not scale out properly: when using for instance xawtv
with -xv flag, rescaling window should alsways give a rescaled image, be the
image smaller than video output (726x625 or sthg like that. this works), or
bigger than the video output (this doesn't work: when trying to maximize window
in 1024x768 for instance, only the center of the screen has the video, and there
is a black border outside).
It doesn't work as well on RedHat 8.0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.needs a video card (any bt878 will be ok), and properly configured XFree86,
with v4l loaded, and any resolution > to 800x600
2.start xawtv -xv -scale (or xawtv alone, since it's the defaults)
3.maximize window / do fullscreen
	

Actual Results:  video appears only in the center, big black frame around.

Expected Results:  fullscreen or maximized image.

Additional info:

This has been reported as working with other distributions and other X servers.
Enabling VidMod extension use in video programs solves the problem, when that
extension can be used by the program.
Problem has been seen using Mach64, Rage 128 and Radeon chips.
More information can be seen on these threads of kwintv/qtvision development
mailing list where the problem has been discussed:
http://mail.kde.org/pipermail/kwintv/2002-October/thread.html#214
http://mail.kde.org/pipermail/kwintv/2002-October/thread.html#229

Comment 1 Mike A. Harris 2002-10-17 11:02:44 UTC
I do not have this hardware in order to test...

Does this problem occur for you, or anyone else in Red Hat Linux 8.0 as well?

Comment 2 Need Real Name 2002-10-17 11:06:31 UTC
As seen on the mailing list, this problem occurs for me on RH 7.3 and for
Michael Kedl who is using RH 8.0. He was the guy who tested it with commercial X
server.

Comment 3 Mike A. Harris 2002-10-17 11:18:47 UTC
Since I do not have access to the hardware this problem is occuring on,
I strongly suggest reporting this problem on the xpert@xfree86.org
mailing list and also the dri-devel@dri.sf.net mailing list to
accelerate the issue by letting many more developers be aware of the
problem.

I do not see any evidence presented in any of those emails that this
is a Red Hat Linux specific problem.

Without the hardware, or a known patch that adds support or fixes
a bug, there is not really a lot that I can do until upstream developers
whom are made aware of the problem can comment on it and/or fix it.

Please keep this report updated with any information you come across.

Thanks.


Comment 4 Michael Schwendt 2002-10-20 21:56:25 UTC
Sounds like it is related to bug #74684 and not reproducible here.


Comment 5 Mike A. Harris 2004-09-24 18:07:47 UTC
Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.


Note You need to log in before you can comment on or make changes to this bug.