Bug 760996 - Add support for the /usr move
Add support for the /usr move
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 760997 760999 761000
  Show dependency treegraph
 
Reported: 2011-12-07 09:45 EST by Harald Hoyer
Modified: 2012-02-15 09:13 EST (History)
7 users (show)

See Also:
Fixed In Version: rpm-4.9.1.2-4.fc16.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 760997 760999 761000 (view as bug list)
Environment:
Last Closed: 2012-01-28 15:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for rpm to provide checks for the usr move (2.82 KB, patch)
2011-12-07 09:45 EST, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Harald Hoyer 2011-12-07 09:45:56 EST
Created attachment 541981 [details]
patch for rpm to provide checks for the usr move

To enable the /usr move
https://fedoraproject.org/wiki/Features/UsrMove
we need the attached patch in rpm.
This helps to guard against updating converted F17 packages on an unconverted system.
Comment 1 Tom "spot" Callaway 2011-12-07 10:12:10 EST
Why is X-CheckUnifiedBindir there? I thought the merge of /usr/sbin and /usr/bin was abandoned?
Comment 2 Kay Sievers 2011-12-07 10:28:06 EST
It's just a simple flag for possible future use, it is not used today, but
we want it in RPM, to have this option.
Comment 3 James Antill 2011-12-07 10:45:14 EST
 As the yum maintainer I would also ask that you not update F16 (and _esp_ F15) with this new rpm. With this patch, and the corresponding packaging changes "yum upgrade" won't do the transaction ... which is as good as it gets for upgrading to F17.

 We can prominently put release notes everywhere saying "you _have_ to use preupgrade/anaconda" for F17 upgrades due to usrmove. Having magic lists of instructions to pretend yum upgrade works is just asking for pain, I don't need. And for anyone who _really_ needs their fix, I'm sure someone will do special rpm builds on repos.fedorapeople.org or something.
Comment 4 Harald Hoyer 2011-12-07 11:24:00 EST
(In reply to comment #3)
>  As the yum maintainer I would also ask that you not update F16 (and _esp_ F15)
> with this new rpm. With this patch, and the corresponding packaging changes
> "yum upgrade" won't do the transaction ... which is as good as it gets for
> upgrading to F17.
> 
>  We can prominently put release notes everywhere saying "you _have_ to use
> preupgrade/anaconda" for F17 upgrades due to usrmove. Having magic lists of
> instructions to pretend yum upgrade works is just asking for pain, I don't
> need. And for anyone who _really_ needs their fix, I'm sure someone will do
> special rpm builds on repos.fedorapeople.org or something.

So, you don't want the manual "dracut convert + manual yum update" to be possible?
Comment 5 James Antill 2011-12-07 11:42:35 EST
 Not from default F16, no.

 Basically no matter what we do "yum upgrade" isn't going to "work", by any sane definition of how it's been used since Fedora 1 => Fedora 2. There is no plan to fix it so it will work, and have this feature. So I'd rather not pretend it can kind of work, if you just reboot 3 times and run random commands correctly.
 If we do that, then even if we say it's unsupported (as it "always" has been) I think users will correctly be filing 666 bugs against yum.

 Just tell everyone they _have_ to use preupgrade/anaconda and leave it at that.
Comment 6 Harald Hoyer 2011-12-07 12:30:21 EST
(In reply to comment #5)
>  Not from default F16, no.
> 
>  Basically no matter what we do "yum upgrade" isn't going to "work", by any
> sane definition of how it's been used since Fedora 1 => Fedora 2. There is no
> plan to fix it so it will work, and have this feature. So I'd rather not
> pretend it can kind of work, if you just reboot 3 times and run random commands
> correctly.
>  If we do that, then even if we say it's unsupported (as it "always" has been)
> I think users will correctly be filing 666 bugs against yum.
> 
>  Just tell everyone they _have_ to use preupgrade/anaconda and leave it at
> that.

in this case only bug 760999 has to be accepted.
Comment 7 Harald Hoyer 2011-12-07 13:33:13 EST
(In reply to comment #6)
> (In reply to comment #5)
> >  Not from default F16, no.
> > 
> >  Basically no matter what we do "yum upgrade" isn't going to "work", by any
> > sane definition of how it's been used since Fedora 1 => Fedora 2. There is no
> > plan to fix it so it will work, and have this feature. So I'd rather not
> > pretend it can kind of work, if you just reboot 3 times and run random commands
> > correctly.
> >  If we do that, then even if we say it's unsupported (as it "always" has been)
> > I think users will correctly be filing 666 bugs against yum.
> > 
> >  Just tell everyone they _have_ to use preupgrade/anaconda and leave it at
> > that.
> 
> in this case only bug 760999 has to be accepted.

oh and maybe the RHEL-6 version for the build servers bug 761000
Comment 8 Fedora Update System 2012-01-24 13:51:58 EST
rpm-4.9.1.2-4.fc16.1 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpm-4.9.1.2-4.fc16.1
Comment 9 Panu Matilainen 2012-01-25 01:17:20 EST
Hmm, I was under the impression that we were not going add this to F15 and F16 to "force" use of preupgrade/anaconda. No big deal, just a little surprised to see these updates.
Comment 10 Kay Sievers 2012-01-25 04:48:24 EST
(In reply to comment #9)
> Hmm, I was under the impression that we were not going add this to F15 and F16
> to "force" use of preupgrade/anaconda.

That is right. We will still not suport live-udates without a reboot step
that converts the filesystem with dracut/anaconda, and prepares for the
installation of the converted packages.

The F15 F16 RPM patch is only to ease the suport for the build systems which
run on F15/F1. Secondary architectures need to run Fedora there. Release
Engineering asked us to do that.
Comment 11 Fedora Update System 2012-01-25 17:26:53 EST
Package rpm-4.9.1.2-4.fc16.1:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpm-4.9.1.2-4.fc16.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0912/rpm-4.9.1.2-4.fc16.1
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-01-28 15:56:02 EST
rpm-4.9.1.2-4.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Harald Hoyer 2012-02-15 09:13:10 EST
test could be a test-convertfs.spec with:

Requires: rpmlib(X-CheckUnifiedSystemdir)

which would not install, unless the filesystem is converted.

And a test-unconvertfs.spec with:

Conflicts: rpmlib(X-CheckUnifiedSystemdir)

which should install fine on an unconverted filesystem (RHEL-6).

Note You need to log in before you can comment on or make changes to this bug.