This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 761259 - System is unable to automount floppy disk (1.44 Mb.) from usb-floppy external device
System is unable to automount floppy disk (1.44 Mb.) from usb-floppy external...
Status: CLOSED DUPLICATE of bug 766010
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
15
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 17:23 EST by Alberto Chiodi
Modified: 2011-12-09 16:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-09 16:09:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alberto Chiodi 2011-12-07 17:23:43 EST
System:

Fedora fc 15 x86_64 with xfce 4.8 
kernel 2.6.41.1-1.fc15.x86_64
autofs-5.0.5-38.fc15.x86_64

others:

hal-filesystem-0.5.14-6.fc15.x86_64
hal-libs-0.5.14-6.fc15.x86_64
hal-info-20090716-4.fc15.noarch
hal-0.5.14-6.fc15.x86_64
hal-devel-0.5.14-6.fc15.x86_64


If I insert my usb-floppy disk with no floppy, dmesg is

 usb 1-1.3: new full speed USB device number 6 using ehci_hcd
[ 5986.340579] usb 1-1.3: New USB device found, idVendor=054c, idProduct=002c
[ 5986.340584] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5986.340588] usb 1-1.3: Product: USB Floppy Drive
[ 5986.340590] usb 1-1.3: Manufacturer: Sony
[ 5986.345759] usb-storage 1-1.3:1.0: Quirks match for vid 054c pid 002c: 1
[ 5986.345798] scsi9 : usb-storage 1-1.3:1.0
[ 5987.350440] scsi 9:0:0:0: Direct-Access     SONY     USB-FDU          7.03 PQ: 0 ANSI: 0 CCS
[ 5987.350511] scsi: killing requests for dead queue
[ 5987.350578] scsi: killing requests for dead queue
[ 5987.350635] scsi: killing requests for dead queue
[ 5987.350691] scsi: killing requests for dead queue
[ 5987.350746] scsi: killing requests for dead queue
[ 5987.350802] scsi: killing requests for dead queue
[ 5987.350914] scsi: killing requests for dead queue
[ 5987.350998] scsi: killing requests for dead queue
[ 5987.351410] sd 9:0:0:0: Attached scsi generic sg2 type 0
[ 5987.430427] sd 9:0:0:0: [sdb] Attached SCSI removable disk

If I insert a floppy disk also in dmesg appears

 sd 9:0:0:0: [sdb] 2880 512-byte logical blocks: (1.47 MB/1.40 MiB)
[ 6095.471789] sd 9:0:0:0: [sdb] No Caching mode page present
[ 6095.471794] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[ 6095.535771] sd 9:0:0:0: [sdb] No Caching mode page present
[ 6095.535776] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[ 6095.615723]  sdb:

And no other.
Nothing appears on desktop.

Note:
I'm able to mount it as root if I open a root terminal and I manually mount 
floppy with normal commands.
"mkdir /media/floppy"
"mount /dev/sdb /media/floppy"


From this dmesg about my old usb-key flash drive with no internal partition

 usb 1-1.3: new high speed USB device number 5 using ehci_hcd
[ 5601.030256] usb 1-1.3: New USB device found, idVendor=0457, idProduct=0151
[ 5601.030261] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 5602.164120] usbcore: registered new interface driver uas
[ 5602.170917] Initializing USB Mass Storage driver...
[ 5602.171023] usb-storage 1-1.3:1.0: Quirks match for vid 0457 pid 0151: 80
[ 5602.171076] scsi8 : usb-storage 1-1.3:1.0
[ 5602.171175] usbcore: registered new interface driver usb-storage
[ 5602.171178] USB Mass Storage support registered.
[ 5613.165250] scsi 8:0:0:0: Direct-Access     USB2.0   USB Flash Disk   0.00 PQ: 0 ANSI: 2
[ 5613.165326] scsi: killing requests for dead queue
[ 5613.165392] scsi: killing requests for dead queue
[ 5613.165448] scsi: killing requests for dead queue
[ 5613.165503] scsi: killing requests for dead queue
[ 5613.165557] scsi: killing requests for dead queue
[ 5613.165612] scsi: killing requests for dead queue
[ 5613.165732] scsi: killing requests for dead queue
[ 5613.165827] scsi: killing requests for dead queue
[ 5613.166821] sd 8:0:0:0: [sdb] 249344 512-byte logical blocks: (127 MB/121 MiB)
[ 5613.167021] sd 8:0:0:0: Attached scsi generic sg2 type 0
[ 5613.167436] sd 8:0:0:0: [sdb] Write Protect is off
[ 5613.167441] sd 8:0:0:0: [sdb] Mode Sense: 00 00 00 00
[ 5613.168063] sd 8:0:0:0: [sdb] Asking for cache data failed
[ 5613.168067] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 5613.171854] sd 8:0:0:0: [sdb] Asking for cache data failed
[ 5613.171858] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 5613.278509]  sdb: sdb1
[ 5613.281124] sd 8:0:0:0: [sdb] Asking for cache data failed
[ 5613.281129] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 5613.281132] sd 8:0:0:0: [sdb] Attached SCSI removable disk
[ 5613.543130] SELinux: initialized (dev sdb1, type vfat), uses genfs_contexts

And after this, regularly appears on desktop usb-key windows with its contents.


So: I think problem is only that system is unable to assign a units for device.
If system was able to trasform /dev/sdb to /dev/sdb1 as it does for usb-key...
I think that is missing only one line of program... 

Thank you for your kind attention

Alberto Chiodi
Comment 1 Ian Kent 2011-12-07 18:20:53 EST
What have you added to the autofs configuration to have it
automount floppy discs?

Are you sure you have logged this against the correct component?
Comment 2 Alberto Chiodi 2011-12-07 18:42:57 EST
Sorry... I'm only an end user not a programmer or developer
I search in google and I've found many blog about manual mount command.
One post spoke about autofs and particularly autofs files in /etc; nothing about other components.
I try add this line in file /etc/auto.misc
floppy		-fstype=auto		:/dev/fd0
under line
cd		-fstype=iso9660,ro,nosuid,nodev	:/dev/cdrom

But it doesn't work; nor after autofs restart or reboot.

Also: in the /dev directory there isn't old fd0 device but new /proc/self....

When I posted this bug I chose this program with no idea about if it's a autofs problem or hal or other components.
I bag your pardon
Comment 3 Ian Kent 2011-12-07 19:18:39 EST
(In reply to comment #2)
> Sorry... I'm only an end user not a programmer or developer
> I search in google and I've found many blog about manual mount command.
> One post spoke about autofs and particularly autofs files in /etc; nothing
> about other components.
> I try add this line in file /etc/auto.misc
> floppy  -fstype=auto  :/dev/fd0

Right, that is using autofs.

> under line
> cd  -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom
> 
> But it doesn't work; nor after autofs restart or reboot.
> 
> Also: in the /dev directory there isn't old fd0 device but new /proc/self....

But autofs has no control over device file creation.

The floppy must be recognised by the system and its device
file created before you can configure autofs to use it since
you must use the device file in the map entry.

> 
> When I posted this bug I chose this program with no idea about if it's a autofs
> problem or hal or other components.
> I bag your pardon

To be honest Gnome vfsd is better suited to automatically
mounting and umounting removable media.

Perhaps you should remove the autofs configuration and change
the component to vfsd. If that isn't the correct component
hopefully the maintainer will know the correct one.

Ian
Comment 4 Alberto Chiodi 2011-12-07 19:52:34 EST
Thank'you

Alberto
Comment 5 Alberto Chiodi 2011-12-07 19:53:57 EST
Thank'you

Alberto
Comment 6 Alberto Chiodi 2011-12-09 16:09:02 EST

*** This bug has been marked as a duplicate of bug 766010 ***

Note You need to log in before you can comment on or make changes to this bug.