Bug 76126 - keyboard and mouse have problems after apm resume in XFree86
keyboard and mouse have problems after apm resume in XFree86
Status: CLOSED DUPLICATE of bug 63509
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 04:12 EDT by Justin Albstmeijer
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Albstmeijer 2002-10-17 04:12:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
After I resume from an apm suspend,

- I am not able to move a window with the mouse
- Keyboard repeats stops working

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. apm -s 
2. (push resume button on laptop)
3. hold key in any x app
4. hold the mouse button on title bar of any window, and try to move	

Actual Results:  - I am not able to move a window with the mouse
- Keyboard repeats does not work

Expected Results:  
Both mouse and keyboard should react like before the apm suspend

Additional info:


Laptop:  Dell inspiron 4000

tested with touch pad on laptop and external ps2 mouse
Comment 1 Thomas Vander Stichele 2002-10-18 04:39:53 EDT
Phew, I thought I was the only one and it's been driving me crazy ;)

Laptop is a Toshiba Tecra 8200.

I don't seem to have it every time I put it to sleep, if I did then I would have
gone crazy already.

Any suggestions on what to do here ? I didn't have this with any previous
version of Red Hat (7.1-7.3)
Comment 2 Mike A. Harris 2002-10-18 18:39:35 EDT
APM related problems are almost always due to buggy BIOS's and other
hardware specific weird crap.  The kernel sometimes works around these
hardware issues.  Perhaps something fell out of the kernel that was
working before.

CC'ing our kernel maintainer for comment.
Comment 3 Mike A. Harris 2002-10-18 18:42:31 EDT
What CPU are you using?  What specific kernel arch is installed and
running?

Is this an Athlon?
Comment 4 Justin Albstmeijer 2002-10-19 13:10:22 EDT
No this is a pentium III 800Mhz running a i686 kernel.

I'll will test monday if the mouse/keyboard behaviour restores after a X 
restart.

Additional info:

- Non of the previous 7.x versions have had this problem.
- In the graphical installation mode I already experienced strange 
mouse/keyboard behaviour. I had to install in text mode.. sometimes I was not 
able to activate an input field.

Comment 5 Tuomo Soini 2002-12-04 03:40:00 EST
Same problem with Dell Inspiron 4150 after upgrade to redhat 8.0. Redhat 7.3
worked but kbdrate went down to default after resume. This is a bug in rh 8.0.
Both were running same kernel.
Comment 6 Tuomo Soini 2002-12-04 04:04:16 EST
This seems to be duplicate to bug #72151. I think this is gnome2 bug and not
Xfree bbug at all. After unsuspend "xset r on" fixes it. But question is. Who
disables repeat?
Comment 7 Mike A. Harris 2002-12-19 06:43:41 EST

*** This bug has been marked as a duplicate of 63509 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:49:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.