Bug 76186 - TB ipcalc:60:network
TB ipcalc:60:network
Status: CLOSED DUPLICATE of bug 76267
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 18:46 EDT by Ben Hicks
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-18 11:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Hicks 2002-10-17 18:46:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Traceback (most recent call last):
  File "/usr/sbin/neat", line 496, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/bin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/bin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 60,
in network
    return re.match("NETWORK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'


Thats the error I get. It popped up again while filling out this form. I am new
to Linux and have no knowledge of how to solve this problem. The insall was a
fresh one with all componernts on a  new blank hard drive.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Click the Redhat Icon
2.System settings
3.network

THen change any of the settings and click apply. The error occurs every time.
	

Additional info:
Comment 1 Ben Hicks 2002-10-17 18:49:33 EDT
I just got this error also

Traceback (most recent call last):
  File "/usr/sbin/neat", line 774, in update_devicelist
    self.activedevicelist = NetworkDevice().get()
  File "/usr/bin/../share/redhat-config-network/netconfpkg/Control.py", line 63,
in __init__
  File "/usr/bin/../share/redhat-config-network/netconfpkg/Control.py", line 66,
in load
OSError: Too many open files


Many Thanks In Advanvce
Comment 2 Harald Hoyer 2002-10-18 11:05:13 EDT
last error is due to a bug in rhpl ... see bug #74989
Comment 3 Harald Hoyer 2002-11-12 08:03:19 EST

*** This bug has been marked as a duplicate of 76267 ***

Note You need to log in before you can comment on or make changes to this bug.