Bug 76267 - TB ipcalc:60:network
Summary: TB ipcalc:60:network
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 76186 77568 77911 79901 83396 (view as bug list)
Depends On:
Blocks: 81720
TreeView+ depends on / blocked
 
Reported: 2002-10-18 22:20 UTC by Rodolfo A. Jofre
Modified: 2007-04-18 16:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 09:46:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
redhat-config-network tool crash dump (735 bytes, text/plain)
2002-10-18 22:22 UTC, Rodolfo A. Jofre
no flags Details

Description Rodolfo A. Jofre 2002-10-18 22:20:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I have 2 NICs. The first is embedded in the motherboard, and it was recognized
at once, as an Intel Etherexpress Pro 100B. Later, I installed the second NIC (a
very generic PCI NIC, with a Davicom chip). It was also recognized on the fly,
but I did not configure its network parameters.
After that I needed to take it out of the computer, so I tried to delete it from
the system by deleting it using the RedHat-config-network tool. Everything
worked fine until the moment I hit the "Close" or the "Apply" buttons. to save
the changes. Then it comes the crash:

There is "exception occured" message, and the window says what I include attached.

This happens when using English as the default language and also with spanish
(as a default or not)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log as root 
2.Open the Start here icon
3.Go to Network Settings.
4. Delete the second NIC
5.Comfirm it.
6. Hit the apply or the close button
7. Answer Yes to the question: Do you want to save your changes?
8. Voila! There you have it.
	

Actual Results:  Ditto. I could not even save the dumping to the file I wanted,
but it only saves it to /tmp/dump. Unless I delete it or rename it, the dumping
routine has problems too.

Expected Results:  The second ethernet card should have been removed from the
system.

Additional info:

Comment 1 Rodolfo A. Jofre 2002-10-18 22:22:20 UTC
Created attachment 81024 [details]
redhat-config-network tool crash dump

Comment 2 Harald Hoyer 2002-11-11 10:00:10 UTC
*** Bug 77568 has been marked as a duplicate of this bug. ***

Comment 3 Harald Hoyer 2002-11-12 13:03:12 UTC
*** Bug 76186 has been marked as a duplicate of this bug. ***

Comment 4 Harald Hoyer 2002-11-17 14:29:24 UTC
*** Bug 77911 has been marked as a duplicate of this bug. ***

Comment 5 Harald Hoyer 2003-01-09 14:00:13 UTC
*** Bug 79901 has been marked as a duplicate of this bug. ***

Comment 6 Harald Hoyer 2003-01-13 15:19:25 UTC
new packages to test available at:
ftp://people.redhat.com/harald/redhat-config-network/1.1.87-1/
ftp://people.redhat.com/harald/rhpl/0.74-2/

Comment 7 Harald Hoyer 2003-02-10 11:27:43 UTC
*** Bug 83396 has been marked as a duplicate of this bug. ***

Comment 8 Jeremy Young 2003-03-17 21:04:41 UTC
Can we get a link to take care of this?:
pyxf86config >= 0.3.2 is needed by rhpl-0.74-2

I searched for pyxf86config, but only found the version that I already have.  

Comment 9 Harald Hoyer 2003-03-20 16:16:14 UTC
hmm... you may take the rawhide version of it, or try to install with nodeps

Comment 10 Jeremy Young 2003-03-20 19:31:19 UTC
Running the two RPMs with --nodeps successfully solved my iteration of this
problem.  

I had two network cards, when I tried to change information about either card
when both cards were installed as devices, the program crashed.  

Now it works as it should.  Updates immediately, and the routing tables are correct.

Thanks!

Comment 11 Bruce Gong 2003-09-18 13:07:55 UTC
Redhat Version 9

I can'y save information after I changed the settings of my network!

Command 'netconfig' can work successfully and the informations are 
saved.But 'red-hat-config-network' will course Python error,and the program get 
into crash.

I once used Redhat version 8 on this computer,in that version I can change 
network settings at my will and connect to Internet by ADSL service.

I installed rp-pppoe-3.5-3.i386 and rp-pppoe-gui-3.5-3.i386 ,the GUI also can't 
receive my settings.The sheet event do not echo the charactors I typed.

This made me upset many days!!




Comment 12 Harald Hoyer 2004-06-04 09:46:41 UTC
Closing due to inactivity. Reopen, if the problem is still existing.


Note You need to log in before you can comment on or make changes to this bug.