Bug 76200 - Install crashes with python error when installing zlib
Install crashes with python error when installing zlib
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Need Real Name
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 23:10 EDT by Need Real Name
Modified: 2015-01-07 19:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-01 14:14:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File Anaconda provided after install problem with zlib-1.1.4-4 (J. Sotack) (33.17 KB, text/plain)
2002-11-02 09:17 EST, John Sotack
no flags Details

  None (edit)
Description Need Real Name 2002-10-17 23:10:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90; Hotbar 
4.1.7.0; .NET CLR 1.0.3705)

Description of problem:
I get this when installing Redhat 8.0 (Boxed version)

It seems to crash on the installation of zlib-1.1.4-4 (errors with somthing 
like 'missing or bad rpm') then throws the following.

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 719, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 283, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 119, in getFilename
    f = open("/mnt/source/.discinfo")
IOError: [Errno 2] No such file or directory: '/mnt/source/.discinfo'


Could it be a bad image? if so, how do i get a new one? i bought this at 
compusa today


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 8.0
2.
3.
	

Additional info:
Comment 1 Mark Johnson 2002-10-19 19:59:56 EDT
I received the same problem on a purchased copy of RedHat 8.0.  To attempt to 
get around the problem was able to prove, that the error had nothing to do with 
the packages selected.  Also tested the problem for a RedHat 7.2 system with a 
selected upgrade as well as for a clean install.
Comment 2 Need Real Name 2002-10-19 20:32:33 EDT
I returned the software back to Compusa claiming it was a bad image... but the 
new Boxed RH 8.0 I got has the same issue..  I was finally able to install it 
with using a different CD ROM Drive..  I was using an Acer CD-RW. but it seemed 
to install fine using a plain old Lite-ON 24X CD ROm...  just a note, that Acer 
CD-RW is pretty new and works on everything else...  just picky i guess...
Comment 3 Matt Borchers 2002-10-26 23:02:16 EDT
This also happens to me with my new version of RH Linux 8.0 I bought at 
CompUSA.  It failed during the first install at the zlib package.  It is 
a "file not found" error.  I performed a mediacheck from the boot prompt and it 
told me that my media is fine (PASS).  I tried an install for a 2nd time and 
got the same error.

From what you have said, it is a CD Drive issue.  I also have an Acer CD-RW.  I 
have no other CD drive.  What can I do?
Comment 4 Need Real Name 2002-10-26 23:39:54 EDT
My Acer drive is now working fine with RH 8.0 .... all i had to do was clean 
it. lol

Use any old laser lens cleaning disk...  it may work for you..
Comment 5 John Sotack 2002-11-02 09:17:48 EST
Created attachment 83165 [details]
File Anaconda provided after install problem with zlib-1.1.4-4 (J. Sotack)
Comment 6 John Sotack 2002-11-02 09:53:28 EST
I believe I am having an identical problem.  My install fails at zlib-1.1.4-4. 
The last line of my install.log is I have provided the anacdump.txt that Anconda
wrote to floppy above.  I checked my disk 1 serveral times to rule out an
intermittent media problem.  The error message I get begins:

Traceback (most recent call last)
File "use/bin/anaconda", line 694 in ?
intf.run(id, displatch, configFileData)

The last line in my install log is "Installing zlib-1.1.4-4."

Another message I have been getting is "/mnt/sysimage/var/tmp/zlib-1.1.4-4.i386.rpm
cannnot be opened.  This id due to a missing file, a bad package, or bad media.
 Press <restrart> to try again."

If I CTRL-ALT-F2, cd to /mnt.sysimage/var/tmp/ and then to ls-l, the following
is dislayed for this file:
    "-rw-r--r-- lroot 0 3660 Nov 2 09:45  zlib-1.1.4-4.i386.rpm"
I may have left a 0 off the size since I recall it being about 36K but wrote
down 3660.

My CD rom is a QPS Que! CD-RW 16x/10x/40x.
After the problem occured I went to the qps website and updated my firmware /
calibrated my laser and the problem was not fixed.

The zip file for the CD-RW uppgrade contained a directory called "Acer Days".  I
think the word ACER may have appeared during the flash upgrade or laser calibration.

John Sotack
Comment 7 John Sotack 2002-11-02 14:40:01 EST
***INSTALLATION SUCCEEDED WITH DIFFERENT CD-ROM DRIVE***: I have added an
additional CD-ROM drive (based on earlier comment from
fas-track@fas-track.net)to my system and successfully installed from it. 
Previously (see my earlier comments and attachments) I had multiply problems
when the install reached zlib-1.1.4.4.  Although my CD-ROM drive was branded
QPS, the firmware upgrade zip file did have a directory called "Acer Days", and
I think I saw Acer on the screen while flashing the drive.

I was able to get a CD-ROM drive (20-48X) at a surplus store for $20.  I had
been using my other drive with Red Had 7.3 although I had intermittent install
issues with the same drive and Red Hat 7.3 installing from RW media.

John Sotack
Comment 8 Rico Chen 2002-11-29 00:28:47 EST
I got the same problem when I installed RedHat 8.0 'cause I'm using a Acer 
10x4x32 CDRW. The solution I found was installing RedHat from HardDrive! This 
is how it works. 
1. You gotta have all the iso files (named psyche-i386-disc#.i386, #=1 to 5) 
stored in your harddrive and you know how to access them using Linux name 
system, for example "/hda1/redhatiso".
2. Copy the whole "dosutils" folder into wherever in the harddrive that can be 
access using MSDOS, let say C:\
3. Boot up your system into MSDOS, either using the windows98 command line 
mode or using a win9x boot disk.
4. Goto the "dosutils" folder and run autoboot.bat, Redhat will start its 
installer in no time, tell the installer where to get the iso files and there 
you go.
The only drawback of this method was that I couldn't use graphic mode when I'm 
installing. But it works for me 'cause I'm used to keyboard. Another thing I 
need to mention is that after I select the packages I wanted to install it 
took a while for the installer to begin installation and during that period 
the screen just looked like dead (it wasn't actually, you just need to be 
patient, maybe it won't happen to you).
It's not the perfect way to solve this problem yet but it's worthy since I 
don't need to pay $$ for a new CD Rom. Hope this help you a little.
Comment 9 Michael Lee Yohe 2002-12-01 14:14:03 EST
This appears to be a duplicate of Bug 75377.  Please refer to the instructions
in that bug report to see if the updated image provided will correct your problem.  

There should be a consolidation bug (Bug 75377 has instructions to patch the
installation to attempt to workaround the problem) to handle the ".discinfo"
related bug.

This bug should also be component Anaconda - since the zlib package has not
problems.

Note You need to log in before you can comment on or make changes to this bug.