Bug 76228 - ghostscript.spec, gimp-print.spec mutual build dependencies
ghostscript.spec, gimp-print.spec mutual build dependencies
Status: CLOSED DUPLICATE of bug 69576
Product: Red Hat Linux
Classification: Retired
Component: gimp-print (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2002-10-18 10:21 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-18 10:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-18 10:21:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021015

Description of problem:
Spec files for these two packages have mutually exclusive build dependencies. 

Version-Release number of selected component (if applicable):
ghostscript-7.05-20.src.rpm, gimp-print-4.2.1-5.src.rpm

How reproducible:

Steps to Reproduce:
1. Download SRPMS from rh8 mirror site to up2dated rh7.3 box.
2. Work through Dependency Hell, building and installing as needed
3. Found glitch at ghostscript.

Actual Results:  	
[/usr/src/redhat/SPECS]# rpm -bb ghostscript.spec
error: failed build dependencies:
        gimp-print-devel is needed by ghostscript-7.05-20
[/usr/src/redhat/SPECS]# rpm -bb gimp-print.spec
error: failed build dependencies:
        ghostscript-devel is needed by gimp-print-4.2.1-5

Expected Results:  build and install ghostscript, then build and install gimp-print

Additional info:

 I commented out the line in ghostscript.spec which requires gimp-print, and all
is well.
Comment 1 Tim Waugh 2002-10-18 10:26:48 EDT
All is not well when you build---you'll find that the gimp-print-ijs driver no
longer works.

The fix will be to trick gimp-print into not needing ijs-config I expect.

*** This bug has been marked as a duplicate of 69576 ***

Note You need to log in before you can comment on or make changes to this bug.