Bug 76229 - Mysqld crashes repeatedly
Mysqld crashes repeatedly
Status: CLOSED DUPLICATE of bug 77467
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-10-18 10:22 EDT by Chris Wirt
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-18 10:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Wirt 2002-10-18 10:22:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When connecting to mysql via tcp, the client is challenged for password.  After 
entering password, receives 'connection lost during query'.  A check of the 
mysql log shows that the server hung, the process was killed and restarted.  
Connections via linux sockets seem to work ok.  But any connection via tcp, 
even from the localhost, causes server to crash.  Have tried on 3 hardware 
configurations, problem seems to recur each time.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Install server and mysql software
2.  Start mysqld service
3.  Run Mysql_install_db script
4.  Create mysql root password via 'mysqladmin password <password>'
5.  Log into mysql as root via 'mysql -u root -p'
6.  Create root user for access over network via 'Grant all on *.* 
to 'root'@'%' identified by '<password>';'
7.  Reload priviliges via 'Flush Privileges;'
8.  Exit localhost mysql via 'Exit'
9.  Ping from another machine to test interface
10. Run 'nmap -sT localhost' from localhost and another machine to verify that 
port tcp:3306 is open
11. Run 'netstat' to verify port is listening
12. Run 'iptables' to verify no blocking rules apply
13. Try to connect from another host or from localhost via tcp with
    'mysql -u root -p -h <ip address>'
14. Should receive challenge for password
15. Enter password.  A pause of 1-2 seconds, followed by error message.
16. Check server logs
17. Verify uptime by logging into mysql from localhost and entering 
command 'Status;'


Actual Results:  Message that process mysqld hung and was killed, then 

Expected Results:  Should have been able to login

Additional info:

Have also installed newer version of mysql and client programs, but problem 
recurs.  Did not occur on equivalent machine in RedHat 7.1, which was what was 
running on this machine prior.  Not upgraded, however, but a full install 
Comment 1 Joe Orton 2002-12-12 07:34:23 EST

*** This bug has been marked as a duplicate of 77467 ***

Note You need to log in before you can comment on or make changes to this bug.