Bug 76303 - kudzu crashes on ieee1354 (firewire), preventing any other modules from loading
kudzu crashes on ieee1354 (firewire), preventing any other modules from loading
Status: CLOSED DUPLICATE of bug 72587
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-19 12:41 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-19 12:41:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Kudzu appears to use depmod, insmod, or modprobe to try to turn on the ieee1354
(firewire) port on the HP Pavilion ze1250 laptop.  When it does, the module
insert manages to crash that section, preventing any further module loads.  This
results in the sound card and network adapter not being functional.

Disabling kudzu (chkconfig'ing it off) prevents this from happening.  The
problem is not likely in kudzu directly, but in the firewire subsystem. 
However, as kudzu probes the firewire subsystem, this crash directly impacts the
rest of the kudzu functionality, and impairs the remaining module loads.

Unfortunately, there is no fine-grained method of telling kudzu (that I am aware
of) what to probe, and what to ignore.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Reboot laptop with kudzu enabled.  Occurs every time.
	

Additional info:

Oct 19 12:03:59 protein kernel: ohci1394: $Revision: 1.101 $ Ben Collins
<bcollins@debian.org>
Oct 19 12:03:59 protein kernel: PCI: Enabling device 00:0c.0 (0000 -> 0002)
Oct 19 12:03:59 protein kernel: PCI: No IRQ known for interrupt pin A of device
00:0c.0.
Oct 19 12:03:59 protein kernel: ohci1394: Failed to allocate shared interrupt 0
Oct 19 12:04:00 protein kernel: ieee1394: NodeMgr: host ohci1394 does not exist,
cannot remove
Oct 19 12:04:00 protein kernel: Unable to handle kernel NULL pointer dereference
at virtual address 00000004
Oct 19 12:04:00 protein kernel:  printing eip:
Oct 19 12:04:00 protein kernel: df8d3d6a
Oct 19 12:04:00 protein kernel: *pde = 00000000
Oct 19 12:04:00 protein kernel: Oops: 0002
Oct 19 12:04:00 protein kernel: ohci1394 ieee1394 ide-scsi scsi_mod ide-cd cdrom
mousedev keybdev hid input us
Oct 19 12:03:41 protein rc.sysinit: Mounting proc filesystem:  succeeded
Oct 19 12:04:01 protein kernel: CPU:    0
Oct 19 12:03:41 protein rc.sysinit: Unmounting initrd:  succeeded
Oct 19 12:04:01 protein kernel: EIP:    0010:[<df8d3d6a>]    Not tainted
Oct 19 12:04:01 protein netfs: Mounting other filesystems:  succeeded
Oct 19 12:03:41 protein sysctl: net.ipv4.ip_forward = 0
Oct 19 12:04:01 protein kernel: EFLAGS: 00010046
Oct 19 12:03:41 protein sysctl: net.ipv4.conf.default.rp_filter = 1
Oct 19 12:04:01 protein kernel:
Oct 19 12:03:41 protein sysctl: kernel.sysrq = 0
Oct 19 12:04:01 protein kernel: EIP is at hpsb_remove_host_R34144dc5 [ieee1394]
0x3a (2.4.18-14)
Oct 19 12:03:41 protein sysctl: kernel.core_uses_pid = 1
Oct 19 12:04:01 protein kernel: eax: 00000000   ebx: c220c000   ecx: 00000246  
edx: 00000000
Oct 19 12:03:41 protein rc.sysinit: Configuring kernel parameters:  succeeded
Oct 19 12:04:01 protein kernel: esi: c236f9c0   edi: 00000800   ebp: c23fec00  
esp: dc535e7c
Oct 19 12:03:41 protein date: Sat Oct 19 12:03:39 EDT 2002
Oct 19 12:04:01 protein kernel: ds: 0018   es: 0018   ss: 0018
Oct 19 12:03:41 protein rc.sysinit: Setting clock  (localtime): Sat Oct 19
12:03:39 EDT 2002 succeeded
Oct 19 12:04:01 protein apmd: apmd startup succeeded
Oct 19 12:04:01 protein apmd[423]: Version 3.0.2 (APM BIOS 1.2, Linux driver 1.16)
Oct 19 12:04:01 protein kernel: Process modprobe (pid: 279, stackpage=dc535000)
Oct 19 12:03:41 protein rc.sysinit: Loading default keymap succeeded
Oct 19 12:04:02 protein kernel: Stack: c220c000 c220d4ec 00000000 df8e0fe8
c220c000 c220d4ec c220d4ec 00000000
Oct 19 12:03:41 protein unicode_start: ^[%G
Oct 19 12:04:02 protein kernel:        c220d4ec df8e0adb c23fec00 df8e219f
00000000 df8e219f c220d4ec 00001000
Oct 19 12:03:41 protein rc.sysinit: Setting default font (latarcyrheb-sun16): 
succeeded
Oct 19 12:04:02 protein kernel:        00000400 c220c000 df8e2e00 df8e2e40
c23fec00 00000000 c01cb395 c23fec00
Oct 19 12:03:41 protein rc.sysinit: Setting hostname
protein.scalableinformatics.com:  succeeded
Oct 19 12:04:02 protein autofs: automount startup succeeded
Oct 19 12:04:02 protein kernel: Call Trace: [<df8e0fe8>] ohci1394_pci_remove
[ohci1394] 0x178 (0xdc535e88))
Oct 19 12:03:41 protein rc.sysinit: Initializing USB controller (usb-uhci): 
succeeded
Oct 19 12:04:02 protein kernel: [<df8e0adb>] ohci1394_pci_probe [ohci1394] 0x14b
(0xdc535ea0))
Oct 19 12:03:41 protein rc.sysinit: Mounting USB filesystem:  succeeded
Oct 19 12:04:02 protein kernel: [<df8e219f>] .rodata.str1.1 [ohci1394] 0x0
(0xdc535ea8))
Oct 19 12:03:41 protein rc.sysinit: Initializing USB HID interface:  succeeded
Oct 19 12:04:02 protein kernel: [<df8e219f>] .rodata.str1.1 [ohci1394] 0x0
(0xdc535eb0))
Oct 19 12:03:41 protein rc.sysinit: Initializing USB keyboard:  succeeded
Oct 19 12:04:02 protein sshd: Starting sshd:
Oct 19 12:04:02 protein kernel: [<df8e2e00>] ohci1394_pci_tbl [ohci1394] 0x0
(0xdc535ec4))
Oct 19 12:03:41 protein rc.sysinit: Initializing USB mouse:  succeeded
Oct 19 12:04:03 protein apmd[423]: Charge: * * * (-1% unknown)
Oct 19 12:04:03 protein kernel: [<df8e2e40>] ohci1394_pci_driver [ohci1394] 0x0
(0xdc535ec8))
Oct 19 12:03:41 protein fsck: /: clean, 140413/1050400 files, 629819/2097892 blocks
Oct 19 12:04:03 protein kernel: [<c01cb395>] pci_announce_device [kernel] 0x35
(0xdc535ed4))
Oct 19 12:03:41 protein rc.sysinit: Checking root filesystem succeeded
Oct 19 12:04:03 protein kernel: [<df8e2e00>] ohci1394_pci_tbl [ohci1394] 0x0
(0xdc535edc))
Oct 19 12:03:41 protein rc.sysinit: Remounting root filesystem in read-write
mode:  succeeded
Oct 19 12:04:04 protein kernel: [<df8e2e40>] ohci1394_pci_driver [ohci1394] 0x0
(0xdc535ee4))
Oct 19 12:03:41 protein rc.sysinit: Activating swap partitions:  succeeded
Oct 19 12:04:04 protein kernel: [<c01cb43c>] pci_register_driver [kernel] 0x5c
(0xdc535ef0))
Oct 19 12:03:43 protein /etc/hotplug/usb.agent: Setup usbcore for USB product 0/0/0
Oct 19 12:04:04 protein kernel: [<df8e2e40>] ohci1394_pci_driver [ohci1394] 0x0
(0xdc535ef4))
Oct 19 12:03:43 protein /etc/hotplug/usb.agent: Setup usbcore for USB product 0/0/0
Oct 19 12:04:04 protein kernel: [<df8e11ee>] ohci1394_init [ohci1394] 0x5e
(0xdc535f08))
Oct 19 12:03:49 protein rc.sysinit: Finding module dependencies:  succeeded
Oct 19 12:04:04 protein kernel: [<df8e2e40>] ohci1394_pci_driver [ohci1394] 0x0
(0xdc535f0c))
Oct 19 12:04:04 protein sshd:  succeeded
Oct 19 12:03:50 protein fsck: /boot: clean, 41/7552 files, 6175/30208 blocks
Oct 19 12:04:04 protein kernel: [<df8e219f>] .rodata.str1.1 [ohci1394] 0x0
(0xdc535f10))
Oct 19 12:04:04 protein sshd:
Oct 19 12:03:50 protein fsck: /home: clean, 95599/1492608 files, 1587796/2984302
blocks
Oct 19 12:04:05 protein kernel: [<c011bee9>] sys_init_module [kernel] 0x4d9
(0xdc535f1c))
Oct 19 12:03:50 protein rc.sysinit: Checking filesystems succeeded
Oct 19 12:04:05 protein kernel: [<df8de060>] get_phy_reg [ohci1394] 0x0
(0xdc535f20))
Oct 19 12:03:51 protein rc.sysinit: Mounting local filesystems:  succeeded
Oct 19 12:04:05 protein kernel: [<df8e245c>] .kmodtab [ohci1394] 0x0 (0xdc535f2c))
Oct 19 12:04:05 protein rc: Starting sshd:  succeeded
Oct 19 12:03:51 protein rc.sysinit: Enabling local filesystem quotas:  succeeded
Oct 19 12:04:05 protein kernel: [<df8de060>] get_phy_reg [ohci1394] 0x0
(0xdc535f58))
Oct 19 12:03:51 protein rc.sysinit: Enabling swap space:  succeeded
Oct 19 12:04:05 protein kernel: [<c01090ff>] system_call [kernel] 0x33 (0xdc535fc0))
Oct 19 12:03:54 protein init: Entering runlevel: 5
Oct 19 12:04:05 protein kernel:
Oct 19 12:03:54 protein modprobe: modprobe: Can't locate module block-major-2
Oct 19 12:04:05 protein kernel:
Oct 19 12:03:54 protein modprobe: modprobe: Can't locate module block-major-2
Oct 19 12:04:05 protein kernel: Code: 89 50 04 89 02 8b 53 04 8b 03 89 50 04 89
02 ff 4e 10 51 9d
Oct 19 12:03:54 protein modprobe: modprobe: Can't locate module block-major-2
Oct 19 12:04:05 protein kernel:  ip_tables: (C) 2000-2002 Netfilter core team
Oct 19 12:03:55 protein modprobe: modprobe: Can't locate module block-major-2
Oct 19 12:03:55 protein kudzu: Updating /etc/fstab succeeded
Oct 19 12:03:57 protein modprobe: modprobe: Can't locate module block-major-2
Oct 19 12:03:57 protein last message repeated 3 times
Oct 19 12:03:57 protein kudzu:  succeeded
Comment 1 Need Real Name 2002-10-23 14:02:57 EDT
lspci -v output for machine

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 80)
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: bus master, medium devsel, latency 72
	Memory at a0000000 (32-bit, prefetchable) [size=64M]
	Capabilities: <available only to root>

00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
(prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, medium devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 0000c000-0000dfff
	Memory behind bridge: e0000000-efffffff
	Prefetchable memory behind bridge: 90000000-9fffffff
	Capabilities: <available only to root>

00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: bus master, stepping, slow devsel, latency 168, IRQ 11
	Memory at 1f000000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=176
	Memory window 0: 1f400000-1f7ff000 (prefetchable)
	Memory window 1: 1f800000-1fbff000
	I/O window 0: 00004000-000040ff
	I/O window 1: 00004400-000044ff
	16-bit legacy interface ports at 0001

00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link) (prog-if 10 [OHCI])
	Flags: medium devsel
	Memory at 1f001000 (32-bit, non-prefetchable) [disabled] [size=2K]
	Memory at 1f004000 (32-bit, non-prefetchable) [disabled] [size=16K]
	Capabilities: <available only to root>

00:11.0 ISA bridge: VIA Technologies, Inc. VT8231 [PCI-to-ISA Bridge] (rev 10)
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: bus master, stepping, medium devsel, latency 0
	Capabilities: <available only to root>

00:11.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev
06) (prog-if 8a [Master SecP PriP])
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: bus master, medium devsel, latency 64
	I/O ports at 1100 [size=16]
	Capabilities: <available only to root>

00:11.2 USB Controller: VIA Technologies, Inc. USB (rev 1e) (prog-if 00 [UHCI])
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: bus master, medium devsel, latency 22, IRQ 11
	I/O ports at 1200 [size=32]
	Capabilities: <available only to root>

00:11.4 Bridge: VIA Technologies, Inc. VT8235 ACPI (rev 10)
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: medium devsel
	Capabilities: <available only to root>

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio
Controller (rev 40)
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: medium devsel, IRQ 10
	I/O ports at e000 [size=256]
	I/O ports at e100 [size=4]
	I/O ports at e104 [size=4]
	Capabilities: <available only to root>

00:11.6 Communication controller: VIA Technologies, Inc. AC97 Modem Controller
(rev 20)
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: medium devsel, IRQ 10
	I/O ports at e200 [size=256]
	Capabilities: <available only to root>

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 51)
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: bus master, medium devsel, latency 16, IRQ 11
	I/O ports at e800 [size=256]
	Memory at f0000000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <available only to root>

01:00.0 VGA compatible controller: S3 Inc. VT8636A [ProSavage KN133] AGP4X VGA
Controller (TwisterK) (rev 01) (prog-if 00 [VGA])
	Subsystem: Hewlett-Packard Company: Unknown device 0022
	Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
	Memory at e0000000 (32-bit, non-prefetchable) [size=512K]
	Memory at 90000000 (32-bit, prefetchable) [size=128M]
	Expansion ROM at 000c0000 [disabled] [size=64K]
	Capabilities: <available only to root>
Comment 2 Alan Cox 2003-06-07 22:08:07 EDT

*** This bug has been marked as a duplicate of 72587 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.