Bug 76307 - Cant access largefiles in ksh
Cant access largefiles in ksh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: pdksh (Show other bugs)
2.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Karsten Hopp
:
: 111757 (view as bug list)
Depends On:
Blocks: 87937
  Show dependency treegraph
 
Reported: 2002-10-19 13:15 EDT by Ramesh babu
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-19 10:02:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh babu 2002-10-19 13:15:43 EDT
Description of Problem:

Ksh in Redhat Linux is not supporting largefiles ( greater than 2GB) .
I have made the test by creating files of size 1999MB ( 1.99 GB ) , and the if  
loop works fine. For the file of size 2.1GB , the same checking is not working. 
This conditions is seen only in ksh , whereas the conditions are fine in sh and 
bash. 

          Largefile checking not working in ksh in Linux 
          ------------------------------------------------------------------ 

          # ls -l 
          total 18971736 
          -rw-rw-rw-    1 root     bin	      20979712 Sep 17 02:25 
ctx1VISION.dbf 
          -rw-rw-rw-    1 root     bin       524296192 Sep 17 02:27 emsdat1.dbf 
          -rw-rw-rw-    1 root     bin     14533271552 Sep 17 04:26 mgmt.dbf 
          -rw-rw-rw-    1 root     bin       104865792 Sep 17 02:27 
mgmt_ecm_depot1.dbf 
          -rw------T    1 root     bin      2147483648 Sep 18 05:57 testing 
          -rw------T    1 root     bin      2096103424 Sep 18 05:48 
testing.1.9G 

          # if [ -s testing.1.9G ] 
          > then 
          > echo "1.99 GB" 
          > fi 
          1.99 GB 
          # 
          # if [ -s testing ] 
          > then 
          >  echo "gr than 2G" 
          >  fi 
          # 

	  ------------------------------------------------------------------ 
          Largefile checking works in sh and bash 

          [root@lin1 200209170225.EMS_BACKUP]# ls -l testing 
          -rw------T    1 root     bin      2147483648 Sep 18 05:57 testing 
          [root@lin1 200209170225.EMS_BACKUP]# if [ -s testing ] 
          > then 
          > echo " gr than 2G" 
          > fi 
          gr than 2G 
          ------------------------------------------------------------------ 


Version-Release number of selected component (if applicable):
Red Hat Linux Advanced Server release 2.1AS (Pensacola)
Linux lin1 2.4.9-e.3smp #1 SMP Fri May 3 16:48:54 EDT 2002 i686 unknown

How Reproducible:
If a largefile is created in RH AS2.1 , the file is not accessible from ksh.

Steps to Reproduce:
1. Create a largefile greater than 2 GB 
2. Try to access thru ksh , perform some actions like if loop etc. The file is 
not accessible
3. Same works fine with bash.
Comment 1 Ramesh babu 2002-11-23 11:08:21 EST
Please let me know if any additional information needed . Increasing the 
priority.

Thanks
Comment 2 Kendal L. Montgomery 2003-05-23 14:40:17 EDT
I also see this bug:

For instance if I have some large files in a directory as follows:

csrop@myhost: /data/01/csrbo/bigfile_test
> ls -l
total 15399820
-rw-r--r--    1 csrop    csr2qc   3557352057 Apr 28 09:10 B_EA_20020101.BDT_3.5gb
-rw-r--r--    1 csrop    csr2qc   5081931510 May 23 10:36 B_EA_20020101.BDT_5gb
-rw-r--r--    1 csrop    csr2qc   7114704114 Apr 28 10:03 B_EA_20020101.BDT_7gb

globbing does not seem to work well (using wildcards):

csrop@lxccp043: /data/01/csrbo/bigfile_test
> ls -la ?_EA_20020101.BDT_3.5gb
ls: ?_EA_20020101.BDT_3.5gb: No such file or directory

or

csrop@lxccp043: /data/01/csrbo/bigfile_test
> ls -la *
ls: *: No such file or directory

or

csrop@lxccp043: /data/01/csrbo/bigfile_test
> ls -la B_?A_*
ls: B_?A_*: No such file or directory

but NOT using wildcards works fine:

csrop@lxccp043: /data/01/csrbo/bigfile_test
> ls -la B_EA_20020101.BDT_3.5gb
-rw-r--r--    1 csrop    csr2qc   3557352057 Apr 28 09:10 B_EA_20020101.BDT_3.5gb
Comment 3 Suzanne Hillman 2003-07-25 10:44:31 EDT
Attempting to reproduce on the latest Quarterly Update for 2.1AS.
Comment 4 Suzanne Hillman 2003-07-25 15:22:45 EDT
This still happens in QU2:

.qa.[root@i386-21as shillman_test]# ksh
# ls -lh
total 3.0G
-rw-r--r--    1 root     root         3.0G Jul 25 15:01 large_file
-rw-r--r--    1 root     root           13 Jul 25 15:12 myfile
# if [ -s large_file ]; then
> echo "3.0G file"
> fi
#
# if [ -s myfile ]; then
> echo "small file"
> fi
small file
#


Assigning to owner of pdksh.
Comment 5 Suzanne Hillman 2003-07-25 15:25:08 EDT
Sorry - forgot to change status to ASSIGNED.
Comment 8 Karsten Hopp 2003-07-31 07:44:41 EDT
done for the next quarterly update 
Comment 9 John Flanagan 2003-12-19 10:02:19 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-375.html
Comment 10 Florian La Roche 2003-12-31 02:14:05 EST
*** Bug 111757 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.