Bug 76345 - Removes More Packages Than Deselected Despite Alternative Dependencies
Removes More Packages Than Deselected Despite Alternative Dependencies
Status: CLOSED DUPLICATE of bug 75661
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 10:54 EDT by Thomas Smith
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-20 10:54:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Smith 2002-10-20 10:54:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021014
Phoenix/0.3

Description of problem:
In the case of mutt, I have Konqueror installed as part of kde-base, as well as
htmlview.  One of the three RPMs needs dependency information adjusted to
reflect that both htmlview and Konqueror provide webclient. 

More importantly, redhat-config-packages contains a bug evidenced by its attempt
to remove openoffice. For every indirect dependency on mozilla (e.g.
libmprldap50.so), openoffice-libs is also listed as providing the particular
library.  Openoffice-libs is installed.  The package manager is not recognizing
the installed, alternative provider.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Confirm mozilla, mozilla-mail, mutt, and openoffice pacakges installed
2. Deselect all three mozilla packages in Graphical Internet group
3. Click on update in package manager

	

Actual Results:  After dependencies are computed, the removal confirmation
dialog lists five packages, including mutt and openoffice.

Expected Results:  Only the three deselected Mozilla packages are removed as
there is no critical dependency by mutt or openoffice on mozilla.  In the case
of openoffice, there is already an installed, alternative provider for the
dependencies that reference mozilla.

Additional info:

Ran rpm --rebuilddb and verified same behaviour. 

This results in loss of data (the whole openoffice package) if the user is not
careful. Non-technical users will not understand what is transpiring.
Comment 1 Jeremy Katz 2002-10-20 11:21:51 EDT
Test packages at http://people.redhat.com/~katzj/redhat-config-packages/ should
fix this

*** This bug has been marked as a duplicate of 75661 ***
Comment 2 Thomas Smith 2002-10-20 17:41:36 EDT
New bug report default query did not display the duplicate bug and I did not
include Modified status in general query. Sorry for wasting your time.  I will
email suggestion to Bugzilla owner to expand status types included in new bug
report default query.  Thanks for the fix.  I will check it out as soon as possible.

Note You need to log in before you can comment on or make changes to this bug.