Bug 764266 - (GLUSTER-2534) Glusterd crashes on gsync stop.
Glusterd crashes on gsync stop.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: kaushik
:
: 764265 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-16 14:41 EDT by Junaid
Modified: 2013-08-06 18:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Junaid 2011-03-16 14:41:18 EDT

    
Comment 1 Junaid 2011-03-16 22:13:22 EDT
Glusterd crashes on executing the command

>volume gsync stop master slave

The core file doesnot contain any stack trace.
Comment 2 Vijay Bellur 2011-03-16 22:24:29 EDT
PATCH: http://patches.gluster.com/patch/6492 in master (mgmt/glusterd: Use PATH_MAX for pid_file.)
Comment 3 kaushik 2011-03-18 04:36:42 EDT
*** Bug 2533 has been marked as a duplicate of this bug. ***
Comment 4 Lakshmipathi G 2011-03-28 22:54:52 EDT
testing 3.2.0 stop fails as -
# gluster volume gsync stop :gsyncgit root@ec2-79-125-76-86.eu-west-1.compute.amazonaws.com:/mnt/export1
Gsync command failed

but glusterd is still running.
Comment 5 Lakshmipathi G 2011-03-28 22:55:48 EDT
(In reply to comment #4)
> testing 3.2.0 stop fails as -
testing with 3.2.0qa5 stop fails.
Comment 6 Lakshmipathi G 2011-03-31 07:03:37 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > testing 3.2.0 stop fails as -
> testing with 3.2.0qa5 stop fails.
tested with 3.2.0qa6 - 
--
# gluster volume gsync stop :qagit root@ec2-79-125-76-86.eu-west-1.compute.amazonaws.com::slave

Gsync command failed
----
Comment 7 Lakshmipathi G 2011-04-04 21:38:34 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > testing 3.2.0 stop fails as -
> > testing with 3.2.0qa5 stop fails.
> tested with 3.2.0qa6 - 
> --
> # gluster volume gsync stop :qagit
> root@ec2-79-125-76-86.eu-west-1.compute.amazonaws.com::slave
> 
> Gsync command failed
> ----
with 3.2.0beta1
#gluster volume gsync stop :beta1 root@ec2-79-125-76-86.eu-west-1.compute.amazonaws.com::slave

Gsync command failed
Comment 8 Raghavendra Bhat 2011-04-13 03:58:13 EDT
Now gsync stop does not crash glusterd.

Note You need to log in before you can comment on or make changes to this bug.