Bug 76432 - Anaconda freezes on "Probing for monitor type:"
Anaconda freezes on "Probing for monitor type:"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
8.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-21 14:46 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-18 16:46:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda with debugging info (20.03 KB, text/plain)
2003-02-07 15:35 EST, Michael Fulbright
no flags Details

  None (edit)
Description Need Real Name 2002-10-21 14:46:55 EDT
From Bugzilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.21; Mac_PowerPC)



Description of problem:

Anaconda  hangs at "Probing for monitor type:" on a stock Proliant 1600R dual PIII 
500Mhz.



Version-Release number of selected component (if applicable):





How reproducible:

Always



Steps to Reproduce:

1.  Put in the RH8.0 disc 1.

2.  Reboot the machine.



Actual Results:  Same as description..... the machine hangs.



Expected Results:  It should move past "Probe" into the installer as it does on RH 5.2, 6.0, 
6.1, 6.2HA and 7.2 (those which i've used).



Additional info:
Comment 1 Michael Fulbright 2002-10-23 11:53:36 EDT
Please try adding 'skipddc' to the boot commandline.
Comment 2 Nick Low 2002-11-25 16:34:59 EST
I have tried the suggested work around "linux skipddc" and it did not help with 
the problem.  Anaconda still locked up in the same place.

Here is some additional system information from my computer:
Proliant 1600
P(?) 450 with 512 cache
Loaded: sym53c8xx driver
Loaded: Cirrus Logic GD544x video card

Comment 3 Mark Shewman 2002-11-25 20:46:17 EST
I have exactly the same problem on a Compaq 1850r.

I also have tried the suggested work around "linux skipddc" and it did not help
with the problem.  Anaconda still locked up in the same place.

Here is some additional system information from my computer:
Proliant 1850r
PII 500 with 512 cache
Loaded: sym53c8xx driver
Loaded: ATI Mach64 Rage II video card

I know there are other postings with similar problems starting with version 7.3
and various solutions that have a poor success rate.

Comment 4 Michael Fulbright 2003-01-02 21:19:50 EST
Does it ever print out a monitor type?

Also try switching to VC# (cntl-alt-f3) before the monitor probe is attempted
and see what the last few lines are.
Comment 5 Michael Fulbright 2003-01-02 21:22:01 EST
Seems the same as bug 78740.
Comment 6 Nick Low 2003-01-03 10:15:40 EST
Here is what is reported on the screen:
Running anaconda, the Red Hat Linux system installer - please wait...
Probing for video card:   Cirrus Logic GD544x
Probing for monitor type: Unable to probe
_(blinking)

The system is now halted.

After pressing "cntrl+alt+f3", the following information is displayed:

* Running anaconda script /usr/bin/ananconda
* Probing for video card:   Cirrus Logic GD544x
* ddcprobe returned bogus values:
ID: None
Name: None
HorizSync: None
VertSync: None

* Probing for monitor type: Unable to probe

The monitor that I am using, is normally attached to a different Linux 
machine.  It is a Compaq V720.
Comment 7 Michael Fulbright 2003-02-07 15:35:13 EST
Created attachment 89933 [details]
anaconda with debugging info
Comment 8 Michael Fulbright 2003-02-07 15:36:51 EST
Please save the attachment I just added to an ext2 floppy named as 'anaconda'.

Boot with 'linux updates' and insert the update floppy when asked.

When the machine hangs look on VC3 and let me know what the line starting with
'skipddcprobe' says (it should have 3 #'s).
Comment 9 Nick Low 2003-02-08 11:59:53 EST
I am out of the office right now.  I will be back in the office 2/17/03.  I 
will try what you asked for when I return.
Comment 10 Michael Fulbright 2003-02-21 12:19:17 EST
Thanks!
Comment 11 Need Real Name 2003-03-23 14:00:37 EST
This bug also seems to effect 7.3 builds, in addition to 8.0, and also effects 
Compaq Prolaint 1850R's.  I believe it has nothing to do with the monitor 
hardware.  I yanked my video cable loose before it began to probe and it still 
hung the system with "Unable to Probe".

I do all my installs/upgrades via network and use:

linux text noprobe

during the initial boot with a bootnet.img floppy (so I can enter module 
options).  Whatever scripting is included in the secondary install images, it 
does not honor the "noprobe" option.  I realize that this is a kernel option 
during initial boot, but shouldn't it be possible to set this as an environment 
variable for the other scripts to inherit?

At any rate, I'm going to pull apart the netstg1.img and stage2.img and comment 
out the scripting that insists on probing for a monitor during text 
installs...  If anyone is interested in my findings, I'll post them back here.
Comment 12 Michael Fulbright 2003-04-22 12:21:05 EDT
I added the 'skipddc' option in 8.0 to do what you are attempting to do. I was
able to verify that the ddc probe does not occur when it is used.

It unclear what the issue here is - I've only seen it on this hardware and
unfortunately I do not have it here so I cannot fix this issue.

As time allows I can try to answer question you may have as you look into this
issue.
Comment 13 Michael Fulbright 2003-06-18 16:46:30 EDT
Closing due to inactivity - please reopen if you have additional information to add.

Note You need to log in before you can comment on or make changes to this bug.