Bug 764332 - (GLUSTER-2600) profile info on a volume with all servers down says profile info successful but doesn't say anything
profile info on a volume with all servers down says profile info successful b...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: shishir gowda
:
: GLUSTER-2594 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-28 12:05 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: glusterfs-3.3.0qa9
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description M S Vishwanath Bhat 2011-03-28 12:05:17 EDT
When all the bricks in the volumes are down, running volume profile info displays "profile info successful". volume profile info should inform if any of the servers are down.
Comment 1 shishir gowda 2011-04-06 22:34:55 EDT
*** Bug 2594 has been marked as a duplicate of this bug. ***
Comment 2 Anand Avati 2011-07-20 06:11:53 EDT
CHANGE: http://review.gluster.com/63 (Profile - If all bricks are down, report errror.) merged in master by Anand Avati (avati@gluster.com)
Comment 3 Raghavendra Bhat 2011-09-16 03:49:46 EDT
Its fixed now. If the bricks are down gluster volume profile <volname> info gives error message.

Checked with glusterfs-3.3.0qa9.

ps aux |grep gluster
root      4623  0.0  0.0      0     0 ?        Zsl  Sep12   0:00 [glusterfs] <defunct>
root     13037  0.0  4.8 239700 102476 ?       Ssl  02:02   0:00 glusterd
root     24799  1.2  3.5 208028 73652 ?        Ssl  06:48   0:00 /usr/local/sbin/glusterfsd -s localhost --volfile-id mirror.10.1.11.73.export-mirror -p /etc/glusterd/vols/mirror/run/10.1.11.73-export-mirror.pid -S /tmp/cc858321fc36a83d7850a009d90076cf.socket --brick-name /export/mirror -l /usr/local/var/log/glusterfs/bricks/export-mirror.log --brick-port 24009 --xlator-option mirror-server.listen-port=24009
root     24805  1.8  4.6 213076 97696 ?        Ssl  06:48   0:00 /usr/local/sbin/glusterfs -f /etc/glusterd/nfs/nfs-server.vol -p /etc/glusterd/nfs/run/nfs.pid -l /usr/local/var/log/glusterfs/nfs.log
root     24809  1.6  3.5 187856 74760 ?        Ssl  06:48   0:00 /usr/local/sbin/glusterfs -s localhost --volfile-id gluster/glustershd -p /etc/glusterd/glustershd/run/glustershd.pid -l /usr/local/var/log/glusterfs/glustershd.log
root     24817  0.0  0.0  61184   740 pts/5    R+   06:48   0:00 grep gluster
[root@Centos1 ~]# kill 24799
[root@Centos1 ~]# gluster volume profile mirror info
Cannot reach bricks. Bricks are down
[root@Centos1 ~]# gluster volume profile mirror info
Cannot reach bricks. Bricks are down
Comment 4 M S Vishwanath Bhat 2011-10-21 00:34:55 EDT
This patch needs to be back-ported to release-3.2 branch as well.

Note You need to log in before you can comment on or make changes to this bug.