Bug 764358 - (GLUSTER-2626) nfs.rpc-auth-allow/reject accepts invalid ip address.
nfs.rpc-auth-allow/reject accepts invalid ip address.
Status: CLOSED UPSTREAM
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.1.3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kaushal
: Reopened
: GLUSTER-2935 783110 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 01:55 EDT by Gaurav
Modified: 2013-01-08 09:53 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 04:59:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav 2011-03-30 01:55:13 EDT
gaurav@gaurav-Vostro-3400:~/new_gluster$ sudo gluster volume set new_vol2 nfs.rpc-auth-reject 000
Set volume successful
Comment 1 shishir gowda 2011-05-24 04:51:50 EDT
*** Bug 2935 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Byers 2011-08-29 13:31:55 EDT
Why couldn't this fix have been incorporated into GlusterFS 3.2.3 released on 23-Aug-2011?
Comment 3 Gaurav 2011-09-12 00:30:08 EDT
Reopening, Patch not commited.
Comment 4 Amar Tumballi 2011-09-27 01:49:52 EDT
Planing to keep 3.4.x branch as "internal enhancements" release without any features. So moving these bugs to 3.4.0 target milestone.
Comment 6 Rajesh 2012-03-16 02:25:52 EDT
*** Bug 783110 has been marked as a duplicate of this bug. ***
Comment 7 Vijay Bellur 2012-04-27 07:57:32 EDT
Kaushal,

Can you please confirm if this still exists? If not, please close this bug.

Thanks
Comment 8 Kaushal 2012-05-03 04:59:10 EDT
The ip address validations occur correctly now. 
Regarding the example used here, the value '000' is treated as a hostname and will be validated successfully.
Comment 9 Jeff Byers 2013-01-08 09:53:09 EST
Amazingly, this problem *still* is not fixed in GlusterFS 
version 3.2.7, and presumably not in 3.2.6 either.

The bug is that you are using strtok_r() which modifies the 
input param without first using strdup() to make a private 
version of the string.

You fixed this way back in 2011-05-24, but seem unable
to carry this fix over to later releases:

    Patchwork [BUG:2935] NFS rpc auth: handle multiple host/ip args
    http://patches.gluster.com/patch/7233/
    Submitter    shishir gowda
    Date         2011-05-24 11:03:51

Note You need to log in before you can comment on or make changes to this bug.