Bug 783110 - nfs.rpc-auth-allow truncated to first field
nfs.rpc-auth-allow truncated to first field
Status: CLOSED DUPLICATE of bug 764358
Product: GlusterFS
Classification: Community
Component: access-control (Show other bugs)
3.2.5
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Rajesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-19 07:05 EST by Matthias Babisch
Modified: 2013-07-04 18:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Debian Squeeze with glusterfs_3.2.5-1_amd64.deb
Last Closed: 2012-03-16 02:25:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Babisch 2012-01-19 07:05:48 EST
Description of problem:
When multiple Adresses or Wildcards are entered comma-separated into nfs.rpc-auth-allow, only the first field (before the first comma) seems to take effect. I noticed the problem when creating new Replicated Volumes.

Version-Release number of selected component (if applicable):
glusterfs_3.2.5-1_amd64.deb 

How reproducible:

Steps to Reproduce:
1.Create a Volume (only tested with Replicate). 
(my Example: 
gluster volume create iso-images replica 2 transport tcp \
machine1:/data/iso-images machine2:/data/iso-images
)
2. Set rpc-auth-allow
(
my Example: 
gluster volume set iso-images nfs.rpc-auth-allow "172.27.24.*,172.27.27.*"
)
3. Start the volume
  
Actual results:
Machines matching the first entry have access, while machines in the other ranges get access denied.

Expected results:
All listed Machines should be allowed access.

Additional info:
Comment 1 Rajesh 2012-01-31 01:37:59 EST
changing version according to the debian package mentioned. please clarify if it is not 3.2.5
Comment 2 Rajesh 2012-03-16 02:25:52 EDT
http://review.gluster.com/#change,391

patch pending review

*** This bug has been marked as a duplicate of bug 764358 ***

Note You need to log in before you can comment on or make changes to this bug.