Bug 7645 - after initscripts-4.70, keyboard hangs in gnome
after initscripts-4.70, keyboard hangs in gnome
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-06 22:21 EST by Edward Kuns
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-17 13:40:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Kuns 1999-12-06 22:21:09 EST
After upgrading to initscripts-4.70, the keyboard intermittently locks up
in GNOME.  All is well until without warning, any keypress causes a BEEP,
and is otherwise ignored.  ALL keypresses beep, including any attempt to go
to another console.  The mouse still works.  Logging out (with the Gnome
logout button) and logging back in restores the keyboard, making this
clearly a GNOME or ENLIGHTENMENT problem.

Note that unplugging the keyboard and replugging the keyboard in has no
effect.  Only logging off brings the keyboard back, allowing one to log
back in or switch to another console.

Since downgrading to initscripts-4.68, the problem has not recurred.  The
problem first occurred shortly after I upgraded to 4.70.
Comment 1 Bill Nottingham 1999-12-07 10:32:59 EST
You might try right-clicking on a gnome-terminal, and
seeing if 'secure keyboard' has been selected.

There's nothing in the initscripts update that should
affect the keyboard one way or another.
Comment 2 dkaplan 1999-12-13 12:35:59 EST
Hi,

I am having the same problems with gnome-terminals since updating to RH6.1.  The
terminal completely freezes and the only solution I have found is to kill it.  I
havent seen any particular pattern as to when it occurs.

I have RH6.1 on a Gateway 2500 Solo Laptop.
I have gnome-core-1.0.39-10.

Thanks
Comment 3 Edward Kuns 1999-12-14 00:50:59 EST
FYI ... this never happened before installing 4.70, and it has not happened at
all since I downgraded to 4.68.  It's been a week since I downgraded and of
course I'd had Red Hat 6.1 installed for about a month before upgrading to
initscripts-4.70.

I agree that this doesn't seem to make sense, but initscripts is the only
variable here.

This happened several times in the fewer-than-24 hours I had initscripts-4.70
installed.
Comment 4 dkaplan 1999-12-14 20:32:59 EST
I just figured out what is causing my gnome-terminal's to freeze - Shift+Tab.
Fortunately, Shift+Tab also
undoes the problem.  I assume this is a bug and not a feature, or perhaps there
is some reason why
shift+tab should freeze the terminal.

Again, I have gnome-core-1.0.39-10 and initscripts-4.48-1.

David
Comment 5 Elliot Lee 2000-01-17 13:40:59 EST
Please get the GNOME errata from the Red Hat. This problem was fixed in
gnome-core after the 1.0.40 release.

Shift+Tab is normally used to switch widget focus within an application, and was
not being caught by only-one-thing-to-focus-on gnome-terminal.

I am pretty sure this problem has nothing to do with initscripts.
Comment 6 Leigh L. Klotz, Jr. 2000-05-10 13:33:59 EDT
*** Bug 11330 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.