Bug 764702 - (GLUSTER-2970) RPM packaging does not comply with FHS and Fedora/RedHat Packaging Guidelines
RPM packaging does not comply with FHS and Fedora/RedHat Packaging Guidelines
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
All Linux
medium Severity low
: ---
: ---
Assigned To: Amar Tumballi
Sachidananda Urs
:
: GLUSTER-2947 GLUSTER-3677 818839 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2011-05-31 18:10 EDT by Joe Julian
Modified: 2013-12-18 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file being used for post-3.1.5qa1 git tree. (18.40 KB, text/x-rpm-spec)
2011-05-31 15:11 EDT, Joe Julian
no flags Details

  None (edit)
Description Joe Julian 2011-05-31 15:11:59 EDT
Created attachment 503
Comment 1 Joe Julian 2011-05-31 18:10:58 EDT
I understand your reasoning for wanting to put things in version directories under opt, but this doesn't comply with FHS and Fedora/RedHat packaging guidelines.

Attached is the spec file I'm using for building my yum repo with some tweaks made to Jon's fedora rawhide package (the source rpm with the patches is available at http://joejulian.name/yumrepo/testing/redhat/5/SRPMS/ ) . 

To install the rpm to your opt tree you could simply install with 
 rpm -i --relocate /=/opt/gluster/$VERSION glusterfs-$VERSION.rpm
which should satisfy your debugging requirements.
Comment 2 Amar Tumballi 2011-10-24 23:54:02 EDT
Joe,

Are we complaint with FHS (Fedora/Red Hat) way of building RPMs now, in release-3.2/master branch? If yes, I would like to close this bug. Let me know if you have tried with these two branches.

Regards,
Amar
Comment 3 Harshavardhana 2011-11-07 15:46:39 EST
(In reply to comment #2)
> Joe,
> 
We are not, but Joe maintains a different repository for that. Joe can you please re-attach your specification file from 3.2.4 build, lets get it pushed in.
Comment 4 Anand Avati 2011-11-24 02:31:00 EST
CHANGE: http://review.gluster.com/704 (Releases will now require changing the source url in configure.ac) merged in release-3.1 by Anand Avati (avati@gluster.com)
Comment 5 Amar Tumballi 2011-12-20 01:37:32 EST
As the patches got in, can we close this bug?
Comment 6 Anand Avati 2012-01-27 07:09:59 EST
CHANGE: http://review.gluster.com/788 (Make volfile-save scriptlet follow .rpmsave convention.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 7 Anand Avati 2012-02-19 04:34:44 EST
CHANGE: http://review.gluster.com/701 (Merged in the fedora spec file to bring glusterfs into compliance with FSH and Redhat/Fedora requirements. Created a single spec that works for both 3.1 and 3.2 versions.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 8 Anand Avati 2012-02-21 07:16:42 EST
CHANGE: http://review.gluster.com/2785 (build: rpmbuild friendly changes) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 9 Anand Avati 2012-02-21 13:23:28 EST
CHANGE: http://review.gluster.com/2788 (build: More rpmbuild friendly changes) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 10 Amar Tumballi 2012-02-21 21:21:04 EST
Considering there are some patches in, I will mark it on QA.
Comment 11 Anand Avati 2012-02-23 02:18:10 EST
CHANGE: http://review.gluster.com/2797 (build: Changes to specfile for correctness and package relevance.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 12 Anand Avati 2012-03-29 10:46:19 EDT
CHANGE: http://review.gluster.com/3009 (Save old volfiles in the RPM standard way.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 13 Csaba Henk 2012-04-18 07:00:17 EDT
*** Bug 764679 has been marked as a duplicate of this bug. ***
Comment 14 Anand Avati 2012-05-10 18:18:44 EDT
CHANGE: http://review.gluster.com/3308 (build: Include protocol/server* shared libraries in the glusterfs-server rpm) merged in master by Anand Avati (avati@redhat.com)
Comment 15 Joe Julian 2012-05-27 13:42:41 EDT
*** Bug 765409 has been marked as a duplicate of this bug. ***
Comment 16 Joe Julian 2012-05-27 13:57:20 EDT
*** Bug 818839 has been marked as a duplicate of this bug. ***
Comment 17 Vijay Bellur 2013-02-07 16:13:27 EST
CHANGE: http://review.gluster.org/702 (Merged in the fedora spec file to bring glusterfs into compliance with FSH and Redhat/Fedora requirements. Created a single spec that works for both 3.1 and 3.2 versions.) merged in release-3.2 by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.