Bug 76473 - plugging in Keyspan 19Qi causes kernel Oops
Summary: plugging in Keyspan 19Qi causes kernel Oops
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 74256 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-22 06:37 UTC by Eric Smith
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-27 00:55:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log messages showing Keyspan probing and Oops (10.29 KB, text/plain)
2002-10-22 06:38 UTC, Eric Smith
no flags Details
/proc/version (146 bytes, text/plain)
2002-11-07 08:05 UTC, Eric Smith
no flags Details
log messages incl. oops from 2.4.18-17.8.0 (5.51 KB, text/plain)
2002-11-07 08:07 UTC, Eric Smith
no flags Details
Try #1 (1.13 KB, patch)
2002-11-26 23:01 UTC, Pete Zaitcev
no flags Details | Diff

Description Eric Smith 2002-10-22 06:37:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
When I plug in the Keyspan 19Qi USB serial adapter, it doesn't work, and causes
a kernel Oops.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Plug a Keyspan 19Qi USB serisl adapter into a USB port


Actual Results:  Kernel oops

Expected Results:  Should work as a serial port

Additional info:

Comment 1 Eric Smith 2002-10-22 06:38:09 UTC
Created attachment 81505 [details]
log messages showing Keyspan probing and Oops

Comment 2 Pete Zaitcev 2002-11-07 04:01:17 UTC
Please give me /proc/version of the failing kernel,
and also try 2.4.18-17.8.0 (available from updates area at ftp.redhat.com).


Comment 3 Eric Smith 2002-11-07 08:05:45 UTC
Created attachment 83944 [details]
/proc/version

Comment 4 Eric Smith 2002-11-07 08:07:04 UTC
Created attachment 83945 [details]
log messages incl. oops from 2.4.18-17.8.0

Comment 5 Kent Pirkle 2002-11-16 18:41:31 UTC
I get the same "oops" with my Keyspan USA-19QW. I have gotten the same oops with
the stock 8.0 kernel (2.4.18-14) that I compiled myself to include the firmware,
as well as 2.4.18-8.0-17, and the just release -18. Since this has worked on
other distros in the past I did some experimentation. I compiled the kernel.org
2.4.19 using the firmware from keyspan's site and it works fine with 8.0. Here
is where it gets interesting. If I boot to my 2.4.19 kernel or Win2K and get the
adaptor working, then reboot without powering down into the Redhat 2.4.18
kernel, the adaptor is recognized and works. If I then unplug my adaptor and
plug it back in, I get the kernel oops. This tells me that one of the Redhat
patches to the kernel doesn't like the keyspan firmware or vice-versa.

Comment 6 Kent Pirkle 2002-11-16 18:46:36 UTC
BTW - additional information on my bug is at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=73556

Comment 7 Eric Smith 2002-11-21 07:16:57 UTC
kmp, I don't think the issue is an incompatability with the Keyspan firmware,
though it is related to the firmware loading process.  I think it's caused by
the Cypress chip in the Keyspan attempting what Cypress calls "renumeration": 
when the device is initially detected with no firmware, it shows up with one ID.
 The driver detects this, loads the firmware, and tells the device to go.  The
device signals a USB disconnect, just as if it had been physically unplugged,
then an insertion.  This is to force the host to enumerate the bus again, at
which point it finds the same device with a different ID.

Based on the log messages, I think the Red Hat kernel is failing to deal with
the disconnect properly.


Comment 8 Pete Zaitcev 2002-11-26 23:01:09 UTC
Created attachment 86628 [details]
Try #1

Comment 9 Pete Zaitcev 2002-11-26 23:07:02 UTC
*** Bug 74256 has been marked as a duplicate of this bug. ***

Comment 10 Tom Wood 2002-11-27 00:55:31 UTC
As you can see in bug 74256, this isn't unique to the 19Q.  Try the stock kernel from ftp.kernel.org - 
it works, but doesn't (obviously) have the Red Hat patches.

Comment 11 Pete Zaitcev 2002-11-29 23:15:51 UTC
You can get Rawhide kernels to get Red Hat patches integrated.

Integrated milan >2.4.18-19 or Rawhide (should be at 2.4.20 a.t.m.)



Note You need to log in before you can comment on or make changes to this bug.