Bug 764755 - (GLUSTER-3023) volume stop failed ,when one of the brick is not responding
volume stop failed ,when one of the brick is not responding
Status: CLOSED DUPLICATE of bug 764842
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rajesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-14 02:27 EDT by Lakshmipathi G
Modified: 2013-07-04 18:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lakshmipathi G 2011-06-14 02:27:32 EDT
With 3.2.1qa2 , started 4 dht volume.

------------
# gluster volume info

Volume Name: dht315
Type: Distribute
Status: Started
Number of Bricks: 4
Transport-type: tcp
Bricks:
Brick1: 10.1.12.170:/export/i1
Brick2: 10.1.12.171:/export/i1
Brick3: 10.1.12.173:/export/i1
Brick4: 10.1.12.170:/export/i2
-----------
Now one brick 10.1.12.171 is not responding to normal ssh.

$ ssh root@10.1.12.171
root@10.1.12.171's password: 
Read from remote host 10.1.12.171: Connection reset by peer
Connection to 10.1.12.171 closed.

Tried to stop the volume ,it fails.
# gluster volume stop 315
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
operation failed
[root@centos-rahul-1 ~]# gluster volume stop 315 force
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
operation failed


[root@centos-rahul-1 ~]# gluster volume info

Volume Name: dht315
Type: Distribute
Status: Started
Number of Bricks: 4
Transport-type: tcp
Bricks:
Brick1: 10.1.12.170:/export/i1
Brick2: 10.1.12.171:/export/i1
Brick3: 10.1.12.173:/export/i1
Brick4: 10.1.12.170:/export/i2
-----------------------------------




# tail /usr/local/var/log/glusterfs/usr-local-etc-glusterfs-glusterd.vol.log
[2011-06-13 23:17:31.125710] I [glusterd-handler.c:775:glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2011-06-13 23:17:49.721495] I [glusterd-handler.c:1160:glusterd_handle_cli_stop_volume] 0-glusterd: Received stop vol reqfor volume 315
[2011-06-13 23:17:49.721556] I [glusterd-utils.c:242:glusterd_lock] 0-glusterd: Cluster lock held by e90c681c-e71b-4752-a271-59efc988d48e
[2011-06-13 23:17:49.721569] I [glusterd-handler.c:825:glusterd_op_txn_begin] 0-glusterd: Acquired local lock
[2011-06-13 23:17:49.722131] I [glusterd-rpc-ops.c:663:glusterd3_1_cluster_lock_cbk] 0-glusterd: Received ACC from uuid: a735e389-798a-4a95-9404-e0c9d2b57e6d
[2011-06-13 23:17:49.722151] I [glusterd-utils.c:2072:glusterd_friend_find_by_uuid] 0-glusterd: Friend found... state: Peer in Cluster
[2011-06-13 23:19:53.210231] I [glusterd-handler.c:775:glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2011-06-13 23:19:53.210649] I [glusterd-handler.c:775:glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2011-06-13 23:19:57.230624] E [glusterd-handler.c:1147:glusterd_handle_cli_stop_volume] 0-: Unable to set cli op: 16
[2011-06-13 23:20:08.144759] E [glusterd-handler.c:1147:glusterd_handle_cli_stop_volume] 0-: Unable to set cli op: 16
Comment 1 Amar Tumballi 2011-07-27 22:08:09 EDT
Work with Vijay and check what should be the behavior and take it to resolve state.
Comment 2 Rajesh 2011-08-08 03:53:01 EDT

*** This bug has been marked as a duplicate of bug 3110 ***
Comment 3 gigahoge0001 2013-03-28 03:58:34 EDT
#3110 is a bug of netscape.

I can't see the bug #764842. If I click link, get message:
"You are not authorized to access bug #764842."

Note You need to log in before you can comment on or make changes to this bug.