Bug 765289 - (GLUSTER-3557) self-heal daemon crashes while self-healing a file without gfid
self-heal daemon crashes while self-healing a file without gfid
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
:
: GLUSTER-3575 GLUSTER-3660 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-15 00:42 EDT by Pranith Kumar K
Modified: 2011-10-13 07:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2011-09-15 00:42:52 EDT
afr was always under the assumption that lookup always happens with a gfid, so There is an assert if the gfid does not come to afr_self_heal(), self-heal daemon does not give any gfid so the assertion fails.
Comment 1 Pranith Kumar K 2011-09-28 18:17:40 EDT
*** Bug 3660 has been marked as a duplicate of this bug. ***
Comment 2 Anand Avati 2011-09-29 04:14:24 EDT
CHANGE: http://review.gluster.com/515 (Change-Id: I0553bb7f64d69f5684c3d21f3809da4e9e3529c1) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 Anand Avati 2011-09-29 04:14:46 EDT
CHANGE: http://review.gluster.com/519 (Change-Id: Ibcaaa9c928195939ff1e31b28b592e524e63a423) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 4 krishnan parthasarathi 2011-10-13 04:54:42 EDT
*** Bug 3575 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.