Bug 766044 - [abrt] notification-daemon-0.7.3-2.fc16: g_return_if_fail_warning: Process /usr/libexec/notification-daemon was killed by signal 5 (SIGTRAP)
[abrt] notification-daemon-0.7.3-2.fc16: g_return_if_fail_warning: Process /u...
Status: CLOSED DUPLICATE of bug 712907
Product: Fedora
Classification: Fedora
Component: notification-daemon (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
abrt_hash:dcc5ecd98adfded6e4c04f6a031...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 16:54 EST by Stuart D Gathman
Modified: 2013-03-05 23:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-24 16:55:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: build_ids (3.40 KB, text/plain)
2011-12-09 16:54 EST, Stuart D Gathman
no flags Details
File: smolt_data (2.37 KB, text/plain)
2011-12-09 16:54 EST, Stuart D Gathman
no flags Details
File: maps (26.82 KB, text/plain)
2011-12-09 16:54 EST, Stuart D Gathman
no flags Details
File: backtrace (27.63 KB, text/plain)
2011-12-09 16:54 EST, Stuart D Gathman
no flags Details

  None (edit)
Description Stuart D Gathman 2011-12-09 16:54:48 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/libexec/notification-daemon
crash_function: g_return_if_fail_warning
executable:     /usr/libexec/notification-daemon
kernel:         3.1.4-1.fc16.i686
pid:            3025
pwd:            /home/stuart
reason:         Process /usr/libexec/notification-daemon was killed by signal 5 (SIGTRAP)
time:           Fri 09 Dec 2011 04:04:05 PM EST
uid:            902
username:       stuart

backtrace:      Text file, 28294 bytes
build_ids:      Text file, 3485 bytes
maps:           Text file, 27463 bytes
smolt_data:     Text file, 2422 bytes

dso_list:
:/usr/lib/gio/modules/libgvfsdbus.so gvfs-1.10.1-2.fc16.i686 (Fedora Project) 1320287452
:/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so librsvg2-2.34.1-1.fc16.i686 (Fedora Project) 1320287378
:/usr/lib/gtk-3.0/modules/libcanberra-gtk3-module.so libcanberra-gtk3-0.28-3.fc16.i686 (Fedora Project) 1320287378
:/usr/share/icons/hicolor/icon-theme.cache hicolor-icon-theme-0.12-3.fc16.noarch (Fedora Project) 1320287322
:/usr/share/icons/gnome/icon-theme.cache gnome-icon-theme-3.2.1.2-1.fc16.noarch (Fedora Project) 1322692777
:/usr/lib/gio/modules/libdconfsettings.so dconf-0.10.0-1.fc16.i686 (Fedora Project) 1320287361
:/usr/lib/locale/locale-archive glibc-common-2.14.90-19.i686 (Fedora Project) 1322692731
:/usr/lib/libcanberra-0.28/libcanberra-pulse.so libcanberra-0.28-3.fc16.i686 (Fedora Project) 1320287360
:/usr/lib/gtk-3.0/modules/libpk-gtk-module.so PackageKit-gtk3-module-0.6.20-1.fc16.i686 (Fedora Project) 1322693111
:/usr/lib/gio/modules/libgioremote-volume-monitor.so gvfs-1.10.1-2.fc16.i686 (Fedora Project) 1320287452
:/usr/share/fonts/abattis-cantarell/Cantarell-Regular.otf abattis-cantarell-fonts-0.0.7-1.fc16.noarch (Fedora Project) 1320287314
:/lib/libnss_files-2.14.90.so glibc-2.14.90-19.i686 (Fedora Project) 1322692739
:/usr/lib/gtk-3.0/3.0.0/theming-engines/libadwaita.so adwaita-gtk3-theme-3.2.1-2.fc16.i686 (Fedora Project) 1320287399
:/usr/lib/gconv/gconv-modules.cache glibc-2.14.90-19.i686 (Fedora Project) 1322692739
:/usr/share/locale/en/LC_MESSAGES/gtk30.mo gtk3-3.2.1-1.fc16.i686 (Fedora Project) 1320287377
:/usr/share/fonts/abattis-cantarell/Cantarell-Bold.otf abattis-cantarell-fonts-0.0.7-1.fc16.noarch (Fedora Project) 1320287314

environ:
:XDG_VTNR=3
:XDG_SESSION_ID=5
:SSH_AGENT_PID=2963
:HOSTNAME=sdg.bmsi.com
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=fdeb37f4536ada2d118486fc00000010-1323458603.921014-1009730537
:GNOME_KEYRING_CONTROL=/tmp/keyring-GwyO4Q
:IMSETTINGS_MODULE=none
:USER=stuart
:SSH_AUTH_SOCK=/tmp/keyring-GwyO4Q/ssh
:USERNAME=stuart
:MAIL=/var/spool/mail/stuart
:DESKTOP_SESSION=compiz-gnome
:PATH=/home/stuart/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/stuart/bin
:QT_IM_MODULE=xim
:PWD=/home/stuart
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=2817
:GDM_LANG=en_US.UTF-8
:GDMSESSION=compiz-gnome
:HISTCONTROL=ignoredups
:SHLVL=1
:XDG_SEAT=seat0
:HOME=/home/stuart
:LOGNAME=stuart
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-MGbqcQhL6u,guid=c623fc087b370a77bafb544f00000193
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=3
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/stuart
:XAUTHORITY=/var/run/gdm/auth-for-stuart-ih7o3o/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2821,unix/unix:/tmp/.ICE-unix/2821
:GPG_AGENT_INFO=/tmp/keyring-GwyO4Q/gpg:0:1
:DESKTOP_AUTOSTART_ID=1010a15d4dc3e9db9f132345860488784500000028210037

var_log_messages:
:Dec  9 16:04:05 sdg abrt[21393]: File '/usr/libexec/notification-daemon.#prelink#.jyTJu4' seems to be deleted
:Dec  9 16:04:05 sdg abrt[21393]: File '/usr/libexec/notification-daemon.#prelink#.jyTJu4' seems to be a prelink temporary file
:Dec  9 16:04:06 sdg abrt[21393]: Saved core dump of pid 3025 (/usr/libexec/notification-daemon) to /var/spool/abrt/ccpp-2011-12-09-16:04:05-3025 (20611072 bytes)
Comment 1 Stuart D Gathman 2011-12-09 16:54:51 EST
Created attachment 544720 [details]
File: build_ids
Comment 2 Stuart D Gathman 2011-12-09 16:54:52 EST
Created attachment 544721 [details]
File: smolt_data
Comment 3 Stuart D Gathman 2011-12-09 16:54:53 EST
Created attachment 544722 [details]
File: maps
Comment 4 Stuart D Gathman 2011-12-09 16:54:55 EST
Created attachment 544723 [details]
File: backtrace
Comment 5 Stuart D Gathman 2011-12-13 16:42:58 EST
I see a pattern.  The crash happens when rhythmbox attempts to use the notifier (starting a new track). 
Sometimes rhythmbox crashes (e.g. bug#755253), sometimes the notifier crashes,
sometimes (rarely) it actually works.
Comment 6 Stuart D Gathman 2011-12-14 15:44:27 EST
Ooops, I meant bug#766236
Comment 7 Stuart D Gathman 2012-01-24 16:55:03 EST

*** This bug has been marked as a duplicate of bug 712907 ***

Note You need to log in before you can comment on or make changes to this bug.