Bug 766482 - No validation for stripe block size
No validation for stripe block size
Status: CLOSED DUPLICATE of bug 765248
Product: GlusterFS
Classification: Community
Component: stripe (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-12 01:55 EST by shylesh
Modified: 2013-12-08 20:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-27 01:24:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2011-12-12 01:55:42 EST
Description of problem:
Volume set needs validation for stripe size to be multiple of 512 bytes

Version-Release number of selected component (if applicable):
3.3.0qa15

How reproducible:
Always

Steps to Reproduce:
1. Create a stripe volume (by default stripe block size 128KB)
2. Change the stripe size using volume set command , say 513 

  
Actual results:
Stripe size will be set for the volume 

Expected results:
Command should err out saying stripe block size should be multiple of 512 bytes

Additional info:
Comment 1 shylesh 2011-12-12 05:09:49 EST
Validation needs to be done for numbers, as of now volume set accepts even alphabets as stripe size.
Comment 2 shishir gowda 2011-12-27 01:24:05 EST

*** This bug has been marked as a duplicate of bug 765248 ***

Note You need to log in before you can comment on or make changes to this bug.