Bug 766532 - Stripe related xattrs are not migrated after replace-brick commit operation
Stripe related xattrs are not migrated after replace-brick commit operation
Status: CLOSED DUPLICATE of bug 783916
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
Depends On:
  Show dependency treegraph
Reported: 2011-12-12 04:49 EST by shylesh
Modified: 2015-11-03 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-01-24 04:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description shylesh 2011-12-12 04:49:03 EST
Description of problem:
The xattrs for the stripe volume are not migrated after replace-brick operation

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Create a stripe volume with 2 bricks
2.mount the volume and create some files on it
3.verify the stripe related xattrs for the file in the backend
4. Replace the bricks and commit
5. Now verify the backend bricks for stripe xattrs
Actual results:
None of the stripe xattrs are migrated, because of this any further operation on existing files gives I/O error

Expected results:
Xattrs should migrate after replace-brick

Additional info:
Comment 1 krishnan parthasarathi 2012-01-24 04:04:21 EST

*** This bug has been marked as a duplicate of bug 783916 ***

Note You need to log in before you can comment on or make changes to this bug.