Bug 783916 - value for Stripe related xattrs are not showing the proper value upon getxattr on mount point
value for Stripe related xattrs are not showing the proper value upon getxatt...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: stripe (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: shishir gowda
:
: 766532 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-01-23 03:47 EST by shylesh
Modified: 2013-12-08 20:28 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 14:02:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-01-23 03:47:22 EST
Description of problem:

on the point doing getxattr shows no value for the stripe related xattrs

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Often

Steps to Reproduce:
1.create a stripe volume
2. touch a file on the mount point
3. run "getxattr -d -e text -m . *"
  
Actual results:
Stripe related xattrs will not be having any value

Expected results:


Additional info:
Comment 1 shishir gowda 2012-01-23 03:52:08 EST
This is a regression. Bug 771313 introduced this.

the size being passed to sys_lgetxattr is 0, hence the value received is always NULL.
Comment 2 Anand Avati 2012-01-23 12:42:45 EST
CHANGE: http://review.gluster.com/2676 (storage/posix: Pass correct size to sys_lgetxattr) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 krishnan parthasarathi 2012-01-24 04:04:21 EST
*** Bug 766532 has been marked as a duplicate of this bug. ***
Comment 4 shylesh 2012-05-07 03:13:40 EDT
Now stripe related xattrs will not be shown on the mount point.

Note You need to log in before you can comment on or make changes to this bug.