Bug 766559 - unlocalised strings for subscription-manager identity
unlocalised strings for subscription-manager identity
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 6.3
Assigned To: Engineering Localization bugs mailing list
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 738066 813268
  Show dependency treegraph
 
Reported: 2011-12-12 05:56 EST by Shwetha Kallesh
Modified: 2012-06-20 09:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 813268 (view as bug list)
Environment:
Last Closed: 2012-06-20 09:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2011-12-12 05:56:31 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
[root@tiger ca]# for l in as_IN bn_IN hi_IN mr_IN gu_IN kn_IN ml_IN or_IN pa_IN ta_IN te_IN; do echo "";echo ""; 
> echo "# LANG=$l.UTF8 subscription-manager identity"; LANG=$l.UTF8
> subscription-manager identity; done;


# LANG=as_IN.UTF8 subscription-manager identity
বৰ্তমান পৰিচয় হল: 5bff28bc-bc12-4676-9666-56374b97d6a9
নাম: tiger.lab.eng.pnq.redhat.com
সংঘঠন নাম: Admin Owner
সংঘঠন আইডি: 0000000034272834013427285cef0007


# LANG=bn_IN.UTF8 subscription-manager identity
বর্তমানে ব্যবহৃত পরিচিতি: 5bff28bc-bc12-4676-9666-56374b97d6a9
নাম: tiger.lab.eng.pnq.redhat.com
প্রতিষ্ঠানের নাম: Admin Owner
প্রতিষ্ঠানের id: 0000000034272834013427285cef0007


# LANG=hi_IN.UTF8 subscription-manager identity
मौजूदा पहचान है: 5bff28bc-bc12-4676-9666-56374b97d6a9
नाम: tiger.lab.eng.pnq.redhat.com
संगठन का नाम: Admin Owner
 संगठन आईडी: 0000000034272834013427285cef0007


# LANG=mr_IN.UTF8 subscription-manager identity
सध्याची ओळख: 5bff28bc-bc12-4676-9666-56374b97d6a9
नाव: tiger.lab.eng.pnq.redhat.com
संस्थाचे नाव: Admin Owner
संस्थाचे id: 0000000034272834013427285cef0007


# LANG=gu_IN.UTF8 subscription-manager identity
હાલની ઓળખાણ આ છે: 5bff28bc-bc12-4676-9666-56374b97d6a9
નામ: tiger.lab.eng.pnq.redhat.com
સંસ્થા નામ: Admin Owner
સંસ્થા id: 0000000034272834013427285cef0007


# LANG=kn_IN.UTF8 subscription-manager identity
ಪ್ರಸಕ್ತ ಗುರುತು: 5bff28bc-bc12-4676-9666-56374b97d6a9
ಹೆಸರು: tiger.lab.eng.pnq.redhat.com
ಸಂಸ್ಥೆಯ ಹೆಸರು: Admin Owner
ಸಂಸ್ಥೆಯ id: 0000000034272834013427285cef0007


# LANG=ml_IN.UTF8 subscription-manager identity
Current identity is: 5bff28bc-bc12-4676-9666-56374b97d6a9
name: tiger.lab.eng.pnq.redhat.com
org name: Admin Owner
org id: 0000000034272834013427285cef0007


# LANG=or_IN.UTF8 subscription-manager identity
ବର୍ତ୍ତମାନର ପରିଚୟଟି ହେଉଛି: 5bff28bc-bc12-4676-9666-56374b97d6a9
ନାମ: tiger.lab.eng.pnq.redhat.com
ଅନୁଷ୍ଠାନ ନାମ: Admin Owner
ଅନୁଷ୍ଠାନ id: 0000000034272834013427285cef0007


# LANG=pa_IN.UTF8 subscription-manager identity
ਮੌਜੂਦਾ ਸ਼ਨਾਖਤ ਹੈ: 5bff28bc-bc12-4676-9666-56374b97d6a9
ਨਾਂ: tiger.lab.eng.pnq.redhat.com
ਸੰਗਠਨ ਨਾਂ: Admin Owner
ਸੰਗਠਨ id: 0000000034272834013427285cef0007


# LANG=ta_IN.UTF8 subscription-manager identity
நடப்பு அடையாளம்: 5bff28bc-bc12-4676-9666-56374b97d6a9
பெயர்: tiger.lab.eng.pnq.redhat.com
org பெயர்: Admin Owner
org id: 0000000034272834013427285cef0007


# LANG=te_IN.UTF8 subscription-manager identity
ప్రస్తుత గుర్తింపు: 5bff28bc-bc12-4676-9666-56374b97d6a9
పేరు: tiger.lab.eng.pnq.redhat.com
సంస్థ పేరు: Admin Owner
సంస్థ ఐడి: 0000000034272834013427285cef0007

  
Actual results:


Expected results:

Strings to be localised for ml_IN

Additional info:
Comment 1 Shwetha Kallesh 2011-12-12 05:58:13 EST
RPM used:

[root@tiger ca]# rpm -qa | grep subscription-manager 
subscription-manager-debuginfo-0.98.3-1.el5
subscription-manager-gnome-0.98.7-1.git.0.b436f93.el5_7
subscription-manager-firstboot-0.98.7-1.git.0.b436f93.el5_7
subscription-manager-migration-0.98.7-1.git.0.b436f93.el5_7
subscription-manager-0.98.7-1.git.0.b436f93.el5_7
Comment 4 Shwetha Kallesh 2012-03-28 06:30:50 EDT
Moving the bug back to new.


[root@skallesh entitlement]# for l in as_IN bn_IN hi_IN mr_IN gu_IN kn_IN ml_IN or_IN pa_IN ta_IN te_IN; do echo "";echo "";echo "# LANG=$l.UTF8 subscription-manager identity";LANG=$l.UTF8 subscription-manager identity; done;


# LANG=as_IN.UTF8 subscription-manager identity
বৰ্তমান পৰিচয় হল: 700762ff-fbf0-48bb-a59f-510987015220
নাম: skallesh.csb
সংঘঠন নাম: Admin Owner
সংঘঠন আইডি: 00000000364ee6fc01364ee71f220025


# LANG=bn_IN.UTF8 subscription-manager identity
বর্তমানে ব্যবহৃত পরিচিতি: 700762ff-fbf0-48bb-a59f-510987015220
নাম: skallesh.csb
প্রতিষ্ঠানের নাম: Admin Owner
প্রতিষ্ঠানের id: 00000000364ee6fc01364ee71f220025


# LANG=hi_IN.UTF8 subscription-manager identity
मौजूदा पहचान है: 700762ff-fbf0-48bb-a59f-510987015220
नाम: skallesh.csb
संगठन का नाम: Admin Owner
 संगठन आईडी: 00000000364ee6fc01364ee71f220025


# LANG=mr_IN.UTF8 subscription-manager identity
सध्याची ओळख: 700762ff-fbf0-48bb-a59f-510987015220
नाव: skallesh.csb
संस्थाचे नाव: Admin Owner
संस्थाचे id: 00000000364ee6fc01364ee71f220025


# LANG=gu_IN.UTF8 subscription-manager identity
હાલની ઓળખાણ આ છે: 700762ff-fbf0-48bb-a59f-510987015220
નામ: skallesh.csb
સંસ્થા નામ: Admin Owner
સંસ્થા id: 00000000364ee6fc01364ee71f220025


# LANG=kn_IN.UTF8 subscription-manager identity
ಪ್ರಸಕ್ತ ಗುರುತು: 700762ff-fbf0-48bb-a59f-510987015220
ಹೆಸರು: skallesh.csb
ಸಂಸ್ಥೆಯ ಹೆಸರು: Admin Owner
ಸಂಸ್ಥೆಯ id: 00000000364ee6fc01364ee71f220025


# LANG=ml_IN.UTF8 subscription-manager identity
നിലവിലുള്ള തിരിച്ചറിയല്‍: 700762ff-fbf0-48bb-a59f-510987015220
പേരു്: skallesh.csb
സ്ഥാപനത്തിന്റെ പേരു്: Admin Owner
സ്ഥാപനത്തിന്റെ ഐഡി: 00000000364ee6fc01364ee71f220025


# LANG=or_IN.UTF8 subscription-manager identity
ବର୍ତ୍ତମାନର ପରିଚୟଟି ହେଉଛି: 700762ff-fbf0-48bb-a59f-510987015220
ନାମ: skallesh.csb
ଅନୁଷ୍ଠାନ ନାମ: Admin Owner
ଅନୁଷ୍ଠାନ id: 00000000364ee6fc01364ee71f220025


# LANG=pa_IN.UTF8 subscription-manager identity
ਮੌਜੂਦਾ ਸ਼ਨਾਖਤ ਹੈ: 700762ff-fbf0-48bb-a59f-510987015220
ਨਾਂ: skallesh.csb
ਸੰਗਠਨ ਨਾਂ: Admin Owner
ਸੰਗਠਨ id: 00000000364ee6fc01364ee71f220025


# LANG=ta_IN.UTF8 subscription-manager identity
நடப்பு அடையாளம்: 700762ff-fbf0-48bb-a59f-510987015220
பெயர்: skallesh.csb
org பெயர்: Admin Owner
org id: 00000000364ee6fc01364ee71f220025


# LANG=te_IN.UTF8 subscription-manager identity
ప్రస్తుత గుర్తింపు: 700762ff-fbf0-48bb-a59f-510987015220
పేరు: skallesh.csb
సంస్థ పేరు: Admin Owner
సంస్థ ఐడి: 00000000364ee6fc01364ee71f220025


string id in some of the languages and string "org" for ta_IN needs to be translated as well
Comment 5 Shwetha Kallesh 2012-03-28 06:31:29 EDT
RPM used to verify:
[root@skallesh ~]# rpm -qa | grep subscription-manager
subscription-manager-debuginfo-0.99.12-1.el6.x86_64
subscription-manager-migration-0.99.12-1.git.2.7747155.el6.x86_64
subscription-manager-migration-data-1.12.1.2-1.git.0.9e244c8.el6.noarch
subscription-manager-0.99.12-1.git.2.7747155.el6.x86_64
subscription-manager-firstboot-0.99.12-1.git.2.7747155.el6.x86_64
subscription-manager-gnome-0.99.12-1.git.2.7747155.el6.x86_64
Comment 6 Chris Duryee 2012-04-03 11:14:54 EDT
The translations were not updated for that string:

(from ta.po)

#: ../src/subscription_manager/managercli.py:427
#, python-format
msgid "org name: %s"
msgstr "org பெயர்: %s"

#: ../src/subscription_manager/managercli.py:428
#, python-format
msgid "org id: %s"
msgstr "org id: %s"


For the other strings, I am not sure if "ID" is like "OK" in that it does not get translated.

Ankit: do you know if "id" is the same across languages?
Comment 7 Ankit Patel 2012-04-04 00:35:48 EDT
(In reply to comment #6)
> The translations were not updated for that string:
> 
> (from ta.po)
> 

I think it makes sense to revert both of the messages into English.

> 
> For the other strings, I am not sure if "ID" is like "OK" in that it does not
> get translated.
> 
> Ankit: do you know if "id" is the same across languages?

Not necessary, it varies language by language depends upon their translation style, language criteria, etc.
Comment 8 Chris Duryee 2012-04-09 11:51:03 EDT
Moving bz to translation team to alter the translations in ta.po per comment #7.

Once it's altered in zanata, just assign back to us and we can update the bz to MODIFIED status once the translation is pulled down into our code.
Comment 9 Hedda Peters 2012-04-12 20:05:34 EDT
Unfortunately, we currently have no resources for ta-IN. 
Unable to fix right now.

Ankit, do you want to keep note of this bug until we have a new ta-IN onboard?
Comment 10 Ankit Patel 2012-04-13 00:44:06 EDT
(In reply to comment #9)
> Unfortunately, we currently have no resources for ta-IN. 
> Unable to fix right now.
> 
> Ankit, do you want to keep note of this bug until we have a new ta-IN onboard?

Yes,

Let's have a new bug for Tamil (ta-IN) and get this bug resolved for all the languages where the translations are available.

Thanks!
Ankit
Comment 12 John Sefler 2012-04-17 17:57:46 EDT
Moving this bug to VERIFIED since the msgid for all of these cases has indeed been externalized for translation into the rhsm.mo files.  In many languages, abbreviated words like "Id" are not translated by the translators by convention as indicated in comment 7.

Please follow bug 813268 which will track the msgid for "org id: %s" which was not translated by the Tamil language translator...

[root@jsefler-r63-server ~]# msgunfmt /usr/share/locale/ta/LC_MESSAGES/rhsm.mo | grep "org id" -A1
msgid "org id: %s"
msgstr "org id: %s"
Comment 14 errata-xmlrpc 2012-06-20 09:04:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.