Bug 813268 - [ta_IN] unlocalised strings for subscription-manager identity
[ta_IN] unlocalised strings for subscription-manager identity
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
IDM QE LIST
: i18n, Translation
Depends On: 766559
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-04-17 07:16 EDT by Bryan Kearney
Modified: 2014-06-17 20:21 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 766559
Environment:
Last Closed: 2014-06-13 07:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 John Sefler 2012-04-17 18:10:26 EDT
[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.14-1.el6.x86_64

[root@jsefler-r63-server ~]# msgunfmt /usr/share/locale/ta/LC_MESSAGES/rhsm.mo | grep "org" -A1
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"MIME-Version: 1.0\n"
--
msgid "%s cannot register to any organizations."
msgstr "எந்த நிறுவனங்களுக்கும் %s ஐ பதிவுசெய்ய முடியாது."
--
msgid "<b>User %s is not able to register with any orgs.</b>"
msgstr "<b>பயனர் %s எந்த orgs உடனும் பதிவு செய்ய முடியாது.</b>"

--
"Contact your system administrator if you have forgotten your login or "
"password"
--
msgid "Display the orgs against which a user can register a system"
msgstr "ஒரு கணினியில் பதிவுசெய்ய ஒரு பயனருக்கு எதிராக orgs ஐ காட்டவும்"

--
msgid "Error: Must specify --org to register to an environment."
msgstr "பிழை: ஒரு சூழலுக்கு பதுவுசெய்ய --org ஐ குறிப்பிட வேண்டும்."

msgid "Error: Must specify --org to register with activation keys."
msgstr "பிழை: செயல்பாட்டு விசைகளுடன் பதிவுசெய்ய --org ஐ குறிப்பிட வேண்டும்."

--
msgid "Error: Unable to retrieve org list from Entitlement Platform"
msgstr "பிழை: உரிம மேடையிலிருந்து  org பட்டியலை பெற முடியவில்லை"

--
msgid "Error: you must register or specify --org."
msgstr "பிழை: --org-ஐ பதிவு செய்ய வேண்டும் அல்லது குறிப்பிட வேண்டும்."

--
msgid "Fetching list of possible organizations"
msgstr "சாத்தியமான நிறுவனங்களை கொணரும் பட்டியல்"
--
msgid "This org does not have any subscriptions with service levels."
msgstr "இந்த org சேவை நிலைகளுடன் எந்த சந்தாக்களையும் கொண்டிருக்க வில்லை."

--
msgid "org id: %s"
msgstr "org id: %s"

msgid "org name: %s"
msgstr "org பெயர்: %s"

--
msgid "register to a specific environment in the destination org"
msgstr "இலக்கு org இல் ஒரு குறிப்பிட்ட சூழலுக்கு பதிவுசெய்யவும்"

msgid "register to one of multiple organizations for the user"
msgstr "பயனருக்காக பல நிறுவனங்கள் ஒன்றில் பதிவுசெய்யவும்"
--
msgid "specify org for environment list"
msgstr "சூழல் பட்டியலுக்காக  org ஐ குறிப்பிடவும்"

msgid "specify org for service level list"
msgstr "சேவை நிலை பட்டியலுக்கு org-ஐ குறிப்பிடவும்"

--
msgid "you must specify an --org"
msgstr "ஒரு --org குறிப்பிட வேண்டும்"


^^ It appears that the Tamil language translator did not translate the abbreviation "org" in any of the msgstr values whose msgid contained "org".  I suspect there is not a good translation for "org" in Tamil.  Coupled with the fact that many translators choose not to translate abbreviations like "ID", the msgid "org id: %s" remains completely untranslated.  I believe this was a concious decision by the Tamil language translator.
Comment 3 Ankit Patel 2012-04-18 00:33:13 EDT
Since we don't have in-house Tamil Translator at the moment, we have to wait till we hire a Tamil Translator.

Thanks!
Ankit
Comment 5 RHEL Product and Program Management 2012-07-10 04:47:35 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:49:07 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 RHEL Product and Program Management 2012-12-14 03:47:45 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 Adrian Likins 2014-01-31 10:14:48 EST
identity messages are all translated for ta_IN now, and ta_IN is 100%
Comment 11 Sharath Dwaral 2014-02-04 17:01:43 EST
Comment 10 overlooked 

msgid "org ID: %s"
msgstr "நிறுவன ID: %s"

This is the only occurrence where Org is translated and would prefer it untranslated throughout.

Moving it to POST till a new sting pull is made.
Comment 12 John Sefler 2014-02-04 17:26:25 EST
[root@jsefler-7 ~]# subscription-manager identity
system identity: a7403810-b456-498a-b3f5-3ea3d37937bf
name: jsefler-7.usersys.redhat.com
org name: Admin Owner
org ID: admin


[root@jsefler-7 ~]# LANG=ta_IN.utf8 subscription-manager identity
கணினி அடையாளம்: a7403810-b456-498a-b3f5-3ea3d37937bf
பெயர்: jsefler-7.usersys.redhat.com
org பெயர்: Admin Owner
நிறுவன ID: admin
^^^^^

As indicated in comment 11 and demonstrated in the context above, the msgid "org ID: %s" should remain untranslated.  I just updated Zanata and the change will be applied with the next string pull.
Comment 13 John Sefler 2014-02-18 13:49:35 EST
Verifying Version...

[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.10.14-1.el7.x86_64


[root@jsefler-7 ~]# LANG=ta_IN.utf8 subscription-manager identity
கணினி அடையாளம்: fdbd5d52-eea5-40a5-87d7-cd3a855302bd
பெயர்: jsefler-7.usersys.redhat.com
org பெயர்: stage_test_27 User
org ID: 7066392

^^^
VERIFIED: The word "org" is now consistently left untranslated in the context of running the identity command in LANG=ta_IN
Comment 14 Ludek Smid 2014-06-13 07:43:47 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.