Bug 76684 - Automatically configure Dynamic DNS w/ dhclient
Automatically configure Dynamic DNS w/ dhclient
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-24 17:42 EDT by Dan Morrill
Modified: 2014-03-16 22:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:11:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Morrill 2002-10-24 17:42:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
RH8 discontinued pump, which I previously used since it did dynamic DNS updates
when it got its lease.  dhclient is also capable of this, but requires a bit of
configuration.

/etc/sysconfig/network-scripts/ifup should be augmented to automatically
generate a dhclient.conf file for each interface, containing a line like:

send fqdn.fqdn "[[[FOO]]]";

...where the value of "[[[FOO]]]" is fetched from the HOSTNAME variable defined
in /etc/sysconfig/network.

ifup already invokes dhclient to use a device-specific config file, so that much
is easy.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with DHCP enabled.	

Actual Results:  N/A

Expected Results:  N/A

Additional info:

See also bug 76681.  (I refer to that bug in the text below.)

This change would make the dhclient-${IFACE}.conf files auto-generated and
volatile, meaning that this would have to make use of the
/etc/sysconfig-for-user-defined-data model, similar to, say,
/etc/sysconfig/network, or /etc/sysconfig/desktop.  The dhclient-${IFACE}.conf
files might be placed in /var, for example, or perhaps just overwritten in
/etc/dhclient.d/.

I suggest specifically something like this:

/etc/dhclient.d/ - contains generated dhclient.conf files
/etc/sysconfig/dhclient-${IFACE} - contains files containing user config
templates for a given iface

Alternatively, you could just have ifup only generate /etc/dhclient.d/ files if
they don't already exist, but that's hard to check for (since you can't tell if
ifup generated it or if the user did.)

Or, you could argue that this is NOTABUG and just close it, I suppose. :) 
Mostly I'm just interested in having dynamic DNS work out of the box because it
used to on pump -- I view this as a (minor) regression.
Comment 1 Bill Nottingham 2005-09-29 17:11:11 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.