Bug 766919 - RFE: Block size of hard drive should be available
Summary: RFE: Block size of hard drive should be available
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: inventory
Version: 0.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 0.12
Assignee: Dan Callaghan
QA Contact: Amit Saha
URL:
Whiteboard: Inventory
Keywords: FutureFeature
: 609513 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-12 19:35 UTC by Marian Ganisin
Modified: 2018-08-06 13:38 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-04-11 04:57:11 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1612338 None CLOSED <disk><sector_size> xml filter queries physical sector size instead of logical 2019-04-25 08:43 UTC

Internal Trackers: 1612338

Description Marian Ganisin 2011-12-12 19:35:46 UTC
Description of problem:

New hard drives use 4kB blocks instead of 512B. We need to be able to find particular disks for testing purpose.

Additionally, there are 2 sorts of realization. There are native 4kB drives, 4k blocks are exposed to system. There is also backward compatible option, 4k blocks are used internally in drive, however 512B blocks are exposed to system.

Comment 1 Dan Callaghan 2011-12-12 23:38:23 UTC
Any hints on where we could get this information from? We are currently using libparted to find disk info -- would this be the sector_size and phys_sector_size fields in the PedDevice struct?

http://www.gnu.org/software/parted/api/struct__PedDevice.html

Comment 2 Marian Ganisin 2011-12-13 06:38:48 UTC
(In reply to comment #1)
> Any hints on where we could get this information from? We are currently using
> libparted to find disk info -- would this be the sector_size and
> phys_sector_size fields in the PedDevice struct?
> 
> http://www.gnu.org/software/parted/api/struct__PedDevice.html

Yes, these are the values.

Comment 3 Dan Callaghan 2013-01-03 00:44:43 UTC
James has done most of the work for this, I think we should get it released.

Comment 5 Dan Callaghan 2013-01-15 03:46:42 UTC
One thing not implemented by James was the ability to search by disk size (and sector size) in the web UI and in hostRequires.

Comment 8 Dan Callaghan 2013-02-14 07:56:23 UTC
The disk info collection itself was merged a while back, these two patches (which apparently I forgot to post here) add search:

http://gerrit.beaker-project.org/1653
http://gerrit.beaker-project.org/1654

Comment 12 Dan Callaghan 2013-04-11 04:57:11 UTC
Beaker 0.12 has been released.

Comment 13 Nick Coghlan 2013-07-15 07:11:59 UTC
*** Bug 609513 has been marked as a duplicate of this bug. ***

Comment 14 Pavel Cahyna 2018-08-06 13:38:55 UTC
FYI it seems that filtering by logical sector size never worked, it has been equivalent to physical sector size. Therefore one can not distinguish between native 4kB and 512 emulated.


Note You need to log in before you can comment on or make changes to this bug.