Bug 609513 - RFE: Add disk controller/model information in Beaker
Summary: RFE: Add disk controller/model information in Beaker
Status: CLOSED DUPLICATE of bug 766919
Alias: None
Product: Beaker
Classification: Community
Component: inventory   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard: Inventory
Keywords: FutureFeature
: 591978 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 13:22 UTC by Alexander Todorov
Modified: 2018-02-06 00:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 07:11:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Todorov 2010-06-30 13:22:27 UTC
Description of problem:

(16,17,33) atodorov: bpeck: how can I search for a particular disk model in Beaker
(16,17,51) atodorov: bpeck: I need a system with WD20EADS disk
(16,18,59) bpeck: atodorov: I don't think we have that info right now
(16,19,32) atodorov: bpeck: ok, opening a bug for that. how hard is it to add this kind of info ? 
(16,20,38) bpeck: atodorov: if its just a key/value thing then not too hard.  But we want to model this stuff better in the future.  I imagine the next question might be I want that disk off of a qlogic 2310 controller.
(16,20,57) bpeck: which is not easily modeled in key/value pairs
(16,21,21) atodorov: bpeck: right, or in my recent tests I need any disk connected to a particular controller

Comment 1 Matt Brodeur 2010-08-10 19:37:38 UTC
*** Bug 591978 has been marked as a duplicate of this bug. ***

Comment 2 Qian Cai 2011-04-26 03:18:32 UTC
Ping, any update?

Comment 3 Bill Peck 2011-04-26 13:59:30 UTC
suggesting we update the inventory scripts to record the following key_value pairs:

Key                     Value
Controller,Disk         1077:2300,WD20EADS
Controller,Disk         103c:3230,WD20EADS


Then a user can request via the following:

<key_value name="Controller,Disk" op="like" value="%,WD20EADS"

or

<key_value name="Controller,Disk" op="like" value="103c:3230,%"

Currently we don't support the "like" operator but that would be easy to add.

The downside here is it doesn't help us find systems with a particular disk size.

Comment 4 Raymond Mancy 2011-04-26 23:46:49 UTC
(In reply to comment #3)
> suggesting we update the inventory scripts to record the following key_value
> pairs:
> 
> Key                     Value
> Controller,Disk         1077:2300,WD20EADS
> Controller,Disk         103c:3230,WD20EADS
> 
> 
> Then a user can request via the following:
> 
> <key_value name="Controller,Disk" op="like" value="%,WD20EADS"
> 
> or
> 
> <key_value name="Controller,Disk" op="like" value="103c:3230,%"
> 
> Currently we don't support the "like" operator but that would be easy to add.
> 

We do though support the wildcard '*' with the 'is' operator.

> The downside here is it doesn't help us find systems with a particular disk
> size.

Comment 5 Raymond Mancy 2011-04-26 23:47:54 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > suggesting we update the inventory scripts to record the following key_value
> > pairs:
> > 
> > Key                     Value
> > Controller,Disk         1077:2300,WD20EADS
> > Controller,Disk         103c:3230,WD20EADS
> > 
> > 
> > Then a user can request via the following:
> > 
> > <key_value name="Controller,Disk" op="like" value="%,WD20EADS"
> > 
> > or
> > 
> > <key_value name="Controller,Disk" op="like" value="103c:3230,%"
> > 
> > Currently we don't support the "like" operator but that would be easy to add.
> > 
> 
> We do though support the wildcard '*' with the 'is' operator.
> 

Sorry, first day at work for 5 days. Of course the wildcard only exists for the search bar...

> > The downside here is it doesn't help us find systems with a particular disk
> > size.

Comment 6 Nick Coghlan 2013-07-15 07:11:59 UTC
Collection of disk model and geometry information was added to the inventory task in bug 766919. If any further details are needed (such as controller details), please open a new feature request.

*** This bug has been marked as a duplicate of bug 766919 ***


Note You need to log in before you can comment on or make changes to this bug.