Bug 766955 - Rawhide live images do not boot (nightlies and manually-created with livecd-creator)
Summary: Rawhide live images do not boot (nightlies and manually-created with livecd-c...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: rawhide
Hardware: All
OS: Linux
high
urgent
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F17Alpha, F17AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2011-12-12 20:49 UTC by bodhi.zazen
Modified: 2012-07-18 14:54 UTC (History)
33 users (show)

Fixed In Version: livecd-tools-17.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-19 00:34:12 UTC
Type: ---


Attachments (Terms of Use)

Description bodhi.zazen 2011-12-12 20:49:57 UTC
Description of problem: Rawhide nightly builds are not booting either from CD or using live cd creator.


Version-Release number of selected component (if applicable):

Fedora 17 , rawhide

How reproducible:

Download nightly build, try to boot.


Steps to Reproduce:

Boot
  
Actual results:

Dracut Warning; dracut: Fatal: Don't know how to handle 'root=live:CDLABEL=Fedora-17-Nightly-20111202-i6`

Expected results:

Build boots

Additional info:

Comment 1 Adam Williamson 2011-12-12 21:00:02 UTC
So the label in the parameter is obviously truncated. We are not sure if this is a bug in the nightly generation process, or in dracut.

CCing Harald and Kevin. Reproducing this is trivial: download any current nightly build - http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/ - and attempt to boot it in any way.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Adam Williamson 2011-12-12 21:00:29 UTC
Possible Alpha blocker, though Alphas would have a different label.

Comment 3 Brian Lane 2011-12-14 22:11:18 UTC
I think this is a dracut problem. I'm seeing it as well (with a livemedia created iso). file says that the iso has the following label:

/tmp/boot.iso: # ISO 9660 CD-ROM filesystem data 'rawhide 17 x86_64               ' (bootable)

and the CDLABEL has the full label string.

Comment 4 Adam Williamson 2011-12-14 22:20:02 UTC
let's assign to dracut for now then.

it should be reasonably easy to confirm the issue is in dracut by building a Rawhide live image using f16's dracut, I could try and do that later.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 bodhi.zazen 2011-12-14 22:54:56 UTC
Just FYI, there is a report here 

http://ask.fedoraproject.org/question/590/loadup-failure?comment=1438#comment-1438

of a similar problem on Fedora 16.

I asked this user to file a bug report here, but, possibly same problem / same fix for F16 and rawhide, just trying to save you all some effort.

Comment 6 Adam Williamson 2011-12-14 23:02:25 UTC
It's unlikely to be the same problem. All F17 live images generated so far fail to boot for everyone on all hardware. This is certainly not the case with F16.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 cblaauw 2011-12-15 13:55:39 UTC
Can the image be booted by changig the truncated label name to something else?

Comment 8 Jeremiah 2011-12-17 20:28:20 UTC
If I try root=/dev/sr0 I get

fsck from util-linux 2.20.1
fsck: fsck.iso9660: not found
fsck: error 2 while executing fsck.iso9660 for /dev/sr0

then it drops to a limited shell could the new .conf options in fscks have something to do with this?

Comment 9 Milan Bouchet-Valat 2011-12-25 15:44:46 UTC
I think that's really a problem with "live:", since even when using UUID=XXX (what livecd-iso-to-disk does), I get the same error. The label isn't in cause.

Comment 10 Joachim Frieben 2011-12-27 22:07:43 UTC
Issue still present for Fedora-17-Nightly-20111223.10.

Comment 11 bsfmig 2011-12-29 10:47:30 UTC
So the label in the parameter is obviously truncated. We are not sure if this
is a bug in the nightly generation process, or in dracut.

--I believe it be a dracut issue since the F16 Gnome gold release uses  'root=live:CDLABEL=Fedora-16-x86_64-Live-Desktop.is'.

Comment 12 bsfmig 2011-12-29 10:48:29 UTC
(In reply to comment #11)
> So the label in the parameter is obviously truncated. We are not sure if this
> is a bug in the nightly generation process, or in dracut.
> 
> --I believe it be a dracut issue since the F16 Gnome gold release uses 
> 'root=live:CDLABEL=Fedora-16-x86_64-Live-Desktop.is'.

Note that the filename be truncated by ONE byte.

Comment 13 Ken Dreyer 2011-12-31 21:11:55 UTC
Still seeing this with Fedora-17-Nightly-20111228.11. Is there any way to get the Rawhide composes to boot at all?

Comment 14 Antonio T. (sagitter) 2012-01-11 17:26:46 UTC
Fedora-17-Nightly-20120106.15-i686-Live-desktop.iso has the same problem.

Comment 15 Adam Williamson 2012-01-11 20:57:00 UTC
I built an image myself with livecd-creator, with the label "20120104-x86_64". It fails to boot in the same way as the nightlies, with the error:

dracut: FATAL: Don't know how to handle 'root=live:CDLABEL=20120104-x86_64'

Note that the label is not truncated, yet dracut still fails. I'm really leaning towards dracut as the culprit here.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 16 Harald Hoyer 2012-01-13 09:34:50 UTC
The "dmsquash-live" live module is missing. Please change the liveiso tools to add this dracut module on initramfs generation.

Comment 17 Laurent Charpentier 2012-01-13 14:37:42 UTC
Hi Harald,

What do you mean by "Please change the liveiso tools to
add this dracut module"? Could you elaborate.

My /usr/share/dracut/modules.d/ directory has "90dmsquash-live/parse-dmsquash-live.sh". Is there something to do to this file?

Thanks a lot
Laurent

Comment 18 Brian Lane 2012-01-13 15:01:39 UTC
The latest version of dracut drops some modules that used to be included by default. I'll add this to the dracut.conf we write out.

Comment 19 Harald Hoyer 2012-01-13 16:19:37 UTC
(In reply to comment #18)
> The latest version of dracut drops some modules that used to be included by
> default. I'll add this to the dracut.conf we write out.

/usr/lib/python*/site-packages/imgcreate/live.py:

    def __write_dracut_conf(self, path):

should also have

        f.write('add_dracutmodules+=" dmsquash-live "')


and if we are at it:

    def _mount_instroot(self, base_on = None):

- self.__write_dracut_conf(self._instroot + "/etc/dracut.conf")
+ self.__write_dracut_conf(self._instroot + "/etc/dracut.conf.d/02livecd.conf")

This will prevent /etc/dracut.conf.rpmnew and just leaves it to the user.

Comment 20 Jens Petersen 2012-01-18 01:18:35 UTC
Any ETA for a fix?  I think this bug could potentially delay F17Alpha.

Comment 21 Adam Williamson 2012-01-18 05:36:36 UTC
That's why it's marked as blocking F17Alpha. bcl was at FUDCon all weekend, I expect he'll fix this as soon as he's back into the swing of things.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 22 Greg` 2012-01-18 07:56:09 UTC
hopefully its fixed sooner rather than later

Comment 23 Adam Williamson 2012-01-19 17:52:51 UTC
confirming the fix, I built a live image with this livecd-tools and it boots all the way to X in a VM.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 24 Christopher Patrick 2012-01-20 17:29:18 UTC
when will the new isos be available at http://alt.fedoraproject.org/pub/alt/nightly-composes/

Comment 25 Peter Hedlund 2012-01-20 17:34:01 UTC
Check here for all builds: http://koji.fedoraproject.org/koji/tasks?method=createLiveCD&owner=kevin&state=all&view=tree&order=-id

I just downloaded the latest 64 bit desktop and it boots fine.

Comment 26 Kevin Fenzi 2012-01-20 17:42:28 UTC
I just updated them a bit ago.

Comment 27 Christopher Patrick 2012-01-21 00:25:19 UTC
i tried that build and it is to get to the activities windows and when it finally gets there and i click on the install icon it never brings it up so i can install it. 64 bit build of the gnome desktop from the 20th of January

Comment 28 Adam Williamson 2012-01-21 01:37:22 UTC
That's a different bug. There's no point reporting it here.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 29 Christopher Patrick 2012-01-21 01:57:08 UTC
(In reply to comment #28)
> That's a different bug. There's no point reporting it here.
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

i filed the bug for my problem https://bugzilla.redhat.com/show_bug.cgi?id=783616

Comment 30 bodhi.zazen 2012-01-21 05:55:53 UTC
Thank you, the "Fedora-17-Nightly-20120120.10-i686-Live-desktop.iso" now boots, I shall be on to other bugs ...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 31 Fedora Update System 2012-03-01 18:00:34 UTC
livecd-tools-16.11-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.11-1.fc16

Comment 32 Fedora Update System 2012-03-01 18:03:23 UTC
livecd-tools-15.12-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/livecd-tools-15.12-1.fc15

Comment 33 Fedora Update System 2012-04-13 21:34:48 UTC
livecd-tools-16.11-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 34 Frederick Grose 2012-04-24 03:01:20 UTC
The initrd0.img created on a yum update of a LiveUSB installed from
Fedora-17-Nightly-20120423.09-x86_64-Live-desktop.iso (with the kernel-3.3.2-8.fc17.x86_64) also lacks the parse-dmsquash-live.sh and several other essential live image booting components.

Comment 35 Frederick Grose 2012-05-04 21:16:01 UTC
initramfs-3.3.4-3.fc17.x86_64.img created on a yum update of a Live USB installation of Fedora-17-Nightly-20120503.13-x86_64-Live-desktop.iso continues to lack the parse-dmsquash-live.sh and the other essential live image booting components, and so fails to boot.

Am I reporting this at the right place?

Comment 36 Fedora Update System 2012-05-08 00:06:50 UTC
livecd-tools-15.13-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/livecd-tools-15.13-1.fc15

Comment 37 Fedora Update System 2012-05-27 07:24:30 UTC
livecd-tools-15.13-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.