Bug 767248 - Unable to unsuspended after kernel update to kernel-3.1.5-1.fc16.x86_64
Summary: Unable to unsuspended after kernel update to kernel-3.1.5-1.fc16.x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-13 16:05 UTC by Dennis Appelon Nielsen
Modified: 2012-02-08 22:13 UTC (History)
14 users (show)

Fixed In Version: kernel-3.1.7-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-07 23:04:59 UTC


Attachments (Terms of Use)
THis is the log output fromm all my Xorg logs (171.53 KB, text/x-log)
2011-12-13 16:50 UTC, Dennis Appelon Nielsen
no flags Details
My Xorg all log files without rpmfusion's drivers (171.67 KB, text/x-log)
2011-12-13 17:14 UTC, Dennis Appelon Nielsen
no flags Details
Last hour where I have shuffled around with pm-suspend (873.29 KB, text/x-log)
2011-12-16 19:59 UTC, Dennis Appelon Nielsen
no flags Details
my dmesg out (110.46 KB, application/octet-stream)
2011-12-16 20:02 UTC, Dennis Appelon Nielsen
no flags Details
My pm-suspend output (6.23 KB, application/octet-stream)
2011-12-16 20:04 UTC, Dennis Appelon Nielsen
no flags Details
martin.grotzke pm-suspend.log (5.32 KB, text/x-log)
2011-12-26 21:21 UTC, Martin Grotzke
no flags Details
martin.grotzke Xorg.*.logs (zipped) (27.21 KB, application/x-zip-compressed)
2011-12-26 21:22 UTC, Martin Grotzke
no flags Details

Description Dennis Appelon Nielsen 2011-12-13 16:05:20 UTC
Description of problem:
After installing  kernel-3.1.5-1 x86_64 I'm no longer able to unsuspended my laptop Lenovo W520 (Using a SSD OCZ Vertex 3). The problem is still in kernel-3.1.5-2 x86_64 also

Version-Release number of selected component (if applicable):
kernel-3.1.5-2.fc16.x86_64
kernel-3.1.5-1.fc16.x86_64

How reproducible:
Install on of the to versions of the kernel above, and you are no longer able to unsuspended your system, and have to hit the power off switch to gain acces to you system. 

Steps to Reproduce:
1.Update kernel to kernel-3.1.5-1.fc16.x86_64 or kernel-3.1.5-2.fc16.x86_64
2.reboot in to it
3.try to suspend and then unsuspended 
  
Actual results:
The system keeps being in suspended mode

Expected results:
The system should come back to life without any problems 

Additional info:

Comment 1 Josh Boyer 2011-12-13 16:22:45 UTC
Can you try some of the steps listed here:

https://fedoraproject.org/wiki/KernelCommonProblems#Suspend.2FResume_failure

Comment 2 Sergio Monteiro Basto 2011-12-13 16:28:51 UTC
(In reply to comment #0)
> Description of problem:
> After installing  kernel-3.1.5-1 x86_64 I'm no longer able to unsuspended my
> laptop Lenovo W520 (Using a SSD OCZ Vertex 3). The problem is still in
> kernel-3.1.5-2 x86_64 also

say to me one kernel that works,  kernel-3.1.4-1 works ? 

 
what is yours graphics chiptset ? 
what is the output of ? 
cat /var/log/Xorg.0.log| grep -i chip

Comment 3 Dennis Appelon Nielsen 2011-12-13 16:38:12 UTC
Hi Sergio Monteiro BAsto

It works fine with kernel-3.1.4-1
My graphic chipset is nVidia Corporation GT216 [Quadro FX 880M]

Here is the entire output from my /var/log/Xorg.0.log | http://fpaste.org/Fnb0/
Here is a output of all my Xorg.* log files,

Comment 4 Dennis Appelon Nielsen 2011-12-13 16:42:57 UTC
(In reply to comment #3)
> Hi Sergio Monteiro BAsto
> 
> It works fine with kernel-3.1.4-1
> My graphic chipset is nVidia Corporation GT216 [Quadro FX 880M]
> 
> Here is the entire output from my /var/log/Xorg.0.log | http://fpaste.org/Fnb0/
> Here is a output of all my Xorg.* log files,

Sorry I forgot the link with all my Xorg.*.log output http://fpaste.org/KOTR/

Comment 5 Rex Dieter 2011-12-13 16:45:56 UTC
Id recommend including logs here as attachments, and not rely on fpaste (whose content eventually expires)

Comment 6 Josh Boyer 2011-12-13 16:49:38 UTC
You're using the proprietary nvidia module.  Your logs show that the xorg nvidia module failed to load at some point (there are no date timestamps so we have no idea when), and then nouveau loads but you've blacklisted the kernel driver.

What happens if you don't use the nvidia module and don't blacklist nouveau?  If you can provide the dmesg and xorg logs from a boot setup like that, please attach.

Comment 7 Dennis Appelon Nielsen 2011-12-13 16:50:10 UTC
Created attachment 546287 [details]
THis is the log output fromm all my Xorg logs

Comment 8 Dennis Appelon Nielsen 2011-12-13 16:51:47 UTC
(In reply to comment #7)
> Created attachment 546287 [details]
> THis is the log output fromm all my Xorg logs

Sorry... I have now attached it...

Just a short follow up... the unsuspended freeze the system, I am not able to make my caps lock flash when I try to unsuspended..

Comment 9 Dennis Appelon Nielsen 2011-12-13 16:58:44 UTC
(In reply to comment #6)
> You're using the proprietary nvidia module.  Your logs show that the xorg
> nvidia module failed to load at some point (there are no date timestamps so we
> have no idea when), and then nouveau loads but you've blacklisted the kernel
> driver.
> 
> What happens if you don't use the nvidia module and don't blacklist nouveau? 
> If you can provide the dmesg and xorg logs from a boot setup like that, please
> attach.

Yes I use the proprietary nVidia drivers from rpmfusion.

I'll try to remove them when I get home from work, and then update this bug rapport...

Comment 10 Sergio Monteiro Basto 2011-12-13 17:09:32 UTC
(In reply to comment #9)

> Yes I use the proprietary nVidia drivers from rpmfusion.

if you are using rpmfusion for nvidia drives , you should install akmods to
rebuild nvidia-kmods, but this don't have nothing to do with this kernel
update, in my perspective .

Comment 11 Dennis Appelon Nielsen 2011-12-13 17:14:23 UTC
Created attachment 546292 [details]
My Xorg all log files without rpmfusion's drivers

Comment 12 Dennis Appelon Nielsen 2011-12-13 17:15:02 UTC
(In reply to comment #11)
> Created attachment 546292 [details]
> My Xorg all log files without rpmfusion's drivers

The problem persist without the nVidia drivers

Comment 13 Dennis Appelon Nielsen 2011-12-13 19:17:02 UTC
I have to point out, that this error also could have something to do with changes to btrfs in kernel-3.1.5.1, sense I'm running btrfs on all my partitions, this also could cause the problem with unsuspended

Comment 14 Dennis Appelon Nielsen 2011-12-16 08:21:16 UTC
Any updates regarding my unsuspended issue ?
I still have this problem every time I boot any of these 2 new kernel's:

kernel-3.1.5-2.fc16.x86_64
kernel-3.1.5-1.fc16.x86_64

But I don't have the problem in kernel-3.1.4-1.fc16.x86_64

Do I have to expect this issue for any further kernel releases or what ?

Comment 15 Josh Boyer 2011-12-16 14:06:49 UTC
(In reply to comment #14)
> Any updates regarding my unsuspended issue ?
> I still have this problem every time I boot any of these 2 new kernel's:
> 
> kernel-3.1.5-2.fc16.x86_64
> kernel-3.1.5-1.fc16.x86_64
> 
> But I don't have the problem in kernel-3.1.4-1.fc16.x86_64
> 
> Do I have to expect this issue for any further kernel releases or what ?

Did you try any of the steps on the wiki page in comment #1?

With the information this bug has so far, it's fairly hard to narrow down what might be causing the problem.  If you can isolate it to a particular driver/device, progress might be made.

Comment 16 Sergio Monteiro Basto 2011-12-16 15:44:43 UTC
(In reply to comment #13)
> I have to point out, that this error also could have something to do with
> changes to btrfs in kernel-3.1.5.1, sense I'm running btrfs on all my
> partitions, this also could cause the problem with unsuspended

could be interesting, bisect the patch /pub/linux/kernel/v3.0/incr/patch-3.1.4-5.bz2, and find out what commit break it yours suspend ,
because is a regression. and upstream the bug .

Comment 17 Dennis Appelon Nielsen 2011-12-16 19:59:06 UTC
Created attachment 547941 [details]
Last hour where I have shuffled around with pm-suspend

Attached is my message log file, for the last hour where I have tried to figure what driver is causing this problem....

Please take a look and see if there is anything to notes

Comment 18 Dennis Appelon Nielsen 2011-12-16 20:02:20 UTC
Created attachment 547942 [details]
my dmesg out

Attached is my dmesg output. please take a look an see if anything can put light on my unsuspended problem...

Comment 19 Dennis Appelon Nielsen 2011-12-16 20:04:15 UTC
Created attachment 547943 [details]
My pm-suspend output

This is my pm-suspend.log file please take a look and see if it helps in any way

Comment 20 Dennis Appelon Nielsen 2011-12-16 20:09:34 UTC
I just tried to init 3 and then suspend from there with pm-suspend and I see the same error. I kind of hear mu fan spin and my second ordinary disk spin, but then the laptop just keeps blinking like it was suspended.

Comment 21 Dennis Appelon Nielsen 2011-12-16 20:15:46 UTC
(In reply to comment #16)
> (In reply to comment #13)
> > I have to point out, that this error also could have something to do with
> > changes to btrfs in kernel-3.1.5.1, sense I'm running btrfs on all my
> > partitions, this also could cause the problem with unsuspended
> 
> could be interesting, bisect the patch
> /pub/linux/kernel/v3.0/incr/patch-3.1.4-5.bz2, and find out what commit break
> it yours suspend ,
> because is a regression. and upstream the bug .

Yes, but how do I do this in piratical?

Comment 22 Dennis Appelon Nielsen 2011-12-16 20:34:56 UTC
Well I have this other Fedora 16 system beside my main system, and I just tried to update it to kernel-3.1.5-2.fc16.x86_64 This system also runs btrfs in all partitions beside /boot and it don't have the problem with unsuspended. So I guess we can leave out my suggestion that it is the btrfs changes.

Besides from being a much newer laptop then this spare Lenovo T61P there is not that much differenced between them, beside from the OCZ Vertex 3 SSD I have in my main laptop along side with a bay mounted WD 350 7200RPM disk.

If it is the SSD causing this problems from the 3 latest kernel's

 kernel-3.1.5.1
 kernel-3.1.5.2

now running  kernel-3.1.5.6

and not in the old kernel-3.1.4-1 where shall I look for an error log entry?

Comment 23 Dennis Appelon Nielsen 2011-12-16 21:02:19 UTC
Just some info about my SSD

[nielsenda@laptop linux64]$ sudo ./fwupd -log /dev/sda
fwupd v2.12.05: update drive firmware

/dev/sda:

	Model Number     :   OCZ-VERTEX3                             
	Serial Number    :   OCZ-6SZUK312CSK69SMB
	Firmware Revision:   2.15    

Accessing firmware file...
Firmware does not need to be updated

It is running the latest firmware

Comment 24 Dennis Appelon Nielsen 2011-12-16 21:33:01 UTC
I just found this fellow here having the same issue as me 

 https://bugzilla.redhat.com/show_bug.cgi?id=767416

Comment 25 Dennis Appelon Nielsen 2011-12-17 21:52:06 UTC
Any useful stuff in the log files I attached yesterday?

Comment 26 Roman Spirgi 2011-12-20 19:29:00 UTC
I've the same issue with proprietary NVIDIA driver (xorg-x11-drv-nvidia-1:290.10-1.fc16) + kmod.
Graphics Processor: GeForce GTS 240
---
# dmesg | grep "hash matches"
[    1.446920]   hash matches drivers/base/power/main.c:509
[    1.446931] block loop5: hash matches
[    1.446947] pci 0000:01:00.0: hash matches

/sys/bus/pci/drivers/nvidia/0000:01:00.0

Comment 27 Dennis Appelon Nielsen 2011-12-20 20:39:30 UTC
(In reply to comment #26)
> I've the same issue with proprietary NVIDIA driver
> (xorg-x11-drv-nvidia-1:290.10-1.fc16) + kmod.
> Graphics Processor: GeForce GTS 240
> ---
> # dmesg | grep "hash matches"
> [    1.446920]   hash matches drivers/base/power/main.c:509
> [    1.446931] block loop5: hash matches
> [    1.446947] pci 0000:01:00.0: hash matches
> 
> /sys/bus/pci/drivers/nvidia/0000:01:00.0

Hi Roman Spirgi
Thanks for the input, but I even tried to remove any kmod-nvidia drivers and the problem persisted

Comment 28 John Gotts 2011-12-26 00:31:21 UTC
Does booting with pci=nocrs fix the problem?

Comment 29 Dennis Appelon Nielsen 2011-12-26 21:16:27 UTC
The Problem persist in latest kernel release 3.1.6-1.fc16.x86_64

Comment 30 Martin Grotzke 2011-12-26 21:19:50 UTC
I have the same issue with W510 and now kernel 3.1.6-1.fc16.x86_64 (resume not possible, blinking power button, no capslock light), but `dmesg | grep "hash matches"` is empty in my case after a reboot (after `echo 1 > /sys/power/pm_trace` before the suspend).

I just tried booting with pci=nocrs, this changed nothing for me, still the same issue.

I'll also attach my pm-suspend.log and Xorg.*.logs.

Comment 31 Martin Grotzke 2011-12-26 21:21:44 UTC
Created attachment 549623 [details]
martin.grotzke pm-suspend.log

Comment 32 Martin Grotzke 2011-12-26 21:22:56 UTC
Created attachment 549624 [details]
martin.grotzke Xorg.*.logs (zipped)

Comment 33 Dennis Appelon Nielsen 2011-12-28 21:09:04 UTC
Try booting your kernel with hpet=disable it took care of the problem for me.

But I don't know what hpet is I'll have to Google for a answer.

Comment 34 devsk 2011-12-30 02:49:55 UTC
I hope people are following http://lkml.org/lkml/2011/12/29/45

Disabling hpet should make it work. I think by default on most modern CPUs, TSC is used anyway. So, explicitly disabling HPET and forcing it to use TSC from the get go is not a bad workaround!

Comment 35 Martin Grotzke 2012-01-01 19:24:26 UTC
hpet=disable works for me, great!

Comment 36 Josh Boyer 2012-01-03 12:48:45 UTC
There is an upstream commit that was added to 3.1.5 that seems to have caused a
regression here.  I'll try to provide a scratch kernel with that commit
reverted later today for testing.

Comment 37 Josh Boyer 2012-01-03 19:14:28 UTC
3.1.7 has been released and it contains the revert i previously mentioned.  I'll get a kernel built for testing shortly.

Comment 38 Fedora Update System 2012-01-03 22:53:11 UTC
kernel-3.1.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.7-1.fc16

Comment 39 Dennis Appelon Nielsen 2012-01-04 20:50:36 UTC
The latest kernel-3.1.7-1.fc16 have solved my unsuspended problem.

Thanks Josh Boyer and anyone else there have helped me find the root of the sudden unsuspended problem :-)

I'll be sure to send it a tons of positive karma +1

Comment 40 Fedora Update System 2012-01-05 21:05:48 UTC
Package kernel-3.1.7-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.1.7-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0145/kernel-3.1.7-1.fc16
then log in and leave karma (feedback).

Comment 41 Dennis Appelon Nielsen 2012-01-06 11:55:54 UTC
(In reply to comment #40)
> Package kernel-3.1.7-1.fc16:
> * should fix your issue,
> * was pushed to the Fedora 16 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing kernel-3.1.7-1.fc16'
> as soon as you are able to, then reboot.
> Please go to the following url:
> https://admin.fedoraproject.org/updates/FEDORA-2012-0145/kernel-3.1.7-1.fc16
> then log in and leave karma (feedback).

Well already done that... thanks again, I snatched it before it hit test repo's and Added my Proven tester karma +1

Thanks again...

Comment 42 Fedora Update System 2012-01-07 23:04:59 UTC
kernel-3.1.7-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 43 Jamie 2012-02-08 22:13:00 UTC
Running kernel-3.2.3-2.fc16 and I am still getting black screen after suspend.

[root@localhost ~]# dmesg | grep "hash matches"
[    1.904344]   hash matches drivers/base/power/main.c:576


Note You need to log in before you can comment on or make changes to this bug.