Bug 767314 - f15 f16 rtkit-daemon date logged in /var/log/messages is in the future
f15 f16 rtkit-daemon date logged in /var/log/messages is in the future
Status: CLOSED DUPLICATE of bug 698040
Product: Fedora
Classification: Fedora
Component: rtkit (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-13 14:06 EST by Reartes Guillermo
Modified: 2012-05-15 09:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 09:12:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2011-12-13 14:06:07 EST
Description of problem:

I noticed reading the logs of my f16 laptop after a crash (unrelated) that 
rtkit-daemon date in messages is always in the future. I confirmed that f15
hast it too.

Sample output from a f15 desktop:

Dec 13 17:26:13 ulquiorra rtkit-daemon[2418]: Successfully made thread 3321 of process 3321 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
Dec 13 14:26:13 ulquiorra pulseaudio[3321]: pid.c: Stale PID file, overwriting.
Dec 13 17:26:13 ulquiorra rtkit-daemon[2418]: Successfully made thread 3322 of process 3321 (/usr/bin/pulseaudio) owned by '500' RT at priority 5.
Dec 13 17:26:14 ulquiorra rtkit-daemon[2418]: Successfully made thread 3335 of process 3321 (/usr/bin/pulseaudio) owned by '500' RT at priority 5.
Dec 13 17:26:14 ulquiorra rtkit-daemon[2418]: Successfully made thread 3338 of process 3321 (/usr/bin/pulseaudio) owned by '500' RT at priority 5.
Dec 13 17:26:14 ulquiorra rtkit-daemon[2418]: Successfully made thread 3339 of process 3339 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
Dec 13 14:26:14 ulquiorra pulseaudio[3339]: pid.c: Daemon already running.
Dec 13 17:26:14 ulquiorra rtkit-daemon[2418]: Successfully made thread 3346 of process 3346 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
Dec 13 14:26:14 ulquiorra pulseaudio[3346]: pid.c: Daemon already running.
Dec 13 17:26:14 ulquiorra rtkit-daemon[2418]: Successfully made thread 3351 of process 3351 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
Dec 13 14:26:14 ulquiorra pulseaudio[3351]: pid.c: Daemon already running.


Version-Release number of selected component (if applicable):

Fedora 15
Fedora 16

How reproducible:
allways, just use the distro and check the logs
  
Actual results:
rtkit-daemon output to messages uses a different time that the rest of the
programs. Its entries in messages have different time.

Expected results:
rtkit-daemon must use the true time of the log entry and not one in the future.

Additional info:


an older chuck (also f15):

Nov 25 23:51:45 ulquiorra rtkit-daemon[2404]: Successfully made thread 3215 of process 3215 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
Nov 25 23:51:45 ulquiorra rtkit-daemon[2404]: Successfully made thread 3216 of process 3215 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
Nov 25 23:51:46 ulquiorra rtkit-daemon[2404]: Successfully made thread 3238 of process 3215 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
Nov 25 23:51:46 ulquiorra rtkit-daemon[2404]: Successfully made thread 3240 of process 3215 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
Nov 25 23:51:46 ulquiorra rtkit-daemon[2404]: Successfully made thread 3242 of process 3215 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
Nov 25 23:51:46 ulquiorra rtkit-daemon[2404]: Successfully made thread 3243 of process 3215 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
Nov 25 23:51:46 ulquiorra rtkit-daemon[2404]: Successfully made thread 3244 of process 3244 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
Nov 25 20:51:46 ulquiorra pulseaudio[3244]: pid.c: Daemon already running.
Nov 25 23:51:46 ulquiorra rtkit-daemon[2404]: Successfully made thread 3245 of process 3245 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
Nov 25 20:51:46 ulquiorra pulseaudio[3245]: pid.c: Daemon already running.
Nov 25 23:51:46 ulquiorra rtkit-daemon[2404]: Successfully made thread 3247 of process 3247 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
Nov 25 20:51:46 ulquiorra pulseaudio[3247]: pid.c: Daemon already running.
Comment 1 Lennart Poettering 2012-05-15 09:12:46 EDT

*** This bug has been marked as a duplicate of bug 698040 ***

Note You need to log in before you can comment on or make changes to this bug.