Bug 76772 - hardware cursor AND software cursor on same X display
Summary: hardware cursor AND software cursor on same X display
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 77213 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-26 06:42 UTC by Justin Georgeson
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-05 20:00:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (50.38 KB, text/plain)
2002-10-26 06:43 UTC, Justin Georgeson
no flags Details
X Config file (1.95 KB, text/plain)
2002-10-26 06:44 UTC, Justin Georgeson
no flags Details
lspci -vn output (2.48 KB, text/plain)
2002-10-26 06:45 UTC, Justin Georgeson
no flags Details
XF86Config for 20021101 packages (1.81 KB, text/plain)
2002-11-03 19:50 UTC, Justin Georgeson
no flags Details

Description Justin Georgeson 2002-10-26 06:42:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
The black 'X' which is the mouse pointer before a window manager loads is drawn
in the middle of the screen when the window manager loads. I'm using the CVS
RPMs, version 4.2.99.1-0.20021018.5. When metacity loads, I am given the red
transparent mouse pointer, and the black 'X' is drawn, always on top, in the
center of the screen. I had thought it was permanent, but it has disappeared once.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. login
2. start x

	

Actual Results:  black X is drawn on top of all windows in center of screen when
metacity is loaded.

Expected Results:  black X should become red mouse pointer when metacity loads.

Additional info:

Comment 1 Justin Georgeson 2002-10-26 06:43:11 UTC
Created attachment 82184 [details]
X log

Comment 2 Justin Georgeson 2002-10-26 06:44:06 UTC
Created attachment 82185 [details]
X Config file

Comment 3 Justin Georgeson 2002-10-26 06:45:17 UTC
Created attachment 82186 [details]
lspci -vn output

Comment 4 Mike A. Harris 2002-11-03 10:17:20 UTC
Please try the latest CVS RPM packages from November 1st.  Does the latest
package resolve this problem?

Comment 5 Mike A. Harris 2002-11-03 12:26:27 UTC
*** Bug 77213 has been marked as a duplicate of this bug. ***

Comment 6 Mike A. Harris 2002-11-03 12:27:39 UTC
*** Bug 77213 has been marked as a duplicate of this bug. ***

Comment 7 Mike A. Harris 2002-11-03 12:29:15 UTC
Please test the latest release of my CVS RPM's guys from:

ftp://people.redhat.com/mharris/testing/live-grenades - the 20021101 release

Does the problem persist, or does it go away with this build?

Comment 8 Justin Georgeson 2002-11-03 19:50:05 UTC
Created attachment 83364 [details]
XF86Config for 20021101 packages

Comment 9 Justin Georgeson 2002-11-03 19:50:48 UTC
Problem still exists. Does not occur when logged in as root.

Comment 10 Mike A. Harris 2002-11-04 08:36:56 UTC
Hmm, that is uberweird.

Notifying XFree86 people of this issue, as I have no Intel i8x0 hardware
for troubleshooting.  I'll update the report with any changes, and
periodically ask you to try new packages probably.

thanks again

Comment 11 Mike A. Harris 2002-11-04 08:53:43 UTC
Ok, David Dawes has acknowledged this bug in the i810 driver and that
it affects i830 and i845 hardware not disabling the hardware cursor
in some circumstances.  He plans on fixing it sometime in the next
week or so.  I'll monitor CVS commits for when the changes go in,
and update the bug report when i've got new packages for testing.

Thanks guys, your beta testing is appreciated.

Comment 12 David Monniaux 2002-11-04 13:55:16 UTC
Still present in version from 2002-11-01.

Comment 13 Mike A. Harris 2002-11-05 11:52:42 UTC
David has fixed this in CVS, and I'm building a new CVS snapshot right now,
which will appear in the usual place with datestamp 20021105 within 24 hours.

Please test this and confirm it fixes the problem.  I'm setting bug state
to MODIFIED.  After testing, please set bug state to either RAWHIDE if the
problem is resolved, or to ASSIGNED, if the problem is still present, and
include any new information.

If you encounter any new problems/bugs, please open new bug reports.

Thanks guys.

Comment 14 David Monniaux 2002-11-05 18:37:58 UTC
2002-11-05 fixed it for me.

Comment 15 Justin Georgeson 2002-11-05 20:00:22 UTC
20021105 works for me too. :D

Comment 16 Mike A. Harris 2002-11-06 10:10:15 UTC
Update:  There is still a bug in the i8x0 cursor code, and David just
fixed it.  I'll be rolling new rpm's either today or tomorrow with this
fix in it, so if you do encounter a problem, wait for the next snapshot
to test before reporting it.

Thanks guys.


Note You need to log in before you can comment on or make changes to this bug.