Bug 76781 - Installer crashes after customized selection
Installer crashes after customized selection
Status: CLOSED DUPLICATE of bug 75008
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-10-26 08:46 EDT by Petri T. Koistinen
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-11-02 17:59:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of dmesg command on my system (textmode install) (7.33 KB, text/plain)
2002-10-26 08:52 EDT, Petri T. Koistinen
no flags Details

  None (edit)
Description Petri T. Koistinen 2002-10-26 08:46:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
I started Red Hat 8.0 installation from CD-ROM, booted the disk, pressed just
enter on first prompt. Waited, did not do the media check, because I had done it
before at place where I burned the CDs.

I did the normal selections, finnish language, whell mouse (PS/2). I selected
the Personal desktop. I customized disk partions, added all default partions
that are available (/ /boot swap /usr /usr/local /opt /var /home /tmp). Then I
was asked if I would like to "Customize software selection?", I answered yes. I
used a while to make selections of various programs. I did not select
"Everything" and neither I wanted to select individual packages.

When finnish with selection, I moved forward with installation. Installer
crashed then.

Actual Results:  After finnishing "Customized software selection" I moved
forward, and graphical installation program (anaconda) disappeared. I saw
following message repeated few time at the top of textmode screen:

(anaconda:81): CnomeCanvas-CRITICAL **: file gnome-path-def.c: line 1142
(gnome_canvas_path_any_closed): assertion 'path != NULL' failed
install exited abnormally...
[... some text that umount devices...]
you may safely reboot yout system


Expected Results:  Working installation. It would be nice if installer would say
"Sorry for crashing." I used some time to configure Red Hat installation. I
know, I did not pay for Red Hat, I do not deserve that.

Additional info:

Textmode installation was success, but with textmode disk druid there is no LVM
and no menus where I can select default partitions (those /usr /opt /tmp etc.)
Comment 1 Petri T. Koistinen 2002-10-26 08:52:32 EDT
Created attachment 82207 [details]
output of dmesg command on my system (textmode install)
Comment 2 Michael Fulbright 2002-10-30 17:38:50 EST

*** This bug has been marked as a duplicate of 75008 ***
Comment 3 Petri T. Koistinen 2002-10-31 09:33:29 EST
My media is OK, your software is buggy.
Comment 4 Petri T. Koistinen 2002-10-31 09:36:17 EST
I have seen this error message on more than one machine with diffrent CD's. Fix
GNOME canvas.
Comment 5 Michael Fulbright 2002-10-31 15:24:22 EST
These errors in the log you attached are due to read errors from the CD:

hda: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
hda: drive_cmd: error=0x04 { DriveStatusError }
hda: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
hda: drive_cmd: error=0x04 { DriveStatusError }

If you purchased this product you can talk to customer care about a refund for
the bad media.

*** This bug has been marked as a duplicate of 75008 ***
Comment 6 Petri T. Koistinen 2002-10-31 17:06:30 EST
Dmesg.txt is after installation. 

hda: MAXTOR 6L080J4, ATA DISK drive

And those errors are from smartd.

How do you explain this:
(gnome_canvas_path_any_closed): assertion 'path != NULL' failed
Comment 7 Michael Fulbright 2002-11-01 11:34:01 EST
It is a warning from the gtk+ python bindings that occurs when you go to the
timezone screen with the world map on it.  The gtk+ people were consulted and
told us it was not a problem, just a warning.

I would recommend if you have not already to mediacheck the CDs on the exact
system you're installing from.  

Also I would recommend trying a smaller install set than everything.
Comment 8 Petri T. Koistinen 2002-11-02 17:59:02 EST
Well, I did not select "Everything" in first install. I did the installation
again, now with fewer partitions. It went OK, I did mediacheck: all CDs are OK.
When installation was ready, I saw these messages repeated on text-mode screen:


What are these?

How about the defaults partitions and LVM missing from text-mode Disk Druid?

How about saying sorry if installer crashes? People use lot of time to install
Red Hat. Your paying customers might get annoyed if they experience problems
with installation. Say sorry if installer crashes, it does not cost you
anything, but makes people less angry. You can do this only if you are willing
to admit that your software is not perfect. You can't prevent all installer
crashes, but you should detect them all.
Comment 9 Michael Fulbright 2002-11-06 12:03:43 EST
Text mode installations do not support LVM.

CD drives and media are not 100% robust, and it is quite common from reading
these thousands of bug reports (over 75% are due to bad media) to see cases
where repeated attempts to read marginal media will work.  Because the
mediacheck sequentially reads the CD it does not exactly simulate what happens
during an install where filed are being accessed from different parts of the CD
over time.

We certainly care about our customers and users who download Red Hat for free. 
Our bug tracking system is open to anyone w/o a fee to use it, and you don't
even have to buy our product to report a bug.

However this bugtracking system is not a support mechanism, it is solely for
tracking defects in the software.  Issues like you have reported are due to
media issues and our Customer Support will work with you to get replacement media.

I would recommend openning a bug report against the XFree86 package with details
about the XSetInputFocus() errors you are now seeing.

*** This bug has been marked as a duplicate of 75008 ***

Note You need to log in before you can comment on or make changes to this bug.