Bug 767820 - [abrt] kernel: WARNING: at drivers/pci/search.c:44 pci_find_upstream_pcie_bridge+0x66/0x80()
Summary: [abrt] kernel: WARNING: at drivers/pci/search.c:44 pci_find_upstream_pcie_bri...
Keywords:
Status: CLOSED DUPLICATE of bug 755943
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f43e6eaeae2cec0855b4d5dd57d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-14 22:59 UTC by Panos Polychronis
Modified: 2011-12-15 14:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-15 14:31:47 UTC


Attachments (Terms of Use)

Description Panos Polychronis 2011-12-14 22:59:23 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.5-2.fc16.x86_64 root=UUID=475560dd-bf53-4c6c-8c65-0c09989fe6f3 ro nomodeset rd.md=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8 nouveau.modeset=0 rd.driver.blacklist=nouveau
event_log:      2011-12-15-00:58:56> Smolt profile successfully saved
kernel:         3.1.5-2.fc16.x86_64
reason:         WARNING: at drivers/pci/search.c:44 pci_find_upstream_pcie_bridge+0x66/0x80()
time:           Wed 14 Dec 2011 07:15:32 PM EET

backtrace:
:WARNING: at drivers/pci/search.c:44 pci_find_upstream_pcie_bridge+0x66/0x80()
:Hardware name: System Product Name
:Modules linked in: pata_jmicron(+)
:Pid: 286, comm: modprobe Not tainted 3.1.5-2.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8106b6ef>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106b74a>] warn_slowpath_null+0x1a/0x20
: [<ffffffff812cf5a6>] pci_find_upstream_pcie_bridge+0x66/0x80
: [<ffffffff815cd050>] get_domain_for_dev.part.9.constprop.13+0x2b/0x4dd
: [<ffffffff8106bfa5>] ? console_unlock+0x1f5/0x270
: [<ffffffff815cd5df>] __get_valid_domain_for_dev+0x2c/0xa0
: [<ffffffff814a2a3a>] __intel_map_single+0x1aa/0x1c0
: [<ffffffff81152b03>] ? alloc_pages_current+0xa3/0x110
: [<ffffffff814a2b3e>] intel_alloc_coherent+0xae/0x120
: [<ffffffff8138ac51>] ? __devres_alloc+0x51/0x90
: [<ffffffff81392b4e>] dmam_alloc_coherent+0xce/0x160
: [<ffffffff813cffb8>] ata_bmdma_port_start+0x48/0x60
: [<ffffffff813bdefd>] ata_host_start+0x10d/0x1d0
: [<ffffffff813d3420>] ? ata_bmdma_qc_issue+0x1a0/0x1a0
: [<ffffffff813d0651>] ata_pci_sff_activate_host+0x41/0x240
: [<ffffffff814a3cea>] ? pcibios_set_master+0x7a/0xa0
: [<ffffffff813d0c20>] ata_pci_bmdma_init_one+0x120/0x150
: [<ffffffffa0000032>] jmicron_init_one+0x32/0x40 [pata_jmicron]
: [<ffffffff812cd5dc>] local_pci_probe+0x5c/0xd0
: [<ffffffff812cee79>] pci_device_probe+0x109/0x130
: [<ffffffff81387bec>] driver_probe_device+0x9c/0x2b0
: [<ffffffff81387eab>] __driver_attach+0xab/0xb0
: [<ffffffff81387e00>] ? driver_probe_device+0x2b0/0x2b0
: [<ffffffff81387e00>] ? driver_probe_device+0x2b0/0x2b0
: [<ffffffff81386a6c>] bus_for_each_dev+0x5c/0x90
: [<ffffffff813877fe>] driver_attach+0x1e/0x20
: [<ffffffff81387400>] bus_add_driver+0x1b0/0x2a0
: [<ffffffffa0002000>] ? 0xffffffffa0001fff
: [<ffffffff81388406>] driver_register+0x76/0x140
: [<ffffffff815d4a1d>] ? notifier_call_chain+0x4d/0x70
: [<ffffffffa0002000>] ? 0xffffffffa0001fff
: [<ffffffff812ceb56>] __pci_register_driver+0x56/0xd0
: [<ffffffff81093cc3>] ? __blocking_notifier_call_chain+0x63/0x80
: [<ffffffffa000201e>] jmicron_init+0x1e/0x20 [pata_jmicron]
: [<ffffffff81002042>] do_one_initcall+0x42/0x180
: [<ffffffff810aad21>] sys_init_module+0x91/0x200
: [<ffffffff815d8bc2>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 68fc9146-1432-43e3-9e97-ca16793f5c51
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6420.88
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU         650  @ 3.20GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 3201
:System Memory: 12080
:System Swap: 6144
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.1.5-2.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:64:4163:33667) pci, None, HOST/PCI, Core Processor DRAM Controller
:(32902:15152:4163:33667) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15136:4163:33667) pci, ata_piix, STORAGE, 5 Series/3400 Series Chipset 4 port SATA IDE Controller
:(32902:15106:4163:33667) pci, None, PCI/ISA, 5 Series Chipset LPC Interface Controller
:(32902:15142:4163:33667) pci, ata_piix, STORAGE, 5 Series/3400 Series Chipset 2 port SATA IDE Controller
:(6523:9059:4163:33359) pci, ahci, STORAGE, JMB362/JMB363 Serial ATA Controller
:(6523:9059:4163:33359) pci, pata_jmicron, STORAGE, JMB362/JMB363 Serial ATA Controller
:(32902:15164:4163:33667) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:9294:4163:33667) pci, None, PCI/PCI, 82801 PCI Bridge
:(4358:12356:4163:33278) pci, firewire_ohci, FIREWIRE, M4A series motherboard
:(32902:15170:4163:33667) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15182:4163:33667) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 7
:(32902:15184:4163:33667) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 8
:(32902:15178:4163:33667) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15180:4163:33667) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 6
:(32902:15156:4163:33667) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(4332:33128:4163:33699) pci, r8169, ETHERNET, M4A785TD Motherboard
:(32902:15190:4163:33653) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:11361:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(4318:3044:5218:8307) pci, snd_hda_intel, MULTIMEDIA, High Definition Audio Controller
:(4318:3235:5218:8307) pci, nvidia, VIDEO, GT215 [GeForce GT 240]
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 13780839 8932349 8792393 3506176 3209768 3209768
:/dev/sda1 /boot ext3 1024 1024 495844 410259 384659 128016 127740 127740
:/dev/sdb1 /home ext4 4096 4096 348328510 273396637 255702570 88473600 88075897 88075897
:

Comment 1 Josh Boyer 2011-12-15 14:31:47 UTC

*** This bug has been marked as a duplicate of bug 755943 ***


Note You need to log in before you can comment on or make changes to this bug.