This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 768481 - Kernel panic - not syncing: VFS: Unable to mount root fs
Kernel panic - not syncing: VFS: Unable to mount root fs
Status: CLOSED DUPLICATE of bug 768645
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 14:00 EST by Tom
Modified: 2011-12-19 16:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-18 10:35:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom 2011-12-16 14:00:04 EST
Description of problem:
Kernel panic at boot.

Version-Release number of selected component (if applicable):
3.2.0-0.rc5.git3.1.fc17.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)
Pid:1, comm: swapper/0 Not tainted 3.2.0-0.rc5.git3.1.fc17.x86_64 #1
Call Trace:
[<ffffffff8166fcf6>] panic+0xa0/0x1bb
[<ffffffff81f6402c>] mount_block_root+0x1d1/0x283
[<ffffffff81002930>] ? name_to_dev_t+0x770/0xe40
[<ffffffff81f64131>] mount_root+0x53/0x57
[<ffffffff81f64272>] prepare_namespace+0x13d/0x176
[<ffffffff81f63d97>] kernel_init+0x159/0x15e
[<ffffffff81688604>] kernel_thread_helper+0x4/0x10
[<ffffffff8167df34>] ? retint_restore_args+0x13/0x13
[<ffffffff81f63c3e>] ? start_kernel+0x3f9/0x3f9
[<ffffffff81688600>] ? gs_change+0x13/0x13

Expected results:


Additional info:
Comment 1 Josh Boyer 2011-12-16 14:25:01 EST
This is very likely caused by the kernel not having an initramfs passed to it.  Is there a corresponding initramfs in /boot for this kernel, and is it included in whichever grub configuration file your machine is using?

Do you have anything in /var/log/messages about depmod, new-kernel-pkg, or dracut segfaulting or any out-of-memory errors?
Comment 2 Tom 2011-12-16 20:44:45 EST
I don't have initramfs for git3 kernel.
Comment 3 Dave Allan 2011-12-17 18:42:45 EST
This panic is 100% reproducible for me on KVM VMs, exact same backtrace; I've installed one VM directly from the rawhide repo with the F16 installer and upgraded two other VMs.  All 3 panic'd on reboot.  I am happy to provide access to a VM exhibiting the problem, or anything else I can do to help troubleshoot it, as it's blocking me from verifying a libvirt bug.
Comment 4 Tom 2011-12-17 22:38:14 EST
I took the dracut suggestion, and downgraded to previous dracut-013-100.git20111021.fc17, then reinstalled kernel. I now have initramfs and boots.
Comment 5 Josh Boyer 2011-12-18 10:35:28 EST
Pretty sure this is this issue:

http://lists.fedoraproject.org/pipermail/devel/2011-December/160571.html

*** This bug has been marked as a duplicate of bug 768645 ***
Comment 6 Dave Allan 2011-12-19 16:23:06 EST
Yep, that was it, thanks.  The steps in:

https://bugzilla.redhat.com/show_bug.cgi?id=768645#c1

got my systems booting again.

Note You need to log in before you can comment on or make changes to this bug.