Bug 768645 - dracut has moved to /usr/bin/dracut with dracut-014
dracut has moved to /usr/bin/dracut with dracut-014
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Reopened
: 768481 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-17 10:44 EST by Bruno Wolff III
Modified: 2012-01-03 20:55 EST (History)
7 users (show)

See Also:
Fixed In Version: grubby-8.8-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-19 19:16:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/boot/grub2/grub.cfg after reinstalling the newest kernel (3.94 KB, text/plain)
2011-12-19 19:20 EST, Andre Robatino
no flags Details

  None (edit)
Description Bruno Wolff III 2011-12-17 10:44:39 EST
Description of problem:
initramfs images are not being built for kernel installs/updates because new-kernel-pkg runs /sbin/dracut which no longer exists.

Version-Release number of selected component (if applicable):
grubby-8.4-1.fc17.i686
dracut-014-9.git20111215.fc17.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andre Robatino 2011-12-17 14:36:26 EST
Until the new grubby is available, the following works for me to generate and use the new initramfs file in /boot. (I had to read some to figure out how, adjust the dracut line for desired kernel version.)

# cd /boot
# dracut initramfs-3.2.0-0.rc5.git3.1.fc17.x86_64.img 3.2.0-0.rc5.git3.1.fc17.x86_64
# grub2-mkconfig -o /boot/grub2/grub.cfg
Comment 2 Bruno Wolff III 2011-12-17 14:49:12 EST
The build failed.

8.5 added a new test as well as the change to not use a hard coded path for dracut.
The new test is failing which is preventing the build.
I ran test.sh with the following removed and to confirm the new test was the one that is failing:
grub2Test grub2.1 remove/g2-1.4 --remove-kernel=/boot/vmlinuz-2.6.38.2-9.fc15.x86_64 \
    --boot-filesystem=/boot/
Comment 3 Bruno Wolff III 2011-12-17 15:34:42 EST
It looks like the test output has "Linux" in two places it should have "Fedora". I don't know if that output change is rawhide specific though.
Comment 4 Andre Robatino 2011-12-17 18:43:31 EST
Reopening until there is an actual completed grubby build ( http://koji.fedoraproject.org/koji/buildinfo?buildID=279194 wasn't it).
Comment 5 Josh Boyer 2011-12-18 10:35:28 EST
*** Bug 768481 has been marked as a duplicate of this bug. ***
Comment 6 Andre Robatino 2011-12-19 18:44:30 EST
I see a successful grubby-8.6-1.fc17 build http://koji.fedoraproject.org/koji/buildinfo?buildID=279336 - should this be closed now?
Comment 7 Bruno Wolff III 2011-12-19 19:16:36 EST
I tested the updated grubby and it built an initramfs image, so I am going to close this.
As a side note, I noticed that the update for grubby doesn't seemed to have been pushed to the upstream grubby repo which is still at 8.5 instead of 8.6.
Comment 8 Andre Robatino 2011-12-19 19:20:20 EST
Created attachment 548713 [details]
/boot/grub2/grub.cfg after reinstalling the newest kernel

I tested it by updating grubby, rebooting into an older kernel and reinstalling kernel-3.2.0-0.rc6.git0.1.fc17.x86_64. It works, but there are now 2 grub2 entries for the newest kernel.
Comment 9 Andre Robatino 2011-12-19 19:57:16 EST
I was able to reproduce the same issue on F16 so it's not new. Filed bug 769119.
Comment 10 Fedora Update System 2011-12-21 09:00:54 EST
grubby-8.8-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/grubby-8.8-2.fc16
Comment 11 Fedora Update System 2012-01-03 20:55:41 EST
grubby-8.8-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.