Bug 768561 - TurboGears2-2.1.1-1.fc16.noarch requires repoze.who==1.0.19
TurboGears2-2.1.1-1.fc16.noarch requires repoze.who==1.0.19
Status: CLOSED DUPLICATE of bug 759142
Product: Fedora
Classification: Fedora
Component: TurboGears2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 21:27 EST by Itamar Reis Peixoto
Modified: 2016-09-19 22:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 17:31:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC file patch (283 bytes, patch)
2012-06-06 05:58 EDT, Brendan Jones
no flags Details | Diff

  None (edit)
Description Itamar Reis Peixoto 2011-12-16 21:27:12 EST
Description of problem:

paster quickstart store
Do you need authentication and authorization in this project? ([yes]/no): yes

then I receive this error after running paster serve


    [itamar@localhost store]$ paster serve development.ini
    Traceback (most recent call last):
    File "/usr/bin/paster", line 9, in <module>
    load_entry_point('PasteScript==1.7.3', 'console_scripts', 'paster')()
    File "/usr/lib/python2.7/site-packages/paste/script/command.py", line 73, in run
    commands = get_commands()
    File "/usr/lib/python2.7/site-packages/paste/script/command.py", line 115, in get_commands
    plugins = pluginlib.resolve_plugins(plugins)
    File "/usr/lib/python2.7/site-packages/paste/script/pluginlib.py", line 81, in resolve_plugins
    pkg_resources.require(plugin)
    File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 686, in require
    needed = self.resolve(parse_requirements(requirements))
    File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
    pkg_resources.VersionConflict: (repoze.who 1.0.18 (/usr/lib/python2.7/site-packages), Requirement.parse('repoze.who==1.0.19'))




content of requires.txt

TurboGears2 >= 2.1.1
Mako
zope.sqlalchemy >= 0.4
repoze.tm2 >= 1.0a5
sqlalchemy
sqlalchemy-migrate
repoze.what-quickstart
repoze.what >= 1.0.8
repoze.what-quickstart
repoze.who-friendlyform >= 1.0.4
repoze.what-pylons >= 1.0
repoze.what.plugins.sql
repoze.who==1.0.19
tgext.admin >= 0.3.9
tw.forms
Comment 1 Brendan Jones 2012-06-06 05:58:01 EDT
Created attachment 589807 [details]
SPEC file patch

Is it possible to update this package? SPEC patch attached

http://koji.fedoraproject.org/koji/taskinfo?taskID=4132060
Comment 2 Luke Macken 2013-01-11 17:31:01 EST

*** This bug has been marked as a duplicate of bug 759142 ***

Note You need to log in before you can comment on or make changes to this bug.