Bug 76879 - xchat crashes when opening channel list window
xchat crashes when opening channel list window
Status: CLOSED DUPLICATE of bug 77446
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Depends On:
  Show dependency treegraph
Reported: 2002-10-28 12:09 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
list of all installes "freshrpms" (378 bytes, text/plain)
2002-11-13 14:50 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-10-28 12:09:03 EST
From Bugzilla Helper:
User-Agent: Opera/6.1 (UNIX; U)  [en]

Description of problem:
sometimes the crash is complete, and the "application xchat (Process XXXX) has crashed (Segmentation Fault)" gnome window appers, other times the app just stops reponding (unable to focus, no redraws)

Version-Release number of selected component (if applicable):

[nephros@wirligig]:~ > rpm -qi xchat
Name        : xchat                        Relocations: (not relocateable)
Version     : 1.8.10                            Vendor: Red Hat, Inc.
Release     : 8                             Build Date: Sat Aug 24 04:57:58 2002
Install date: Thu Oct  3 23:50:57 2002      Build Host: daffy.perf.redhat.com
Group       : Applications/Internet         Source RPM: xchat-1.8.10-8.src.rpm
Size        : 3183547                          License: GPL
Signature   : DSA/SHA1, Tue Sep  3 23:43:46 2002, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.xchat.org
Summary     : A GTK+ IRC (chat) client.
Description :
X-Chat is a graphical IRC chat client for the X Window System. X-Chat is
fairly easy to use and includes a nice GNOME/GTK+ based user interface.
[nephros@wirligig]:~ >

How reproducible:

Steps to Reproduce:
1. connect to an IRC server
2. click on "Windows" -> "Channel List Window"
3. if Window appears, perform a search, otherwise goto 6.
4. close Window
5. goto 2.
6. app crashes.

Actual Results:  xchat segfaults or stops responding

Expected Results:  well, the channel list window should appear

Additional info:

i am using stock RH8 RPMs from downloaded ISOs plus some from freshrpms.net, but xchat is NOT from freshrpms.

I am using sawmill, and gnome+nautilus.
Comment 1 Mike A. Harris 2002-11-13 03:28:30 EST
What rpms exactly from freshrpms.net?
Comment 2 Need Real Name 2002-11-13 14:50:58 EST
Created attachment 84904 [details]
list of all installes "freshrpms"
Comment 3 Need Real Name 2002-11-13 14:52:19 EST
I attached a file named "freshrpms.list" (which I hope worked), containing the output from:
 rpm -qa | grep fr1 > freshrpms.list
Comment 4 Mike McLean 2003-01-02 12:45:31 EST
This bug has been inappropriately marked MODIFIED. Please review the bug life
cycle information at 

Changing bug status to ASSIGNED.
Comment 5 Mike A. Harris 2003-01-11 06:35:51 EST
I can't reproduce this.  Obviously whatever you're doing that is crashing
xchat, is something specific to your local setup.  It could possibly be
a specific xchat configuration or configuration option perhaps, or it could
be locale perhaps, or some other thing.  I don't think it is specific JUST
to your system however, as I've seen other users report similar things too.

I just am not able to reproduce it yet.  My currently running xchat process
has been running nonstop for about 2 months without a restart, on
irc.freenode.net, internal Red Hat IRC, and 2 other private networks.  I've
generally got about 20-40 tabs open across 3 or more servers at any one given
time, and I look at channel lists quite often, as well as banlist, and various
other popup things.

I'm not sure what to suggest for now.  Could you enable core dumps perhaps,
and get a backtrace from it using gdb?  To do so:

ulimit -c unlimited
xchat &
<make xchat crash>
gdb --core <corefilename>
gdb> bt

The corefilename will be either "core" or "core.nnnn" where nnnn is a number.

Please attach the output of gdb from the bt command.

Also, as noted above, do not set bugs to the MODIFIED state in bugzilla.
MODIFIED means "Developer has fixed this, and requests user to test the fix",
which also means the developer will never look at the bug report again unless
someone sets it to ASSIGNED indicating the fix being tested did not work.
Comment 6 Mike A. Harris 2003-01-11 06:56:31 EST
Son of a *****.  I just reproduced this!

Also, I just discovered there are other bug reports open about this, so
I'm going to close this one as a duplicate.  Please do any follow ups in
the other bug report.  Thanks.
Comment 7 Mike A. Harris 2003-01-11 06:57:23 EST

*** This bug has been marked as a duplicate of 77446 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:50:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.