Bug 77446 - xchat crash when opening channel list window
xchat crash when opening channel list window
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 76879 81622 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-06 23:48 EST by Rob Kearey
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-27 19:51:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xchat crash traceback (2.00 KB, text/plain)
2002-11-06 23:49 EST, Rob Kearey
no flags Details
and another traceback - pranging more often now (2.00 KB, text/plain)
2002-11-07 01:06 EST, Rob Kearey
no flags Details
buttons.conf (195 bytes, text/plain)
2002-11-07 07:45 EST, Rob Kearey
no flags Details
commands.conf (721 bytes, text/plain)
2002-11-07 07:46 EST, Rob Kearey
no flags Details
ctcreply.conf (66 bytes, text/plain)
2002-11-07 07:47 EST, Rob Kearey
no flags Details
digbuttons.conf (129 bytes, text/plain)
2002-11-07 07:50 EST, Rob Kearey
no flags Details
ignore.conf (350 bytes, text/plain)
2002-11-07 07:51 EST, Rob Kearey
no flags Details
keybindings.conf (839 bytes, text/plain)
2002-11-07 07:55 EST, Rob Kearey
no flags Details
pallete.conf (1.12 KB, text/plain)
2002-11-07 07:57 EST, Rob Kearey
no flags Details
pevents.conf (10.39 KB, text/plain)
2002-11-07 07:58 EST, Rob Kearey
no flags Details
popup.conf (1.66 KB, text/plain)
2002-11-07 08:04 EST, Rob Kearey
no flags Details
replace.conf (50 bytes, text/plain)
2002-11-07 08:06 EST, Rob Kearey
no flags Details
serverlist.conf (34.39 KB, text/plain)
2002-11-07 08:08 EST, Rob Kearey
no flags Details
urlhandlers.conf (923 bytes, text/plain)
2002-11-07 08:10 EST, Rob Kearey
no flags Details
usermenu.conf (899 bytes, text/plain)
2002-11-07 08:11 EST, Rob Kearey
no flags Details
xchat.conf (2.98 KB, text/plain)
2002-11-07 08:13 EST, Rob Kearey
no flags Details
/etc/sysconfig/i18n (83 bytes, text/plain)
2002-11-07 08:14 EST, Rob Kearey
no flags Details
fix for regexp xchat-1.8.10 crash with glibc 2.3.x (1.06 KB, patch)
2002-12-27 01:44 EST, Peter Zelezny
no flags Details | Diff

  None (edit)
Description Rob Kearey 2002-11-06 23:48:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; MSIE 6.999; Windows ME)

Description of problem:
Upon opening channel list window, xchat crashes. Cannot reliably reproduce, so
filing bug for reference. Traceback attached.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Run xchat, open lots of tabs
2. Windows->Channel list
3. Prang!
	

Actual Results:  Xchat crashes, dumps core, catches fire, showers white hot
shrapnel.

Expected Results:  Xchat works happily, kittens and puppies play happily, the
sun shines brightly.

Additional info:
Comment 1 Rob Kearey 2002-11-06 23:49:56 EST
Created attachment 83924 [details]
xchat crash traceback
Comment 2 Rob Kearey 2002-11-07 01:06:41 EST
Created attachment 83928 [details]
and another traceback - pranging more often now
Comment 3 Mike A. Harris 2002-11-07 03:01:49 EST
I've got 31 tabs open in xchat right now, and can open the channel list
without any problems.  I require specific step by step instructions
to reliably reproduce this in order to debug it at all.
Comment 4 Rob Kearey 2002-11-07 07:45:07 EST
Created attachment 83984 [details]
buttons.conf
Comment 5 Rob Kearey 2002-11-07 07:46:27 EST
Created attachment 83985 [details]
commands.conf
Comment 6 Rob Kearey 2002-11-07 07:47:31 EST
Created attachment 83986 [details]
ctcreply.conf
Comment 7 Rob Kearey 2002-11-07 07:50:01 EST
Created attachment 83987 [details]
digbuttons.conf
Comment 8 Rob Kearey 2002-11-07 07:51:45 EST
Created attachment 83988 [details]
ignore.conf
Comment 9 Rob Kearey 2002-11-07 07:55:04 EST
Created attachment 83989 [details]
keybindings.conf
Comment 10 Rob Kearey 2002-11-07 07:57:24 EST
Created attachment 83990 [details]
pallete.conf
Comment 11 Rob Kearey 2002-11-07 07:58:15 EST
Created attachment 83991 [details]
pevents.conf
Comment 12 Rob Kearey 2002-11-07 08:04:24 EST
Created attachment 83992 [details]
popup.conf
Comment 13 Rob Kearey 2002-11-07 08:06:19 EST
Created attachment 83993 [details]
replace.conf
Comment 14 Rob Kearey 2002-11-07 08:08:18 EST
Created attachment 83994 [details]
serverlist.conf
Comment 15 Rob Kearey 2002-11-07 08:10:04 EST
Created attachment 83995 [details]
urlhandlers.conf
Comment 16 Rob Kearey 2002-11-07 08:11:42 EST
Created attachment 83996 [details]
usermenu.conf
Comment 17 Rob Kearey 2002-11-07 08:13:14 EST
Created attachment 83997 [details]
xchat.conf
Comment 18 Rob Kearey 2002-11-07 08:14:46 EST
Created attachment 83998 [details]
/etc/sysconfig/i18n
Comment 19 Rob Kearey 2002-11-07 08:16:37 EST
Added configs and i18n file as requested. Please let me know if anything else is
needed.
Comment 20 Mike A. Harris 2002-11-13 03:32:42 EST
Does bug #76879 sound similiar to you?
Comment 21 Rob Kearey 2002-11-13 17:20:54 EST
Pretty much, though I can't seem to reproduce it with such exactitude. I'll do a
further round of testing during lunch.
Comment 22 Peter Zelezny 2002-12-27 01:44:43 EST
Created attachment 88942 [details]
fix for regexp xchat-1.8.10 crash with glibc 2.3.x
Comment 23 Mike A. Harris 2003-01-11 06:57:36 EST
*** Bug 76879 has been marked as a duplicate of this bug. ***
Comment 24 Mike A. Harris 2003-01-11 07:14:36 EST
Thanks for the patch Zed!

I also see you've released xchat 1.8.11.  I think I'll release an erratum
of 1.8.11 for our affected releases.
Comment 25 Rob Kearey 2003-01-15 01:31:53 EST
See, I wasn't telling pork pies :)

I'll try 1.8.11 when it appears.
Comment 26 Mike A. Harris 2003-01-22 17:36:38 EST
robk: 1.8.11 is in rawhide now.  Please test
Comment 27 Mike A. Harris 2003-01-22 19:34:15 EST
*** Bug 81622 has been marked as a duplicate of this bug. ***
Comment 28 Mike A. Harris 2003-01-22 19:38:34 EST
Awaiting testing of fix.  Setting bug state to MODIFIED.

Please set to ASSIGNED if problem recurs, or to RAWHIDE if 1.8.11
resolves the problem for you after testing as per above.

Thanks.
Comment 29 Rob Kearey 2003-01-27 19:51:34 EST
xchat 1.8.11 fixes this problem, yay. Resolving as RAWHIDE as per instructions.

Note You need to log in before you can comment on or make changes to this bug.